The MU forums have moved to

????????? Question marks instead of "Weblog title" (9 posts)

  1. ala101
    Posted 16 years ago #

    I have successfully installed MU on my future blogs network website.
    My MU is for Arab people so it should deal with Arabic well..
    I noticed that when i tried to change "Weblog title" into Arabic words they became "??????????" question marks ..
    And the same problem occur whenever i write a post or a comment in Arabic..

    How can i solve this problem please ?
    notes : my wp-config.php file has the Arabic setup correctly :
    define('WPLANG', 'ar');

    and my .mo language file is in /public_html/wp-includes/languages/

    ( i feel that the reason of the problem is related to DB )

  2. ekusteve
    Posted 16 years ago #

    Are your database tables set to utf8?


  3. ala101
    Posted 16 years ago #

    oh :(
    i just noticed that the Collation for each table is

    How can i fix this problem please ?
    Is it ok if i change it from "Processes" ?
    Or i have to re install MU ?

  4. ekusteve
    Posted 16 years ago #

    I'm not 100% sure, but I believe your MySql database needs to be MySQL 4.1.16 or later in order to support unicode. So first thing is to check your database version.

    I would think that if your database version is recent enough to support unicode, then mu should have created them as utf8...again, I'm not a "database expert", so I may be wrong. I think you will need to convert your tables to utf8 and then if you already have data in your tables, I believe you will need to do some sort of data migration to convert to utf8...again, not sure.

    If this is a new install and you don't mind starting over, then just delete the database and create a new one making sure it is utf8 to start with. Then install mu again and all "should" be well.


  5. ala101
    Posted 16 years ago #

    Ok, MySQL client version: 4.1.22 .
    I will try to convert the DB to utf8..
    As its a fresh install.. if i dont success then i will delete the whole DB and start again !

    Thanks a lot for your fast support.

  6. ala101
    Posted 16 years ago #

    I reinstalled MU after i deleted the DB and altered it to utf8-general..
    and now the title of the main blog appears in weired characters :
    شبكة المدونات الإسلامية

    instead of Arabic!

    Besides, when i tried to login now the following problem appears :
    Warning: Invalid argument supplied for foreach() in /*/wp-includes/capabilities.php on line 31

    Warning: Cannot modify header information - headers already sent by (output started at /*/wp-includes/capabilities.php:31) in

    please help!

  7. ekusteve
    Posted 16 years ago #

    Did you delete everything and start fresh by going through the entire set-up process again?

    And if so, does your site work in the default language?

    If the answer to either of the questions above is "no", I would suggest you do a complete fresh install and make sure it works like is should as a default install. Then, you may be able to isolate this to a language specific the moment, I'm not sure if it is a problem with the install or if it is a problem with the language.

    Just shooting in the dark here...I haven't tried to use different languages in mu, but I know others have it working well.


  8. vinhlg
    Posted 16 years ago #

    Do not install WordPressMu like WordPress, especially do not change wp-config-sample.php to wp-config.php and modify it like you mentioned in your post.

    1. Make sure that you create WordPress database with utf8 and collation utf8_standard_ci. An easy way is using phpmyadmin.
    2. create ..wp-includes/languages directory
    3. Download from
    4. copy it over wp-includes/languages. you will have wp-includes/languages/
    5. Now you can configure your WordPress with arab language in "Options"

  9. ala101
    Posted 16 years ago #

    I deleted all the contents and all the tables in DB, and then started uploading wpmu again.
    This time i didnt modify "wp-config-sample.php"
    and it worked 100% ..
    I thought that i should alter that file to make wpmu appears in Arabic before i install it.. this was the reason of the header errors i guess..

    So after installing successfully i added to languages directory .. same as vinhlg's instructions, and also i added a file called ar.php to the same /languages/ , this file has this code :

    // Arabic

    $text_direction = 'rtl';


    So now all problems are solved but only one small problem remaining which is that "ar.php" is appearing in the Language selection under General Options.
    Is there any way to hide it from there please ?

About this Topic