The MU forums have moved to WordPress.org

WPMU and windows live writer (23 posts)

  1. nunez
    Member
    Posted 15 years ago #

    I am trying to use Windows Live Writer to publish to blogs in a WPMU installation. However I have not been able to publish from WLW to blogs in WPMU. Anyone using WLW with WPMU successfully?

  2. SteveAtty
    Member
    Posted 15 years ago #

    No.. I'm using Blog Desk and it works perfectly - even allows me to pull published posts down, edit them and push them back up.

  3. jshare
    Member
    Posted 15 years ago #

    When I try to connect with WLW, I get: "A successful connection was made to your account however the server reported that you do not currently have an active weblog. Please ensure that your account with this provider is current before proceeding." Of course, I do have an active weblog.

    I get this message when I specify my Weblog Home Page as http://mydomain.com/.

    If I try http://mydomain.com/blog, I get to the next screen where I can specify a WordPress blog.

    But then, for the life of me I can't find the "Remote posting URL" that will allow me to continue, I just keep getting the above "A successful connection..." message.

    I can plainly see that xmlrpc.php is in the root WPMU directory, and I try both "WordPress" WordPress 2.2+" for the type of weblog that I'm using.

  4. enseignement
    Member
    Posted 15 years ago #

    I have no problem at all using WLM.
    If you use subdir, you should specify : http://mydomain.com/myblog/
    (don't forget the / )

    if not, you use : http://blog.mydomain.com/
    And of course, you should use the latest version :
    http://get.live.com/betas/writer_betas

  5. Anonymous
    Unregistered
    Posted 14 years ago #

    Hey! I have the same trouble with my WMPU 2.6 installation. Each blog has an unique url - http://blog.platform.tld/.

    If I fill Weblog Homepage URL in WLR as http://blog.platform.tld/, then WLR shows that damned eroor. But if i fill in http://platform.tld/, then there are no errors at all. What's the problem? XML-RPC publishing is turned on.

  6. cafespain
    Member
    Posted 14 years ago #

    If I recall there was a problem with older versions of MU and the xmlrpc.php file:
    http://mu.wordpress.org/forums/topic.php?id=7494

  7. Anonymous
    Unregistered
    Posted 14 years ago #

    Thanks, but that link didn't help me. I tried dome older versions, but not too old, I wanted not to cause compatibility troubles.

  8. fncll
    Member
    Posted 14 years ago #

    I am experiencing this exact problem since we upgraded to 2.6.x -- never a problem before. I am using the latest livewriter...

  9. fncll
    Member
    Posted 14 years ago #

    I wanted to followup on this because this marked fix in Trac but I do not believe it is fixed.

    I am running WPMU 2.6.1 -- both livewriter and scribefire, which worked fine before the upgrade-- have stopped working.

    Scribefire claims that my username and password are wrong, but they are not. I have seen many other reports of this behavior. I have no problem posting to standalone WP sites.

    Livewriter accepts the server name then asks for the location of xmlrpc.php and, when given, reports: A successful connection was made to your account however the server reported that you do not currently have an active weblog. Please ensure that your account with this provider is current before proceeding. But I do have an active weblog and can post through the dashboard without a problem.

    Clearly this a WPMU and xmlrpc.php issue. I am running with subdirectories, and have no way to test whether the problem still occurs with subdomains... it MIGHT be a problem related only to subdomains.

  10. lunabyte
    Member
    Posted 14 years ago #

    Scribefire works just fine with 2.6.1 for me.

  11. tdjcbe
    Member
    Posted 14 years ago #

    There is an outstanding issue with xmlrpc listed on trac:

    http://trac.mu.wordpress.org/ticket/735

  12. fncll
    Member
    Posted 14 years ago #

    Lunabyte are you using subdomains or subdirectories? I saw the issue on Trac- can't tell if it's the same or not. The one ticket that definitely was the same has been closed with the code now in 2.6.x which adds the wp.getUsersBlogs function. I'm finding people with the same problem all over the web, but still trying to figure out what the commonality might be.

    Things worked like a charm until the upgrade-- this appears to be the only thing (so far) that has broken...

  13. scenario
    Member
    Posted 14 years ago #

    Hi, I have a recently installed version of 2.6.1 using sub-domains, and haven't had success getting scribefire to work. (I am using scribefire with my standalone wordpress blogs.) I've read through various posts on using MU with scribefire and am overloaded with info, but still don't know how to fix the problem. If someone can summarize it, I'd be extremely grateful. Thanks.

  14. andrea_r
    Moderator
    Posted 14 years ago #

    On your main b,log, go to Writing -> Options. Scroll down, check both ticky boxes.
    Go to the sub-blog you're trying to post on. Do the same thing,.
    Now try it again and see if it works.

  15. scenario
    Member
    Posted 14 years ago #

    Thanks for responding so quickly. I went into both the main blog and the separate blog and checked the boxes in settings/writing/options for xml-rpc and atom. Then I tried my scribe-fire setup again. Doesn't work. It does the exact same thing it did before.

    I will isolate the steps because it may be something I am selecting that is causing the problem.

    Attempt #1
    (1) I start by telling scribefire I have a new blog. It asks me for the url for my site. I enter it. No problem. It says it successfully found my blog and to continue onto the next step
    (2) Then it asks me which Blogging Service I want to add. The options are Wordpress.com, TypePad.com, and several others with the last being Custom Blog. I selected Wordpress.com. (Below I describe where I redid this using Custom Blog)
    (3) It asks me for a username and password. I entered the correct ones. I've checked it so I know I'm not mis-entering. Then I hit next.
    (4) It comes back as "Login Error. Check your username and password for errors and try again. Additionally, the server sent back this message: Bad login/pass combination."

    ---------------------------------------
    This is the same thing that was happening before. If I am self-diagnosing, I would assume the problem is the selection of Wordpress.com as the service.
    Assuming this to be the case, I tried Custom Blog. Here are the results.
    ----------------------------------------

    Attempt #2 (same as above only chosing Custom Blog as my service)
    *It gave Wordpress as an option.
    *Then it asked me to add the location for my API URL. I entered it. (Assuming that it is the xmlrpc.php file in my public_html directory.)
    *Next I put in my login and password.
    *Result? "Login Error. Please check your username and password for errors and try again."

    So... I'm right back to where I was, I think.

    Am I doing something wrong? Or what other changes do you suggest?

  16. scenario
    Member
    Posted 14 years ago #

    Anybody?

  17. cafespain
    Member
    Posted 14 years ago #

    What did you put for this?
    *Then it asked me to add the location for my API URL. I entered it. (Assuming that it is the xmlrpc.php file in my public_html directory.)

    You confused me a bit with the mention of public_html.

    It should be something like
    http://myblog.domain.com/xmlrpc.php

  18. scenario
    Member
    Posted 14 years ago #

    The public_html is just meant to show I was looking for the file in the root folder of my domain. This is where Wordpress MU is installed on my site. In other words, I was inputting http://domain.com/xmlrpc.php

    Hmmm... the way you explained this seems to suggest I should use the subdomain name, rather than the main domain address. Was that intentional?

    Should I be using the subdomain addresses or the main domain?

  19. scenario
    Member
    Posted 14 years ago #

    Ahhh... I got it to work. I tried using one of my blog subdomains for the site location. Then I used the main domain for the location of the xmlrpc.php file.

    Then, once scribefire logged in successfully, it pulled up ALL of the blogs I had created in MU (including the main site) and allowed me to add them in one step. Interesting.

    Well... anyway. It is now working. Thanks to andrea and cafespain for the input. :)

  20. montgomerykmc
    Member
    Posted 13 years ago #

    I installed WPMU 2.7beta and try to use Windows Live Writer.
    Not working!!!
    "Successful connection was made to your account however the server reported you do not have active blog....."
    Actually, I have several blogs setup and using it as team blogging.

    Any solution?

    THanks,

  21. nggablog
    Member
    Posted 13 years ago #

    WPMu 2.7 also has a problem with scribefire.
    Error! username and password considered as invalid.

  22. SharkGirl
    Member
    Posted 13 years ago #

    I got Live Writer to work on WPMU 2.7 by going here:

    http://enteryourdomainname/wp-admin/options-writing.php

    Scroll down to the Remote Publishing section.

    Check the box for "XML-RPC"

    Now Live Writer can see your xmlrpc.php page.

  23. SharkGirl
    Member
    Posted 13 years ago #

    When adding a new blog (in WPMU 2.7), for the first time, into Live Writer, I had to deactivate all my plugins, then configure Live Writer.

    I suppose I could have deactivated one plugin at a time until I found the one that blocked WLW from accessing the blog. But, I didn't have that many to work with, so I deactivated all of them to save time.

About this Topic