The MU forums have moved to

Site Wide theme tries to download when executed (22 posts)

  1. Bill007
    Posted 15 years ago #

    Has any one come across this problem every time I try to activate a site wide theme change the wpmu-themes.php tries to execute and then try's to down load as a file and the settings are not stored I have Tried to communicate to my server providers they don't think the problem is their end

    Other execution scripts work fine its just the wpmu-themes.php that tries to download at this stage

    To view the issue the file I am trying to execute is

    try to select a theme and execute it ..!

    will give the log in details so it can be witnessed if need be

  2. Bill007
    Posted 15 years ago #

    Ok some more to add this is the File that tries to download do you think this is a server issue strange how I am not seeing this when executing other edit scripts in the Backend

  3. lunabyte
    Posted 15 years ago #

    And the error logs say.... ?

  4. Bill007
    Posted 15 years ago #

    [Tue Sep 25 07:32:35 2007] [error] [client] File does not exist: /home/freeblog/public_html/wp-admin/updated=themesupdated
    [Tue Sep 25 06:51:49 2007] [error] [client] File does not exist: /home/freeblog/public_html/wp-admin/updated=themesupdated

    it seems there is problem finding this file i thought this is whats getting called to execute the theme change thru the
    which inturn calls the

    the error log is a little differnt how often do you have to ask us idiots for error logs


  5. lunabyte
    Posted 15 years ago #

    "File does not exist: /home/freeblog/public_html/wp-admin/updated=themesupdated"

    Notice the missing file?

    Should be something like wp-admin/filename.php?updated=....

    Any details on the server environment would be helpful too.

    Please see...

  6. Bill007
    Posted 15 years ago #

    Yeah But I notice the log says


    shouldnt it be more like


    so is the coding right the log has come back with same thing all the files are there

    server environment

    Operating system Linux
    Service Status Click to View
    Kernel version 2.6.9-42.0.10.ELsmp
    Machine Type i686
    Apache version 1.3.37 (Unix)
    PERL version 5.8.8
    Path to PERL /usr/bin/perl
    Path to sendmail /usr/sbin/sendmail
    Installed Perl Modules Click to View
    PHP version 4.4.4
    MySQL version 4.1.22-standard
    cPanel Build 11.11.0-RELEASE 16983
    Theme cPanel X v2.6.0

  7. lunabyte
    Posted 15 years ago #

    That link should be:

    Could it be that wpmu-edit or wpmu-themes got corrupted when you uploaded it?

    Unfortunately, across several server environments (including a cPanel one), I can't reproduce the same results that you are experiencing.

    You haven't edited either of those files, have you?

  8. Bill007
    Posted 15 years ago #

    Man you are a busy Boy lunabyte you single handedly holding this forum together

    No I have not touch the script, all though I'm tempted

    Could it it be that version 1.25a is still in beta is there a more stable version that I should be using ..

    Ive still got a ticket with the server folks but it seems the theme side of things is not working at all

    even on a blog by blog basis I cant seem to select a theme

    I have seen this before once where a php files try to download instead of executing and i cant remember what it was php.ini springs to mind But the server folk are still looking into it on that side of things

    I will keep googling as well


  9. lunabyte
    Posted 15 years ago #

    It could be possible that they have some sort of caching enabled (like APC or eaccelerator) that could be causing it. Although the only problems I've seen have been because of kses.php.

    I run APC myself, and it's not causing this issue.

    Try downloading a fresh copy of 1.2.5a (no, it's not a beta, it's the actual release), and then uploading those 2 files. Not a guarantee, but it's something to check.

    If it was actually passing you to "/wp-admin/updated=themesupdated", then you should end up at a 404 page, since that doesn't exist.

    Other than that, without having full control of the box, I'm short on ideas at the moment.

  10. Bill007
    Posted 15 years ago #

    Im Back At it lunabyte

    Thought I would keep you updated so you could see if it works Cant see why not some thing got corrupted along the way I think

    Copied those two files wpmu-edit.php wpmu-theme.php across no go, so I have deleted the entire account off the server and recreated it from scratch

    I have down loaded a fresh copy of wordpress mu 1.2.5a and are currently uploading now thank god there was no real info in that database well just another thing to do I suppose

    anyway Ill post back with My results

  11. lunabyte
    Posted 15 years ago #

    Might be a little on the drastic side, but can't hurt if there wasn't any real data in the db at the moment.

    And your host isn't getting any errors in their logs or anything?

    PHP 4.4.4 is a little low, but shouldn't be a problem. I've got a machine with 4.3.9 on it (for environmental testing, not production) and it runs fine.

    If it were my box, I'd run a tail on the error log, and watch it while I went through those pages.

    Something else you could try, as I step way out on a limb, is turning off mod_rewrite in /wp-admin/ through an htaccess file there.

    Not that it should be having an effect back there, but something goofy is going on there since the file name is being stripped in the log sample you provided above. At the very least, it can't hurt. It would also help down the road when you get some users (if that's your goal) as they tend to paste all kinds of crazy stuff in their posts. (Sometimes causing it to hit the max internal rewrite limit.)

    It isn't MU specifically, so that leaves it to something like encoding, transfer (ftp) issues, something funny during install (server side, for some reason), or the server environment.

  12. Bill007
    Posted 15 years ago #

    Yep that did it is now doing it

    Must have been a cache issue in the server or most Likely a corrupted original download copy of 1.2.5a

    Over and Out for Now

    Thanks lunabyte

    Kind Regards Bill

  13. lunabyte
    Posted 15 years ago #

    You're welcome.

  14. Bill007
    Posted 15 years ago #

    Its Back After about 5 6 theme activations working perferctly and now its not the wpmu-edit.php tries to download arrrgh

    Its got to be the server end

    Ill get them to do some testing

    once I know Ill report back

  15. lunabyte
    Posted 15 years ago #

    Have them check their PHP caching program, and make sure kses.php has been excluded.

    It can cause things like that to happen, as can some other files from various programs.

    It sounds like a probable theory at the moment.

    I had a similar issue with a file that did that. Just the file being loaded, without even calling functions from it, caused random php files to be served up as a download vice being run. It was nuts.

  16. lunabyte
    Posted 15 years ago #

    Oh, while I'm thinking of it, maybe also check the amount of memory in php.ini (it's something your host will have to do) and make sure it's more than 8M. Preferably something like 64M (or higher).

  17. arnonel
    Posted 15 years ago #

    i dont know if this is related but, if i got to and enable my 3 default themes, i get taken to which gives me a 404 error, and the 3 themes i tried to enable dont enable.

    have tried to reupload fresh admin folder, but no luck

    help!! :)

  18. smap
    Posted 15 years ago #

    I'm having the same problem (in FireFox). So far it's seeming that FF is not passing HTTP_REFERER.

    So the line in wpmu-edit.php:

    wp_redirect( add_query_arg( "updated", "themesupdated", $_SERVER[ 'HTTP_REFERER' ] ) );

    is rediretcting me incorrectly.

    Whether this is due to some plug-in I have installed ... not sure yet. Will reply if I figure it out.

  19. smap
    Posted 15 years ago #

    Hmm I'm reading that using HTTP_REFERER is kind of frowned upon in general (and unreliable). I'm thinking I'm going to replace all the HTTP_REFERER instances with REQUEST_URI. Am I off base?

    I have disabled all my FF plugins ... still showing no results for $_SERVER['HTTP_REFERER']. Not sure what's up with that.

  20. Bill007
    Posted 15 years ago #

    Did anyone get this sorted because I have changed server and its still Occurring or not Should I say not occurring that is the theme change script still tring to down load

    Also the spam is incredible Anyone got a fix

  21. mborin
    Posted 15 years ago #

    I have the same problem in my dedicated server. The problem is intermittent. I use WordPress MU and sometimes all my files inside admin try to download if I click on any links. Also the front page of any blog is blank. So I played around and found that kses.php is causing this problem. So to get my site back working I have to re-upload this file to /wp-includes/ directory. It's very strange, kses.php does not get corrupted when this happens. Re-uploding it fixes the problem but only temporarily.

  22. mborin
    Posted 15 years ago #

    I think I found a fix...


    Create a .htaccess file ABOVE public_html

    Have these 2 lines:

    php_flag eaccelerator.enable 0
    php_flag eaccelerator.optimizer 0

About this Topic