The MU forums have moved to WordPress.org

Installation on localhost using XAMPP (6 posts)

  1. pumpkinpatch
    Member
    Posted 14 years ago #

    ok, ok, I know- it's been beaten to death. RT*M and all that. Not for Novices...
    But, will this help? $25 to the one who helps me with complete the installation and get it running on localhost with XAMPP. I am totally lost, and need help desperately. I have spent days reading many of the posts here and in XAMPP forums.
    WPMU installed in c:xampp/htdocs/

    I have it to the point where WPMU is running but subdomains are not visible. They are being created in the database (I mean the domain name is visible in wp_blogs table). Whenever I try to reach a subdomain, I get the "Server Not Found" error.
    I am running Vista and latest version of XAMPP.
    The following was added to httpd.conf (path is correct, ServerRoot "C:/xampp/apache" added at the begining):

    LoadModule rewrite_module modules/mod_rewrite.so

    The following added to httpd-vhosts.conf:
    <VirtualHost *:80>
    ServerAdmin a@localhost
    DocumentRoot "C:/xampp/htdocs"
    ServerName localhost.localdomain
    ServerAlias *.localhost.localdomain
    ErrorLog logs/error.log
    CustomLog logs/access.log common
    </VirtualHost>

    There is a directory directive that needs to go in somewhere with the vhosts, and I tried various places, which didn't help. I am not reproducing all those tests here, but please let me know where it needs to go.
    Also, in Vista, added (right below 127.0.0.1 localhost) in Windows/system32/drivers/etc/hosts:
    127.0.0.1 localhost.localdomain

    I really need the subdomain thing working.

    Somebody please help.
    Thanks a bunch!

  2. lunabyte
    Member
    Posted 14 years ago #

    A local hosts file doesn't like wildcard entries.

    For testing, you have to add each subdomain to the hosts file as well.

    127.0.0.1 test.localhost.localdomain
    127.0.0.1 test2.localhost.localdomain

    Also, make sure you edited the virtual host for Apache (whether in httpd.conf, or one of the added configuration files, included from there) that is for the virtal host you are using. To that file, you need to add the ServerAlias as referenced in the readme.

  3. pumpkinpatch
    Member
    Posted 14 years ago #

    Thanks Lunabyte,
    Adding the subdomain was all I needed to do and it worked.
    Sent you a mail.

    The WPmu README.txt says that I need to add this directory Directive of the Virtual Host (file httpd-vhosts.conf), which I didn't do, but it still works:
    "AllowOverride FileInfo Options"
    I am not sure when and where this will come back to haunt me...

  4. lunabyte
    Member
    Posted 14 years ago #

    Well, on localhost for testing purposes, it probably won't matter "too" much.

    When you push it to a live server, ensure you have those set. It's in the same area that you added the ServerAlias.

  5. pumpkinpatch
    Member
    Posted 14 years ago #

    lunabyte
    I will remember to put that in on the live install.
    I am glad I went with WPmu instead of plain WP. This meets my website requirements rather well!
    Sent the PayPal amount.
    Thanks!

  6. PBO
    Member
    Posted 13 years ago #

    What I did was used WAMP instead of XAMP and followed the intructions here

    http://weblogtoolscollection.com/archives/2007/12/30/install-wordpress-locally-1-of-2/

    and here

    http://weblogtoolscollection.com/archives/2008/01/03/install-wordpress-locally-part-2-of-2/

    (except i used the wordpress MU installation procedures instead of the old wordpress)

    And everytime I make a subdomain blog

    I use lunabyte's instructions

    C:\WINDOWS\system32\drivers\etc

    then add the subdomains like what he said: just like this

    127.0.0.1 localhost
    127.0.0.1 localhost.localdomain
    127.0.0.1 test.localhost.localdomain
    127.0.0.1 test100.localhost.localdomain

About this Topic

  • Started 14 years ago by pumpkinpatch
  • Latest reply from PBO