The MU forums have moved to

virtual hosts stops images! (3 posts)

  1. richardh37
    Posted 18 years ago #

    I've got my host to add virtual hosts and wild card dns with a static IP. I've re-installed wpmu. First i installed with virtual hosts on and when i tried to upload an image it uploaded but all that showed was the image number. when the image was dragged and dropped into a blog it was just a broken image link. I reinstalled with virtual hosts OFF and the images worked fine BUT the main blog was bust.

    any suggestions ?

  2. mistwist
    Posted 18 years ago #

    there is a fix around here somewhere...

  3. zeug
    Posted 18 years ago #

    There are several long threads on the forum about this problem, as in

    Most probably it's htaccess interacting with your server setup on the VHost install. I don't know about the non VHost install as I really like the subdomains for user blogs. With htaccess though it's different problems and solutions for different installs. You could try replacing the two rewrite rules in the top blogs section with:

    RewriteRule ^([_0-9a-zA-Z-]*)/?files/(.*) /wp-inst/wp-content/blogs/$1/files/$2 [L]
    RewriteRule ^([_0-9a-zA-Z-]*)/?wp-content/blogs/(.*)/files/(.*) /wp-inst/wp-content/blogs/$1/files/$3 [L]

    Works for some but didn't for me. Beware caching delays and if it doesn't work you could then rename blogs in wp-content to blogs.php which finally worked for me but not for others, and the developer advises against it.

    Then again, next time you update from the nightly build it might all be fixed/broken again ... or not. We're all pre-alpha bug testers here :)

About this Topic