The MU forums have moved to WordPress.org

rss feed broke, xml parsing error (12 posts)

  1. bschwarting
    Member
    Posted 15 years ago #

    i don't think my rss has ever worked since install of MU.

    getting this error:

    XML Parsing Error: syntax error
    Location: http://domain.com/feed/
    Line Number 1, Column 31:<?xml version="1.0" encoding=""?>

    Ideas where to start?

  2. dsader
    Member
    Posted 15 years ago #

    http://validator.w3.org/feed/

    Look at your source highlighted there.

    Start with a fresh install on a test server.

    Add themes/plugins/hacks until you repeat the error.

  3. bschwarting
    Member
    Posted 15 years ago #

    ok, thanks, it got this error:

    This feed does not validate.
    line 1, column 30: XML parsing error: <unknown>:1:30: XML declaration not well-formed [help]

    # <?xml version="1.0" encoding=""?>

  4. dsader
    Member
    Posted 15 years ago #

    Shouldn't encoding="UTF-8" or anything other than ""?

  5. bschwarting
    Member
    Posted 15 years ago #

    yeah, but the feed-rss2.php file has this:

    <?php echo '<?xml version="1.0" encoding="'.get_option('blog_charset').'"?'.'>'; ?>

    I'm guessing MU gets this encoding option from somewhere else.

  6. dsader
    Member
    Posted 15 years ago #

    Check wp-config.php: should have a define('DB_CHARSET', 'utf8'); in there near the top.

    And

    Dashboard-->Options->Reading set the option near the bottom to UTF-8 as well.

  7. bschwarting
    Member
    Posted 15 years ago #

    hmm, my wp-config.php looks good, but i don't see the option in the dashboard. only options i have under reading is:

    Front Page
    Front page displays:
    Your latest posts
    etc...

    Blog Page
    Show at most:

  8. bschwarting
    Member
    Posted 15 years ago #

    doh! my own hack busted me! i commented that out so users wouldn't change it. i added it back, put UTF-8 in and it works!

    thanks again!

  9. dsader
    Member
    Posted 15 years ago #

    Rather than comment out such fields, add a "disabled" to the input field.
    Such as:
    <td><input name="blog_charset"
    to
    <td><input disabled name="blog_charset"

    You can still see it, but no user editing.

  10. theapparatus
    Member
    Posted 15 years ago #

    An actual link to the feed in question would be helpful so we can see what is occuring. Else all we can do is make guesses.

  11. bschwarting
    Member
    Posted 15 years ago #

    ahh, great idea dsader!

    theapparatus, the site isn't live yet, so i don't want to pass out links just yet.

  12. andrea_r
    Moderator
    Posted 15 years ago #

    @theapparatus - two posts above yours he said he got it working.

About this Topic

  • Started 15 years ago by bschwarting
  • Latest reply from andrea_r