The MU forums have moved to WordPress.org

WordPress MU 1.3RC3 (33 posts)

  1. donncha
    Key Master
    Posted 16 years ago #

    This is the final release candidate before the final release on Monday next. Hopefully there won't be any major changes to this as it's quite stable. No new features or major cleanups are going in until after 1.3 is released on Monday.
    This is revision 1104.

    Download WordPress MU 1.3RC3

    Changes:
    The main blog of the site doesn't have to live at /blog/ if you're using virtual hosts. #409

    WordPress importer can now assign posts to other users. #435
    The importer shouldn't error on the foreach() loop when there's only one author now #405

    Privacy mode of new blog is stored properly. #423

    Various cleanup patches by ktlee and momo360modena.
    momo360modena gave the wpmu-* admin pages a nice facelift!

    XMLRPC posting and the signup page are now disabled by default. They can be activated in the wpmu-options.php page. It is possible to change the xmlrpc setting for a particular blog by editing it via the wpmu-blogs.php page.

    Individual blog's upload quota can be edited on the edit blog page too.

    Developers! get_blog_option() will never return the string "falsevalue" again. It will return the bool value false instead.
    Version numbers look more like WP.org's ones to aid plugin compatibility.

    Misc bug fixes.

  2. suleiman
    Member
    Posted 16 years ago #

    awesome awesome awesome work donncha!

  3. lunabyte
    Member
    Posted 16 years ago #

    Great fixes/additions. Very nice to see these, and the other recent ones as well.

  4. xknown
    Member
    Posted 16 years ago #

    Donncha, take a look to the following bug reports for WP 2.3:

  5. andrewbillits
    Member
    Posted 16 years ago #

    Just tried it and I didn't find any problems :)

    Thanks,
    Andrew

  6. dsader
    Member
    Posted 16 years ago #

    I've created a fresh install, brand new DB, subdirs(no vhost) and the only bug is a show stopper:

    When I go to the SiteAdmin-->Options(wpmu-options.php) and click the Update I get the following error.

    406 Not Acceptable
    
    An appropriate representation of the requested resource /wp-admin/wpmu-edit.php could not be found on this server.
    
    Apache/1.3.39 Server at blabbityblab.org Port 80

    The url is wp-admin/wpmu-edit.php?action=siteoptions and if I reload this url again, every option is deleted and the site becomes inaccessible until I delete the database, delete the wp-config.php rebuild them with a fresh install.

    I have repeated this on a brand new install over and over.(brand new admin, brand new database). I'm stuck. Help.

  7. Konstan
    Member
    Posted 16 years ago #

    Oh god, so much to edit to upgrade :( Will wait until 1.3 final :D

  8. andrewbillits
    Member
    Posted 16 years ago #

    dsader,
    I wasn't able to replicate the error on either of my test sites. I even reinstalled them both to see if it was a fresh install issue.

    I'm not saying that the problem definetely doesn't exist. I'm just saying that I couldn't reproduce it.

    Thanks,
    Andrew

  9. dsader
    Member
    Posted 16 years ago #

    I get the bug here from wpmu-options.php:

    <tr valign="top">
    					<th scope="row"><?php _e('Enable posting by XMLRPC') ?></th>
    					<?php
    					if( !get_site_option('xmlrpc_active') )
    						update_site_option( 'xmlrpc_active', 'no' );
    					?>
    					<td>
    						<input name="xmlrpc_active" type="radio" id="xmlrpc_active1" value='yes' <?php echo get_site_option('xmlrpc_active') == 'yes' ? 'checked="checked"' : ''; ?> /> <?php _e('Yes'); ?><br />
    						<input name="xmlrpc_active" type="radio" id="xmlrpc_active2" value='no' <?php echo get_site_option('xmlrpc_active') == 'no' ? 'checked="checked"' : ''; ?> /> <?php _e('No'); ?><br />
    						<?php _e('This is an advanced technique for making posts to blogs. It is used by <a href="http://codex.wordpress.org/Weblog_Client">blog clients</a> like Ecto, Flock and Microsoft Live Writer and by Flickr to post pictures to blogs. Unfortunately it is also extensively used by spammers. <em>Disabled by Default</em>') ?>
    					</td>
    				</tr>
  10. andrewbillits
    Member
    Posted 16 years ago #

    I take back what I said an hour ago. I still don't get an error but apparently it wiped the site admin box clean because it's empty in the db.

    thanks,
    andrew

  11. lunabyte
    Member
    Posted 16 years ago #

    Ruh roh!

  12. dsader
    Member
    Posted 16 years ago #

    I've been staring at the "no" input radio box for a few minutes and can't explain why it causes all the chaos?

  13. Farms
    Member
    Posted 16 years ago #

    It's been great to see so much fantastic feedback and development work going into 1.3... huge kudos to all of ya working on it, beers await you in Melbourne if you ever make it down here.

  14. dsader
    Member
    Posted 16 years ago #

    Attempting to edit the xmlrpc setting for the main blog under the misc blog actions in SiteAdmin->Blogs->Edit provokes the same error.

    Removing the xmlrpc add_filter in wp-admin/includes/mu.php makes the error go away.

  15. andrewbillits
    Member
    Posted 16 years ago #

      Removing the xmlrpc add_filter in wp-admin/includes/mu.php makes the error go away.

    I can verify that removing the filter does indeed seem to fix the problem. Nice work dsader!

    Thanks,
    Andrew

  16. dsader
    Member
    Posted 16 years ago #

    There is something wrong with the case "siteoptions" in wpmu-edit when updating site option for xmlrpc_active
    update_site_option( "xmlrpc_active", $wpdb->escape( $_POST[ 'xmlrpc_active' ] ) );

    But what?

  17. donncha
    Key Master
    Posted 16 years ago #

    I haven't been able to replicate this yet. PHP's memory limit is set to 256MB but I'll try it with a lower value. What's yours?

  18. donncha
    Key Master
    Posted 16 years ago #

    dsader - are you using memcached or have you enabled WP's internal cache?

  19. donncha
    Key Master
    Posted 16 years ago #

    Are you using mod_security?

  20. dsader
    Member
    Posted 16 years ago #

    Php Mem = 64 MB
    no plugins/cache. Default settings from install built wp-config.
    no mod_security

  21. dsader
    Member
    Posted 16 years ago #

    There must be something with the very name "xmlrpc_active" for a database table(meta_key) in my version of MySQL/PHP is all I can think of at the moment.

    I replace every instance(in every wpmu file) of "xmlrpc_active" with just "rpc_active" this bug vanishes. And all works as expected!

    (I create two separate virgin installs with this the only difference. The rpc_active name works, the xmlrpc_active does not)

    There must be something in my PHP versions or Mysql that doesn't like simply the name of a table to start will xml?(Like a "reserved word" see http://ca.php.net/manual/en/ref.xmlrpc.php "xmlrpc_" is popular)

    One server on shared host has MySQL 4.1.22-standard and PHP 5.0.5.
    The other also has MySQL 4.1.22-standard but PHP 5.2.1. But treat the bug and workaround the same way.

    So, could it be MySQL/PHP refusing to Post/update/get to a xml-type named table(meta_key) in the db?

    andrewbillits, can you verify this workaround?

  22. andrewbillits
    Member
    Posted 16 years ago #

    I restored the site options that got cleared from a backup and I actually haven't had any problems since. Apparently it was a one time thing.

    Thanks,
    Andrew

  23. xknown
    Member
    Posted 16 years ago #

    dsader, it seems your host refuses any request that contains "xmlrpc":
    http://iblog.stjschool.org/?s=xmlrpc
    http://iblog.stjschool.org/?xmlrpc

    IMHO, it's a web server configuration (or a plugin) rather than MySQL.

  24. dsader
    Member
    Posted 16 years ago #

    Thanks, xknown. Hadn't tried that. I'll investigate further. Yeah, it borks on every domain, on every piece of software, worpress or not.

    A reply from my host:

    "It looks like our modsecurity apache module was being a bit too strict. I've disabled this for your account, so it should work now. You may need to clear your cache before this takes effect."

  25. dsader
    Member
    Posted 16 years ago #

    Viewing images after uploading in the post form provokes the following:
    Fatal error: Call to undefined function apply_filters() in /.../wp-includes/functions.php on line 1065

    http://mu.wordpress.org/forums/topic.php?id=6578&page&replies=1

  26. donncha
    Key Master
    Posted 16 years ago #

  27. tom81
    Member
    Posted 16 years ago #

    >> Viewing images after uploading in the post form provokes the
    >> following:
    >> Fatal error: Call to undefined function apply_filters() in
    >> /.../wp-includes/functions.php on line 1065

    http://trac.mu.wordpress.org/changeset/1116

  28. Ovidiu
    Member
    Posted 16 years ago #

    I seem to have some problems with theme activating, maybe someone could test this:

    I upload a theme, don't activate it, go to site admin => blogs, click on edit my main blog, and on the right side, where it says blog themes, I should be able to enable the uploadeed, not activated theme just for this blog, right?

    well I check the uploaded theme, save, it says "options saved", reloads the page, but the theme is still unchecked and I can't select it from the themes menu.

    I am working on a clean 1.3RC3 install, please confirm or check with your install.

  29. bloggsbe
    Member
    Posted 16 years ago #

    I tried the same, uploaded a theme, enabled it for just one blog - and it worked fine. The themes shows up on that users theme page, but not anywhere else.

    I'm doing this on 1.3RC3 (upgraded from 1.2.1).

  30. dsader
    Member
    Posted 16 years ago #

    Ovidiu, I'm using a very recent zip from trac downloaded today ("rev 1137") and no flaws to theme activation from blog edit menu. Individual theme activation works as it should.

About this Topic