The MU forums have moved to

WPMU Install: "Undefined index: action in /...../index.php" (2 posts)

  1. chuckm
    Posted 18 years ago #

    Using the latest (27 Nov 2005) unstable release, I can't get past the second stage of WPMU installation. Here are some data points gathered as I went through each step:

    - I have a working installation of WordPress (non-MU) which uses its own separate database, installation directory, and URL path, so there should be no conflicts. That installation went without a hitch.

    - Apache is correctly configured with wildcard virtual hosts, as is my DNS entry.

    - File permissions are correct - Apache can read/write everything.

    - Apache is configured with index.php as a default index page.

    - FollowSymLinks and "AllowOverride All" are set. (Same behavior if I use "AllowOverride FileInfo")

    - The MySQL database is correctly created and permissions set.

    Here is what happens:

    - using http://this.domain/path/to/my_wpmu/ the installation page starts ok. I set Virtual Server Support to "Yes" and fill in the database information. Table Prefix is set to "wpmu_" just in case, although it does have its own independent database to begin with.

    - When I submit this form there is an Apache errorlog entry which states: "PHP Notice: Undefined index: action in /path/to/my_wpmu/index.php on line 455". Line 455 is a "switch" statement but I don't know which case to examine. The next-step page is displayed in spite of the error.

    - I then fill in a blog name and email address and submit the form. The database tables are created. No email is sent (and there is no entry in the email server log). There are no further error messages in the Apache log.

    - I notice that no .htaccess file is created from the template, but the wp-config.php and wpmu-settings.php files seem to be correctly created.

    - New or modified items in the wp-content directory seem to be created ok, judging by the timestamps.

    I am using my own 'LAMP' web server, so there are no issues usually associated with remote ISPs. The non-MU version of WordPress works fine on this server.

    I'm baffled, and unfortunately I'm not much more than a newbie at PHP, so there's probably something obvious going on that I'm missing. Can anyone shed some light on this problem??

    Many thanks!

  2. fredl
    Posted 18 years ago #

    Hi chuck,
    i've the same problem, i've migrate from an hosting service to another. the 5 minutes install became 4 days.
    Help needed

About this Topic