The MU forums have moved to WordPress.org

Upgrade messed up with content (18 posts)

  1. kishorebudha
    Member
    Posted 15 years ago #

    My upgrade from 1.2.4 to 1.3 has messed up the content on all the blogs. Žižek has turned into Žižek. Other examples include "a cinema-véritésque film", industry's has turned into industry’s. All unicode Hindi text has changed. How do I make it right. I have the database backed up.

  2. qza
    Member
    Posted 15 years ago #

    In "wp-config.php" file, there is line which says something like "DB_CHARSET(utf-8)". Delete "utf-8" here. Also make sure DB_COLLATE() option is blank. Now try reading the blog again.

  3. kishorebudha
    Member
    Posted 15 years ago #

    Both DB_CHARSET(utf-8) and DB-COLLATE() are not there in wp-config.php file.

  4. theapparatus
    Member
    Posted 15 years ago #

    They should be. Take a look at the included example wp-config.php for reference:

    http://trac.mu.wordpress.org/browser/trunk/wp-config-sample.php

    Sounds like the site wasn't utf-8 to begin with and it's now trying to run as UTF-8.

  5. qza
    Member
    Posted 15 years ago #

    In my case, first upgrade messed my unicode texts. Then I made above changes to the wp-config.php file and restored from backup. And last, I upgraded my site and everything is OK now.

  6. kishorebudha
    Member
    Posted 15 years ago #

    I had not updated my WP-config file to the new ones and contrary to your experience, adding the utf-8 line actually sorted out the problem.

  7. qza
    Member
    Posted 15 years ago #

    Then you're lucky :) I have to try adding utf-8 options again sometime.

  8. djsteve
    Member
    Posted 15 years ago #

    I am having similar issues. I had an MU install that did not get the previous update, so I did this 1.3 update and now I have the funny symbols in several blogs too. (Â )

    I had uploaded all files and did not overwrite the wp-config. Did the upgrade button in admin and then had the symbols. After reading this thread I renamed the original config file to -old and then used the new config file that unpacked with 1.3. I changed the /base issue and it seemed to work, symbols still there.

    So I used my backup database and redid the upgrade script with the newer config file in place, and I still get the symbols. I tried going back to the old wp-config file and they still show up.

    Any way to search and replace for these symbols across all blogs?

    Is there anything about this issue in the readme (which I admittedly skipped since I backed up).

    Should I have not kept the old config or sued the new one?

  9. kishorebudha
    Member
    Posted 15 years ago #

    I think you use the new config file. The original config file has the following

    DB_CHARSET(utf8)

    I changed it to DB_CHARSET(utf-8)

    Can you confirm you have tried the same.

  10. djsteve
    Member
    Posted 15 years ago #

    Actually my origianl wp-config didn't have any CHARSET in it.. not sure which version of MU I originally started with, but there is none of that in it.

    Also noticed my original has some vhost thing set to yes that I don't think the new one has in it... Now wondering if there is some other issue I may have missed that a fresh install would've created within the config file.. since it's an upgrade perhaps there is more changes needed in config...

  11. djsteve
    Member
    Posted 15 years ago #

    Any chance we could get some info about this issue in the readme for future upgrade... I still have tons of posts that have messed up symbols.. going post to post to fix them is one thing.. having to do this again in the future makes my heart sink.. Had similar problems using fantistico upgrading wordpress on other blogs too.. if there is any way to avoid this / fix this it would be awesome!

    perhaps a plugin that would search and replace the unusual quotes and stuff that shows this issue would be an option? More info before upgrade would be helpful..

  12. jimgroom
    Member
    Posted 14 years ago #

    Hey all,

    I followed the adive here and changed the ostensible typo UTF8 to UTF-8. It fixed all my encoding issues, but I just realized that it is now preventing me from creating any new blogs that will resolve properly.

    I changed the character set back to UTF8, and I can now create new blogs, but I noticed a few character encoding anomalies as soon as I did this. Anyone work though this issue in an effective manner so that we don't have to use a character set that seems like a typo not go back through a WPMu environment and root out bad encoding?

    This thread, for me, is related to this one here http://mu.wordpress.org/forums/topic.php?id=6758&page&replies=7#post-46835

  13. tdjcbe
    Member
    Posted 14 years ago #

    Please don't cross post like that. All you do is waste the time of the volunteers trying to help out here. You don't go up to someone in real life and repeat yourself like that, do you?

    You can't just change a charset by flipping a switch. You need to convert the database from one format to the new one. A quick google search will show you a number of methods and scripts that will help you do that.

  14. jimgroom
    Member
    Posted 14 years ago #

    @tdjcbe.

    Thanks for the advice. Sorry for cross-posting, I just thought I was link a relationship between two threads, in the future I will just include the link and refrain from putting my issue in twice.

    Best

  15. tdjcbe
    Member
    Posted 14 years ago #

    Cool and thanks.

    Were you able to find a method of converting your database? That's the important thing.

  16. JCBiggar1
    Member
    Posted 14 years ago #

    THANKS ALOT!!! I updated my website http://www.SensationalSerpents.com, and it put all this weird code in the content. This Forum helped me fix it. Thanks!

  17. suleiman
    Member
    Posted 14 years ago #

    way to spamalot. not even an mu site?

    How do I apply to become an admin around here?

  18. JCBiggar1
    Member
    Posted 14 years ago #

    Sorry Here's the Url http://www.SensationalSerpents.com , by the way the wp-config.php, looks something like this:

    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    define('DB_CHARSET', 'utf8');

    define('DB_COLLATE', '');

    You can either delete the utf8 in the charset or replace it with utf-8.

About this Topic

  • Started 15 years ago by kishorebudha
  • Latest reply from JCBiggar1