The MU forums have moved to WordPress.org

Help with WP database error please (2 posts)

  1. kgs03
    Member
    Posted 16 years ago #

    Using fantastico, I upgraded my 4 WP blogs from 2.2 to 2.3 without apparent problem. However, in each blog, I now consistently have error messages when in the "Write" screen and when I click on "save and continue" or "publish". While the error message differs a bit between the two buttons, when I log back into my blog, the post is there and it appears it will be published on the date requested.

    Details of one of the error messages is as follows:
    WordPress database error: [Table 'ksinrcom_wrdp3.wp_post2cat' doesn't exist]
    SELECT c.cat_name FROM wp_post2cat p2c INNER JOIN wp_categories c ON p2c.category_id = c.cat_id WHERE p2c.post_id = 286

    WordPress database error: [Table 'ksinrcom_wrdp3.wp_post2cat' doesn't exist]
    SELECT cat_ID AS ID, MAX(post_modified) AS last_mod FROM wp_posts p LEFT JOIN wp_post2cat pc ON p.ID = pc.post_id LEFT JOIN wp_categories c ON pc.category_id = c.cat_ID WHERE post_status = 'publish' GROUP BY cat_ID

    WordPress database error: [Table 'ksinrcom_wrdp3.wp_post2cat' doesn't exist]
    SELECT c.cat_name FROM wp_post2cat p2c INNER JOIN wp_categories c ON p2c.category_id = c.cat_id WHERE p2c.post_id = 286

    WordPress database error: [Table 'ksinrcom_wrdp3.wp_post2cat' doesn't exist]
    SELECT c.cat_name FROM wp_post2cat p2c INNER JOIN wp_categories c ON p2c.category_id = c.cat_id WHERE p2c.post_id = 286

    Warning: Cannot modify header information - headers already sent by (output started at /home/ksinrcom/public_html/my-personal-growth/wp-includes/wp-db.php:160) in /home/ksinrcom/public_html/my-personal-growth/wp-includes/pluggable.php on line 391

    Please advise whether further information is needed to assist with a response.

    Thanks in advance,
    Kevin.

  2. theapparatus
    Member
    Posted 16 years ago #

    There's a sticky on the wp forums that covers this. The one about 2.3 upgrades. (ie your theme is hardcoded and needs to be upgraded or edited.)

About this Topic

  • Started 16 years ago by kgs03
  • Latest reply from theapparatus