The MU forums have moved to WordPress.org

Upgrade to WPMU 1.3 and now I cannot add blogs (24 posts)

  1. esteban27
    Member
    Posted 14 years ago #

    I have upgrade to 1.3 and now after adding a new blog to the site I always get the following message

    Not Found
    The requested URL /wp-admin/install.php was not found on this server.

    And the url it tries to navigate to is http://myblog.example.tk/wp-admin/install.php

    I have tried to serach for that fiel in the install and it's not there (I just doenloaded an unzipped, and I cannot find that file).

    Can anyone help? Thanks.

    E

  2. ruigato
    Member
    Posted 14 years ago #

    samething here..

    Is there a solution for this?

  3. andrea_r
    Moderator
    Posted 14 years ago #

    Did you click the upgrade button in the backend under Site Admin?
    How big of an upgrade jump did you do? Some stuff was moved around.

  4. ruigato
    Member
    Posted 14 years ago #

    Yes i upgraded from a svn version 1.2.4 i think. I installed the http://mu.wordpress.org/download/ version, should i get one more recent from the trac?

    I have only about 10 blogs.

    Here what hapens:
    1- in wp-admin/wpmu-blogs.php i enter a adress/ title/ admin mail

    2- in wpmu-blogs.php?updated=true&action=add-blog i get a sucess message. Blog aded

    3-if i try to visit or acess the backend of the new blog i get a 404 page (/wp-admin/install.php)

    the existing blogs seem to work fine

  5. andrea_r
    Moderator
    Posted 14 years ago #

    When you upgraded, did you wipe out the old files and replace with the new ones, or just overwrite with ftp?

  6. ruigato
    Member
    Posted 14 years ago #

    I deleted the files and uploaded the new one. Exept blogs.dir htaccess and wp-config i think

    should i update from the latest svn?

  7. andrea_r
    Moderator
    Posted 14 years ago #

    Worth a try at this point.

  8. ruigato
    Member
    Posted 14 years ago #

    Replaced all with the latest 1164rev trough ftp, still the same..

    Maybe some chmod thing? i just noticed the new directory wasnt created in blogs.dir is there some specific directory permissions?

    i also noticed that my wp-config has dont has this new lines:

    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');
    define('VHOST', 'VHOSTSETTING');
    $base = 'BASE';

  9. ruigato
    Member
    Posted 14 years ago #

    what about database updates? i think i upgraded from 1.2.4 to 1.3 skiping 1.2.5 will this could afect the script?

    Have i got some kind of radical solution like install everithing again and import contant/database data?

  10. lhurey
    Member
    Posted 14 years ago #

    same thing here..i have downloaded the latest version but after i click the upgrade button i can not add blog using the signup page and in the admin panel still i can not add a blog...

    what should i do?

  11. andrea_r
    Moderator
    Posted 14 years ago #

    @ ruigato
    "define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');
    define('VHOST', 'VHOSTSETTING');
    $base = 'BASE';"

    Are you *sure* this is what's in wp-config.php? because it's not correct. that's what it in the wp-config-sample.php.

    Imprting your db into a fresh install may fix it, may cause more problems. I really don't know. The only thing I woudl do is make a backup of everything (so I can restore the whole site if I need to), and then try it.

  12. ruigato
    Member
    Posted 14 years ago #

    @ ruigato
    "define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');
    define('VHOST', 'VHOSTSETTING');
    $base = 'BASE';"

    i noticed this variables are not in my wp-config.php

    If i backup an then delete everithing and make a fresh install how can i import the existing blogs again? is it simple?

  13. andrea_r
    Moderator
    Posted 14 years ago #

    Go into phpmyadmin and click the "import" tab and import the backed-up database.

    Like I said above, I'm not sure that would fix it. The other thing I would do is make sure the fresh install works before I did anything else.

    And backup. You backed up right?

  14. ruigato
    Member
    Posted 14 years ago #

    i have a backup but it has several days, i would rather have 1.3 working..

  15. Iron
    Member
    Posted 14 years ago #

    Get two blog id, one for a new blog that do not work and another for an existent blog that works

    Excute this with phpmyadmin, repleace # by id

    SELECT option_value FROM wp_#_options WHERE option_name = 'db_version'

    Is it the same value ?

  16. julen
    Member
    Posted 14 years ago #

    For me 'db_version' is the same (always 6124). Somebody knows how to solve this problem? :S

  17. lunabyte
    Member
    Posted 14 years ago #

    I wonder if on upgrade, it doesn't maybe set that value for the entire table when it does the first upgrade on a site, so it never runs for the others?

    Not that I've looked into the actual file(s) yet, but that would seem a logical possibility with the information from this thread and the post right above.

    If the db version matches what the upgrade is looking for, it won't execute as it thinks it's on the most current db version.

  18. theapparatus
    Member
    Posted 14 years ago #

    If that is so, open up the wp-includes/version.php, bump up the db number by one, and run the upgrade script again.

  19. ruigato
    Member
    Posted 14 years ago #

    "If that is so, open up the wp-includes/version.php, bump up the db number by one, and run the upgrade script again."

    sorry.. didnt quite understand the "bump up"
    i currently have this in the version.php

    // This holds the version number in a separate file so we can bump it without cluttering the SVN

    $wp_version = '2.3.1';
    $wpmu_version = '1.3';
    $wp_db_version = 6124;

    i am running 1.3 should i decrease this db value and run the upgrade again?

  20. lunabyte
    Member
    Posted 14 years ago #

    No, make it 6125 in that file. Then it should run the upgrade.

    The bad thing, is that if the code actually does have a bug (and sets the database version across the entire table or something), then it won't do any good and you'll be in the same spot as you are now.

  21. ruigato
    Member
    Posted 14 years ago #

    "No, make it 6125 in that file. Then it should run the upgrade."

    it upgrade with no errors but it is the same..

    i am starting to desperate for a solution..

  22. ruigato
    Member
    Posted 14 years ago #

    in the email i receive:

    New Blog:
    URL:
    Remote IP: 85.243.174.xxx

    Disable these notifications: http://aroucaonline.com/blogs/wp-admin/wpmu-options.php

    the blog name and url are empty..

  23. dgilmour
    Member
    Posted 13 years ago #

    I got these symptoms following upgrade 1.2.5a to 1.3.3.

    Â (capital A with circumflex) characters were appearing at random places in blog posts. In forum post "Upgrade messed up with content" kishorebudha suggested changing the database character set setting:

    I think you use the new config file. The original config file has the following
    DB_CHARSET(utf8)
    I changed it to DB_CHARSET(utf-8)
    Can you confirm you have tried the same.

    That fixed the display of spurious characters, and I had left it like that, but it was causing this problem.

    I've now changed it to latin1, having found that is the default character set for my database. I can now access new blogs, and do not have spurious characters displaying.

    mysql> show create database wordpress;
    gives
    CREATE DATABASE wordpress /*!40100 DEFAULT CHARACTER SET latin1 */

    Now thinking about whether I should be planning to change that to utf8, to keep things standard...

  24. chrisdoth
    Member
    Posted 13 years ago #

    Same problem after upgrade. Anything other than UTF8 means I can't register new blogs however if I have that all my old blogs display incorectly.

About this Topic

  • Started 14 years ago by esteban27
  • Latest reply from chrisdoth