The MU forums have moved to WordPress.org

Site Wide feed not including tags? (4 posts)

  1. dbasulto
    Member
    Posted 15 years ago #

    I´m using the sitewide feed by IT Damager, but it doesn´t seem to be under development, because it works fine.

    The thing is that under WPMU 1.3 it works fine, but it doesn´t add the tags as categories, as the regular per blog feed does. This is odd, because it uses the_category_rss function to get the categories, same as the regular feed output which does include the tags as categories.

    I really don´t understand why this is happening, since it´s the same function afaik....

    any ideas?

  2. andrea_r
    Moderator
    Posted 15 years ago #

    Nope, it's not. In the new WP 1.4, the tags *are* different and would need to be added. They are even in their own db tables and everything.

    Just to make it confusing, tags =/= categories.

  3. dbasulto
    Member
    Posted 14 years ago #

    But tags are showing up on the_category_rss function. So, if you use each blog´s feed, tags show up on the category field for the rss.

    The weird thing is that the same function (the_category_rss is used by the sitewidefeed (it switches to each latest post to output it on rss format) but it doesn´t output the tags.

    If you take a look at the_category_rss function on feed.php on wp-includes, it shows how it gets the tags from the new taxonomy.

  4. theapparatus
    Member
    Posted 14 years ago #

    Maybe dropping ITD an email and politely pointing that out to him would be a good idea. He might not be aware of it.

About this Topic

  • Started 15 years ago by dbasulto
  • Latest reply from theapparatus