The MU forums have moved to WordPress.org

Supercache line change for wpmu (8 posts)

  1. stevejbayer
    Member
    Posted 14 years ago #

    If you do use supercache (0.5.1) with wpmu and transfer the wp-cache.php file into the mu-plugins folder, ya need to adjust the following line in wp-cache.php in the mu-plugins folder.

    $wp_cache_config_file = ABSPATH . 'wp-content/wp-cache-config.php';

    into

    $wp_cache_config_file = ABSPATH . 'mu-plugins/wp-cache-config.php';

    bascially just swap out wp-content into mu-plugins

  2. theapparatus
    Member
    Posted 14 years ago #


  3. Farms
    Member
    Posted 14 years ago #

    Actually, doesn't it create wp-content/wp-cache-config.php automatically?

    Just temporarily 777-ing wp-content should allow that to happen.

  4. lunabyte
    Member
    Posted 14 years ago #

    Well, you should know Mr. Big MU tester. ;-)

    How's it working out over on your site, James?

    Better/easier than the original wp-cache?

  5. Farms
    Member
    Posted 14 years ago #

    Heh... I'm in with tha big bhoys y'know ;)

    We've had some issues on edublogs as it's running on a cluster (which this isn't configured for) but for every other MU (and regular WP) build it rocks out and being easily deployed for WPMU (rather than wp-cache which'll take you an hour min) it wins hands down.

  6. stevejbayer
    Member
    Posted 14 years ago #

    Well it does create wp-content/wp-cache-config.php automatically but I had (well still have) some bugs so needed to rule out if supercache was the cause so I disabled and delete supercache, the bugs were still there so I ruled out supercache's involvement.

    I re-uploaded and re-enabled supercache and had a few errors and found out I needed to adjust the needed line even though WP-Content was chmoded as 777. Well mod_rewrite on my shared hosting isn't being detected (WP detects it just fine) by WPMU so supercahce doesn't work but the module does make it easy for me to have atlast WP-Cache running.

  7. andrea_r
    Moderator
    Posted 14 years ago #

    If you're on shared, that's probably why you're having so many issues, sorry to say.

  8. theapparatus
    Member
    Posted 14 years ago #

    the bugs were still there so I ruled out supercache's involvement.

    Maybe passing them along to Donncha would be a good idea instead of keeping them to yourself. Also make sure that you tried the latest 5.1 version as it's been updated a number of times since release.

About this Topic

  • Started 14 years ago by stevejbayer
  • Latest reply from theapparatus