The MU forums have moved to WordPress.org

Member Blog Creation errors (9 posts)

  1. stevejbayer
    Member
    Posted 14 years ago #

    Hi, my wpmu site can register user namess fine but registering for a blog creates errors. I had an earlier post on the same error but I think it was not related to the original posters issue.

    My blog is supposed to create subdomains as membername.domain.com instead its been creating mydomain.comBASEmembername/ instead

    Here's whats in my htaccess http://pastebin.org/11032

    I'm using supercache as well

    Help would be much appreciated.

    The site itself is http://angloindianblogs.com

  2. andrea_r
    Moderator
    Posted 14 years ago #

    Usually that means BASE is stuff in the htacces file somewhere where it shouldn't be, but I didn't see it.

    Run a search on your database and see if it's stuck in a field somewhere.

  3. stevejbayer
    Member
    Posted 14 years ago #

    Thanks for the tip, nothing really seems out of place in the database though.

  4. stevejbayer
    Member
    Posted 14 years ago #

    It hasn't been fixed but I probably backspaced or deleted (when configuring a plugin) the $ from $base in one of the files used to register new blog addresses with the sub domain structure.

  5. theapparatus
    Member
    Posted 14 years ago #

    OK, I just noticed something here and you note it in your post up there. During signup, the system first tells me you're running a subdomain install and then the system tells me it's subdirectories.

    Please check your wp-config.php file and see what vhosts is set to. It should also be set within your sitemeta table. What does it display?

  6. stevejbayer
    Member
    Posted 14 years ago #

    K didn't mean to triple post but while looking at http://mu.wordpress.org/forums/topic.php?id=6899&page&replies=22 I do remember clicking on upgrade in site admin and the errors probably started from there I did swap out the original wp-config.php thinking replacing it with wp-config-sample.php and renaming it to wp-config.php would help. Well atleast its only my first install of wpmu, I don't have a backup if my database though.

    Changing line 12 in the wp-config.php
    from
    $base = 'BASE';
    $base = '/';

    allows me to use subdirectories but not subdomains yet.

    I'll install WPMU on another domain and check how wp-config.php oughta look like for subdomains.

  7. stevejbayer
    Member
    Posted 14 years ago #

    http://pastebin.org/11197 is whats in my wp-config right now with sub directories working even though i initially set it to subdomains and initial blogs did get created as subdomains

    I'm relatively new to setting up CMS's and haven't done much database related work. Not sure what a sitemeta table is, I'll look it up though.

  8. stevejbayer
    Member
    Posted 14 years ago #

    Thanks for the help everyone, It was just 2 lines that needed to be changed (apart from replacing .htaccess with htaccess.dist which I had done previously and changing RewriteBase /BASE to RewriteBase / in the newer .htacess to reduce the initial domain.tldbasemembername errors into just mydomain.comBASEmembername/)

    The lines in wp-config.php that did not work when I initially panicked a bit and replaced wp-config.php with a renamed wp-config-sample.php are:

    define('VHOST', 'VHOSTSETTING');
    $base = 'BASE';

    Thanks to apparatus for pointing out VHOST settings. The correct amended lines in wp-config.php are

    define('VHOST', 'yes');
    $base = '/';

    Clicking on upgrade option in site admin was most likely the culprit (Being new to WPMU, I'm glad I caught it before I brought in a co-admin. I now know to warn co-admins about clicking on the upgrade button. I guess the upgrade screen needs a warning about upgrading when not necessary.)

  9. theapparatus
    Member
    Posted 14 years ago #

    Strange as the install should have set those up for you. Glad you got it working though.

    I run upgrade everytime I upgrade anyway and suggest my site admins that i host to announce it. Makes it look like they're actually doing something. ;)

About this Topic

  • Started 14 years ago by stevejbayer
  • Latest reply from theapparatus