The MU forums have moved to WordPress.org

403 Access forbidden error after installation (12 posts)

  1. ahmsme
    Member
    Posted 16 years ago #

    Hi all,

    I followed the instruction step by step, after I finished and getting the congratulation page. The congratulation page gave me admin uid and pwd ans link to log-in. When I try to log-in I got the 403 Access forbidden error. I navigated the whole forum for such solution but could not find any.

    **Hereunder my VHost settings

    <VirtualHost 192.168.XXX.XXX>
    DocumentRoot /srv/www/htdocs/blog
    ServerName ourdomain.com
    ServerAlias *.ourdomain.com
    ServerAdmin myname@ourdomain.com
    <Directory /srv/www/htdocs/WPMU>
    AllowOverride FileInfo Options
    Order allow,deny
    Allow from all
    </Directory>
    </VirtualHost>

    ** My .htaccess content

    RewriteEngine On
    RewriteBase BASE/

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    php_flag register_globals 0
    php_flag display_errors 0

    ------------------------------
    I have a dedicated IP for the WPMU and created a virtual directory as shown. I chmod the .htaccess to 666 as suggested by some posts in this form.

    Please help.
    I have other PHP-MySQL installations which work perfectly like wikimedia, phpmyadmin and sugar crm

  2. andrea_r
    Moderator
    Posted 16 years ago #

    Check the permissions on the files in the index folder, as well as the folder permissions.

  3. magidu
    Member
    Posted 16 years ago #

    I have the same error.
    What should we do?

    regards,

    magi

  4. ahmsme
    Member
    Posted 16 years ago #

    What should be the permissions in the root folder?

    I deleted the .htaccess and it is working fine while it is able to create bog.mydmoani.com blog addresses. The problem is I do not know what are the other impact on what I did !!!

  5. ahmsme
    Member
    Posted 16 years ago #

    unfortunately, now any virtual sub-directory is not working. Any help?

  6. andrea_r
    Moderator
    Posted 16 years ago #

    Read the readme.txt, make sure you follow all the steps. You *need* an htaccess file for it all to work properly.

  7. ahmsme
    Member
    Posted 16 years ago #

    I got the following error lines from Apache log file:

    Options FollowSymlinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /srv/www/htdocs/blog

    Any advice now?

  8. ahmsme
    Member
    Posted 16 years ago #

    I solve it.....

    I added the following line to the Direcotry directive

    Options +FollowSymLinks

    Thanks for anyone who tried to help

  9. magidu
    Member
    Posted 16 years ago #

    Dear all,

    I have still my error. I can register on my site.. but.. when i visits the http://www.domain.com/username.

    i got the

    Forbidden
    You do not have permission to access this document.

    Here is my Apache Setting.

    <VirtialHost *>
    ServwerAdmin webmaster@localhost

    DocumentRoot /var/www
    <Directory />
    Options FollowSymLinks
    AllowOvverride FileInfo Options
    </directory />

    <Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
    AllowOverride All
    Options+ ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    </Directory>

    regards,

    magi

  10. theapparatus
    Member
    Posted 16 years ago #

    Reading the readme file and looking at the suggestions made in the debugging script would be a start. (ie provide a link, check the error logs for the specific error, not copying code unless asked for, etc.)

  11. Anjelina
    Member
    Posted 15 years ago #

    I had the same problem with 403 Access forbidden error:
    Forbidden
    You do not have permission to access this document.

    However, I found an easy fix - I just added to .htaccess:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    DirectoryIndex index.php

    It all works now.
    Hope that helps.
    Regards,
    Anjelina

  12. Azznonimous
    Member
    Posted 15 years ago #

    Just to say that the ahmsme solution of adding "Options +FollowSymLinks" worked for me.

    Thanks all!

About this Topic

  • Started 16 years ago by ahmsme
  • Latest reply from Azznonimous