The MU forums have moved to WordPress.org

Stuck in an Installation Loop (12 posts)

  1. jonimueller
    Member
    Posted 16 years ago #

    This will be my third WPMU install; the other two went fairly well. So I believe I have the procedure down pat.

    When I first go to my site url to start the install, everything goes smoothly. WPMU asks for the database information, I give it what it wants, it proceeds to allow me to give the weblog a title and enter my email information.

    I even get the welcoming email and login information. Yet, when I click on the link in the email to login (http://mysite.com/wp-login.php), I get a Page Not Found. When I go to my site url, I'm presented with the installation screen and it wants to start all over again.
    I've cleared my browser cache and everything seems to be CHMODed properly. WPMU can write to the .htaccess file, presumably, since it never once bellyached that it couldn't.

    My host has Apache vhosts and wildcard DNS activated; it's a cPanel host, but as I said, I don't believe I am having problems with .htaccess as the other two installs I did use the same cPanel web host.

    Thoughts?

  2. CountBlah
    Inactive
    Posted 16 years ago #

    Sadly I am in the same damn state...

  3. moyii
    Inactive
    Posted 16 years ago #

    en
    the same probloem

  4. gappiah
    Member
    Posted 16 years ago #

    What nightly build are you installing? Some (especially the latest ones) are known to have such bugs.

  5. flammable
    Member
    Posted 16 years ago #

    Same here! I'm using the latest nightly, the 04/05/2006 build. I just cannot seem to get around it...if I download an older nightly, can I install using that and then update to the latest nightly? Will that work?

    I don't even get to the point that it emails me, I just enter my blog name and email address, and it goes back to the installation page. Also, I notice that by that point, the wp-config.php file is reset to the defaults.

    Kind of frustrating that I set aside all of this time tonight to do this and cannot get past this installation bug.

    If you need any other details, I'd be happy to provide them.

  6. mrball
    Member
    Posted 16 years ago #

    sounds like the broken .htaccess

    was wondering, is the .htaccess left deliberately broken as sort of a screening process for new users? like, if you can't sort this our yourself, you shouldn't be using wpmu! :)

  7. flammable
    Member
    Posted 16 years ago #

    Aww, c'mon, I was able to successfully edit the httpd.conf file...doesn't that get me through the screening process?

    Hehe, guess not...off to fix that htaccess file and see what happens. Thank you for the tip. :D

  8. flammable
    Member
    Posted 16 years ago #

    Hmm, I just got the same thing...renamed the htaccess file to have a period before it, entered the info, submitted it, and it said "success"...then I entered my blog name, and my email address. Clicked submit, got this:

    "Error establishing a database connection"

    and an explanation on what's wrong, etc...and I know the info I entered is correct. So, I reloaded the wpmu directory and now it wants to install again. I opened wp-config.php and it had all of the defaults in there. It just looked like a duplicate of wp-config-sample.php.

    This is not on my server, it's on a friend's...so while I was able to edit the httpd.conf file so that the VirtualHosts setting was enabled, I'm not sure if I had to do anything separate for the DNS...he's running OS X, is there anything in particular necessary? Does he need to contact his ISP? He's got a domain name pointed to his machine, so maybe he needs to configure something through whoever he bought that from?

    That's the only thing I can think of that I might have done improperly.

    Thanks for the help...you guys rock. Can't wait to get this up and running. :D

  9. mrball
    Member
    Posted 16 years ago #

    flammable:

    allow me to apologise. about the .htaccess thing, I was griping! I wasn't thinking you were actually going to try and fix it yourself.

    it sounds like you are getting quite lost. for now at least, running WPMU is quite an involved process. a first step would be to try a search in these forums for "htaccess", itdamager posted a working one.

  10. andrewbillits
    Member
    Posted 16 years ago #

    We really have to start checking the dates on posts. You guys are also replying to an older thread. :)

  11. mrball
    Member
    Posted 16 years ago #

    i know... the problem is still around tho

  12. dungog
    Member
    Posted 16 years ago #

    do you have this line in apache
    when i had None instead of All I had your symptoms
    AllowOverride All

    <Directory /opt/muwp>
    AddType application/x-httpd-php .php .php3 .phtml
    AddType application/x-httpd-php-source .phps
    php_admin_value open_basedir /opt/muwp
    Options None
    Options +Indexes
    Options +Includes
    Options +FollowSymLinks
    AllowOverride All
    order deny,allow
    deny from all
    allow from all
    </Directory>

About this Topic

  • Started 16 years ago by jonimueller
  • Latest reply from dungog