The MU forums have moved to

'User updated.' returned but user is not updated. (6 posts)

  1. webmaestro
    Posted 16 years ago #

    I have an intermittent problem. When I attempt to update a user and click 'Update Profile', the 'User updated.' box is displayed at the top of the page, but the user is not actually updated.

    The problem happened when I check/uncheck the '[x] Use the visual editor when writing' checkbox.

    I just received a report from another all-access WPMU Site Admin user:

    Something funky is happening with the blogs. I just created a new blog named mobile. The admin's email is [user]@[domain].com. He already has an account with the username '[user]'. But when I created the blog, it created a new username 'mobile with the same email address. This shouldn't happen.

    I also have been trying to add users as admins to the blog, but am not able to. If I try to change the user's role, the screen says 'User updated.' but the role field says '-No role for this blog-' instead of the role I just assigned them.

    Also if go to the list of users under the Users tab, they show up in the list as 'No role for this blog'. I tried using the Bulk Update to change them to admins, editors, or authors, but this didn't work either.

    I deleted and tried recreating the blog twice, but the same thing happens each time. Although the second time, it didn't create another username for [user]@[domain].com.

    The problem appears to be similar to this old bug:

  2. webmaestro
    Posted 16 years ago #

    Sorry... I meant to add:

    $wp_version = 'wordpress-mu-1.2.5';
    $wporg_version = 'wordpress-2.2.3';
    $wp_db_version = 5200;

    (that's really wpmu-1.2.5a)

    and some system details

    Server version: Apache/1.3.37 (Unix)
    Server built: Dec 13 2006 15:06:38

    mysql: Ver 8.41 Distrib 5.0.27, for pc-solaris2.10 on i386

    PHP 5.2.0 (cli) (built: Aug 6 2007 17:21:41)
    Copyright (c) 1997-2006 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2006 Zend Technologies

  3. lunabyte
    Posted 16 years ago #

    First thing is to upgrade, and see if the problem persists.

  4. andrea_r
    Posted 16 years ago #

    Also, check your error logs.

  5. webmaestro
    Posted 16 years ago #

    Thanks... I'll check the error logs.

    One thing I've fairly recently added, is WP Super Cache, so I wonder if there's some 'caching' of the /wp-admin/ involved or something.

    I'd love to upgrade, but I am concerned about the affect and haven't had time to adequately test the effects an upgrade will have, since there are changes to the database.


  6. andrea_r
    Posted 16 years ago #

    know what you mean about the upgrading. I've just been patching in security fixes, as previous upgrades broke about as many things as it fixed.

    The other thing is, find out if anything was done server-side lately.

About this Topic

  • Started 16 years ago by webmaestro
  • Latest reply from andrea_r