The MU forums have moved to WordPress.org

upgrade to 1.3 cannot add blogs (14 posts)

  1. kishorebudha
    Member
    Posted 14 years ago #

    I have upgraded to 1.3 from 1.2.4. I deleted all folders and files except .htaccess, wp-config.php, and the directory /wp-content

    I have already referred to this post: http://mu.wordpress.org/forums/topic.php?id=6899&page&replies=22 and the suggestions there have not solved my problem.

    After adding new blogs, I do not receive notification from system, I cannot access the blog through URL or the backend. Accessing the URL either front end or backend leads me to to the blog leads me to http://subalterncinema.com/wp-admin/install.php

    I tried bumping up the sql version in /wp-includes/version.php but it did not help either.

    Any help appreciated.

  2. kishorebudha
    Member
    Posted 14 years ago #

    bump. anybody please?

  3. lunabyte
    Member
    Posted 14 years ago #

    Any information about your server?

    This was noted in a recent trac ticket, although under a different set of circumstances, but a recent fix that's in the latest trac revision corrected a similar issue. As a side benefit, it also corrected this (which wasn't a widespread problem, but did cause certain version of mysql to bork).

  4. kishorebudha
    Member
    Posted 14 years ago #

    you mean apache and mysql versions?

  5. lunabyte
    Member
    Posted 14 years ago #

    "...certain version of mysql..."

  6. kishorebudha
    Member
    Posted 14 years ago #

    General server information:
    Operating system Linux
    Service Status Click to View
    Kernel version 2.6.9-023stab043.1-smp
    Machine Type x86_64
    Apache version 1.3.37 (Unix)
    PERL version 5.8.8
    Path to PERL /usr/bin/perl
    Path to sendmail /usr/sbin/sendmail
    Installed Perl Modules Click to View
    PHP version 5.1.6
    MySQL version 4.1.22-standard
    cPanel Build 11.16.0-RELEASE 18546
    Theme cPanel X v2.6.0
    Documentation Click to View
    cPanel Pro 1.0 (RC1)

  7. kishorebudha
    Member
    Posted 14 years ago #

    OK. made the following changes to the wp-config file

    original
    define('DB_CHARSET', 'utf-8');

    changed to
    define('DB_CHARSET', 'utf8');

    THis seems to have had the following effect. I am now able to add blogs. But for some strange reason they are not listed on the home page (I use the list all posts plugin). Please see http://subalterncinema.com I have added the blog test http://subalterncinema.com/test but the same is not displayed on home page.

  8. kishorebudha
    Member
    Posted 14 years ago #

  9. theworkisdone
    Member
    Posted 14 years ago #

    Same problem here after upgrading from 1.3.2 to 1.3.3. A new user registered a blog. Right after entering the activation code he was redirected to /wp-admin/install.php. No blog-tables were created.

    Though an existing user registered a new blog and everything worked.

    Running a vhost-Install on Apache 2.2.3 and Mysql 5.x an PHP 5.1.x. I never had problems with db-charset utf-8.

  10. Mattz
    Member
    Posted 14 years ago #

    Mhh, I see this also now on a testblog, I wonder if this is plugin related.

  11. epheph
    Member
    Posted 14 years ago #

    Is there any resolution to this? I am experiencing several issues with WPmu after an upgrade from 1.1.1 (to 1.3.3). Whenever a new blog is added, any attempt to access that blog redirects you to /wp-admin/install.php, which does not exist in this version of WPmu . I am running

    Red Hat Enterprise Linux ES release 4
    Apache 2.0.59
    MySQL-5.0.45-community
    PHP 5.2.3

    I performed a clean install of the extracted files and selectively copied over old files (plugins, themes, wp-config.php)

    I guess this could answered by someone who knows if there is supposed to be an install.php in wp-admin, or if the browser is being incorrectly redirected.

    Plugins installed: NiceAdmin, SK2, Per User Themes

  12. andrea_r
    Moderator
    Posted 14 years ago #

    Check and see if the tables exist in the database. My guess is not (I've had this error before).

  13. epheph
    Member
    Posted 14 years ago #

    No, no tables are being created. Although a row is inserted into the "wp_blogs" table.

    I figured it was the 'install.php' that created this since that is where I'm being redirected?

  14. epheph
    Member
    Posted 14 years ago #

    Bump

    Any ideas? It's going to be a problem real soon when we need to add more blogs.

About this Topic

  • Started 14 years ago by kishorebudha
  • Latest reply from epheph