The MU forums have moved to WordPress.org

Xiando Social Networking Package, sub-directory (33 posts)

  1. bschwarting
    Member
    Posted 14 years ago #

    http://xsnp.livelyblog.com/

    Since using WPMU, this is probably one of the best plugins I've seen. I have some issues with it, and I'm wondering if most of my issues are because I use sub-directory install. Not by choice, but my only option with my web host. (might have to switch) Most issues are with the drop down and never taking you to the item you selected. It usually takes you to the main site, or dashboard home instead of what you clicked. I also had problems with the friends list, subscribe to blogs, and PM setup.

    Anyway, can anyone confirm they have gotten this package to work with sub-directories?

    I also noticed that it doesn't play very nice with IE6 or IE7, specifically the drop down menus. Can anyone else confirm this? Any fixes available for that?

    If I could get this plugin to work, my site would be ready to launch. Here's hoping I can get it to work :)

  2. andrea_r
    Moderator
    Posted 14 years ago #

    It's probably the subdir setup. I've been using this on a subdomain setup just fine.

  3. bschwarting
    Member
    Posted 14 years ago #

    shoot, i was hoping that wasn't it. looks like it's time to jump ship from 1and1 hosting.

    does yours work in IE6 or IE7?

  4. andrea_r
    Moderator
    Posted 14 years ago #

    Dunno, I'm on a linux box. :D

  5. gurucs
    Member
    Posted 14 years ago #

    Don't have experience with 1and1 for hosting, but have many domains with them... isn't it bad to have your domain registrar also be your web host? (ie. Godaddy)

  6. bschwarting
    Member
    Posted 14 years ago #

    i guess i could use a free DNS service to fix this problem, correct? anyone had experience with that?

  7. lunabyte
    Member
    Posted 14 years ago #

    Using external DNS is a possibility, and would work.

    However, I can't say that a "free" one would be the best option.

  8. bschwarting
    Member
    Posted 14 years ago #

    yeah, i agree on the free DNS stuff, probably not a good idea. i really like the 1and1 service package, just don't feel like changing providers for wildcard DNS. such a pain in the butt. might try dnspark.com or similar to avoid the web host change.

  9. andrewbillits
    Member
    Posted 14 years ago #

    1and1 setup the wildcard apache entry but won't allow the dns entry?

    Thanks,
    Andrew

  10. lunabyte
    Member
    Posted 14 years ago #

    Crazy, isn't it?

    It's makes it seem like they want you to think they want to support it, but the DNS deal gives them an "out".

  11. bschwarting
    Member
    Posted 14 years ago #

    ok, if i setup an alias (CNAME) of *.domain.com and point it to my web hosts IP for my domain name, that should work, correct?

  12. lunabyte
    Member
    Posted 14 years ago #

    Actually, an A record pointing to the IP address would be better.

  13. bschwarting
    Member
    Posted 14 years ago #

    ok, so setup my A record as *.domain.com and do away with the CNAME totally?

  14. bschwarting
    Member
    Posted 14 years ago #

    also, they have TTL as 7200

    what is recommended?

  15. lunabyte
    Member
    Posted 14 years ago #

    Yes, but don't forget the extra dot after com ( .com. )

  16. bschwarting
    Member
    Posted 14 years ago #

    this is a gui, so hopefully they catch that since they just ask you to enter your domain name with this example:

    (i.e. example.com)

  17. bschwarting
    Member
    Posted 14 years ago #

    things that make you go hmmm...

    now that I will have DNS external, I wonder if my development world should still work. right now, on my web host, i have a true alias setup for testing, beta.domain.com

    you think it will still work?

  18. lunabyte
    Member
    Posted 14 years ago #

    Not unless you set it up on the new DNS.

    Remember, when you change your domain name to use the new name servers, everything will be routed through there.

    www, no www, and anything else setup in the DNS of the old host.

  19. bschwarting
    Member
    Posted 14 years ago #

    ok, DNS seems to have moved quicker than i expected, but it's working now so i can test it. when i run my activate (wp-activate.php) link now, i get a 404 error message from my web host.

    Error 404 - Not found
    The document you requested is not found

    ideas as to why i can't activate now that i'm setup on subdomain?

  20. bschwarting
    Member
    Posted 14 years ago #

    ok, started brand new. on a fresh install of 1.3 with a new mysql 5.0 database. install went perfect.

    uploaded a fresh download of http://xsnp.livelyblog.com/ (social networking package)

    when i go to the main page, i get this error:

    Parse error: parse error, unexpected T_ARRAY, expecting ')' in /homepages/38/d218960724/htdocs/wp-content/mu-plugins/xsnp/xsnp-functions.php on line 209

    line 209 = function display_content_of_most_recent_posts_from_blogarray(array $blogs, $how_many = 18, $excerpt_length = 80, $showimages=true, $queryinterval=10,

    ideas as to what's going on?

  21. bschwarting
    Member
    Posted 14 years ago #

    oops, the rest of line 209

    function display_content_of_most_recent_posts_from_blogarray(array $blogs, $how_many = 18, $excerpt_length = 80, $showimages=true, $queryinterval=10, $unsubscribelink=false) {

  22. c-bass
    Member
    Posted 14 years ago #

    http://xsnp.livelyblog.com/ is down. but i need the plugin very quick. can anyone send me or upload his copy please?

  23. nolageek
    Member
    Posted 14 years ago #

    anyone send it to me too? :) Would love to check this out.

  24. honewatson
    Member
    Posted 14 years ago #

    Still down for me also.

  25. bschwarting
    Member
    Posted 14 years ago #

    post your email, i'll send it.

  26. nolageek
    Member
    Posted 14 years ago #

    nolageek at gmail dot com

  27. nolageek
    Member
    Posted 14 years ago #

    oops. site is back up.

  28. Sprout
    Member
    Posted 14 years ago #

    Couple questions regarding Xiando:

    Has anyone been able to use this plugin with php 4? Is it even possible if the arrays are rewritten to avoid the error mentioned above.

    Also, does anyone have examples of xsnp running on their site? I'm having trouble finding any.

  29. awarner20
    Member
    Posted 14 years ago #

    I was also just made aware of this plugin pack, and would love to see examples of use for the various plugins included.

  30. andrea_r
    Moderator
    Posted 14 years ago #

    I have it on a closed site in dev. Still testing.

    Oh, almost forgot - I have parts of it on a working site. The css override thingy and the custom background.

About this Topic

  • Started 14 years ago by bschwarting
  • Latest reply from suleiman