The MU forums have moved to

Uploaded files and permissions (3 posts)

  1. lexo
    Posted 18 years ago #


    I've successfully installed WPµ but i've 3 problems :

    1/ In master domain, only jpg jpeg png gif are allowed.
    But, in an user blog, php/txt and other filetypes can be uploaded :(
    Max upload file size works fine instead.

    2/ I upload an image, no thumbnail is available and if i'm including this image to a post, image will not appear and ?attachment_id=9 is in adress bar :(
    I've changed .htaccess like this :
    RewriteRule ^([_0-9a-zA-Z-]*)/?files/(.*) /wp-inst/wp-content/blogs/$1/files/$2 [L]
    RewriteRule ^([_0-9a-zA-Z-]*)/?wp-content/blogs/(.*)/files/(.*) /wp-inst/wp-content/blogs/$1/files/$3 [L]

    3/ Folder wp-inst/wp-content/blogs.dir/2/files/2005/12/ is readable by all users: (



  2. itdamager
    Posted 18 years ago #

    1 - allowed file type fix

    2 - htaccess fix (vhosts only)

    3 - change permissions so group and owner are the webserver user and other is none. (not tested but should work)

  3. lexo
    Posted 18 years ago #

    1/ Plugin allowed file type works fine
    2/ htaccess for images works fine
    3/ Added this to my vhost config

    <directory PATH/TO/WEBSITE>
    Options MultiViews -Indexes FollowSymLinks SymLinksIfOwnerMatch IncludesNoExec

About this Topic