The MU forums have moved to WordPress.org

WYSIWYG editor disappeared (5 posts)

  1. Taylor0330
    Member
    Posted 16 years ago #

    I'm setting up my third WPMU site (the other two were just me playing around with how the plugins play with WPMU). I have been working with WMPMU sets up for about 2 months pretty intensely and have not run into an issue yet that I could not figure out based on Googling for a solution or finding an alternate route to accomplish something -- WPMU rocks!

    However, I have hit a wall with something simple and cannot figure out how to fix it.

    I don't know how this happened, but I went to look at the wysiwyg toolbar to see if the ImageManager (WPMU compatible version) buttons had been added (I make sure everything is functioning properly for plugins as I am installing) but the WYSIWYG editor wasn't even there at all -- I had successfully done this on the previous two WPMU installs.

    I thought that it was triggered by ImageManager, so I worked into possible solutions on that, but I cannot be sure because I had not looked at the wysiwyg editor in the install before in this installation.

    I have disabled all plugins, disabled RTE in my site admin user profile and logged in and out -- cleared the cache in my browser and still cannot get the visual text editor (RTE) to show in the write or manage tabs for posts or pages.

    I cannot get the RTE to show up even with no plugins enabled. I disabled all plugins, reinstalled the entire wp-includes folder and then downloaded my theme and plugins folders and wiped out everything and reinstalled WPMU 1.3.2. There is nothing extra in the root that could interfere. I am the same hosting environment for the other two WPMU installs that I had no problem with.

    :(

    Then I tried uploading the following plugin with the thought it might force the editor to appear, to no avail.

    WPMU_Plugin:Miwa_Editor_Mu from:

    http://my.sambazen.net/wiki/index.php/En:WPMU_Plugin:Miwa_Editor_Mu

    Both the visual and the code tabs are there, but the text that appears under the visual tab appears as it does and should under the code tab.

    Any help would be greatly appreciated.

  2. andrea_r
    Moderator
    Posted 16 years ago #

    Anything in the error logs?

    (I really feel your pian too.)

  3. Taylor0330
    Member
    Posted 16 years ago #

    Good idea! Although I'm not very good at decoding errors, I was not able to find any js or mce in the error logs...however I found these, that I am not sure what they are caused by or affect:

    [Sat Jan 26 01:03:14 2008] [error] [client 67.173.181.164] mod_rewrite: maximum number of internal redirects reached. Assuming configuration error. Use 'RewriteOptions MaxRedirects' to increase the limit if neccessary., referer: http://mysiteurl.com/
    [Sat Jan 26 01:03:14 2008] [error] [client 67.173.181.164] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: http://mysiteurl.com/
    [Sat Jan 26 01:03:15 2008] [error] [client 67.173.181.164] File does not exist: /home/isabella/mysiteurl.com/wp-content/plugins/social_bookmarks/lib/niftyCube/niftyPrint.css, referer: http://mysiteurl.com/

    [Sat Jan 26 00:56:21 2008] [error] [client 67.173.181.164] , referer: http://mysiteurl.com/wp-admin/post.php?action=edit&post=1
    [Sat Jan 26 00:56:26 2008] [error] [client 67.173.181.164] mod_rewrite: maximum number of internal redirects reached. Assuming configuration error. Use 'RewriteOptions MaxRedirects' to increase the limit if neccessary., referer: http://mysiteurl.com/
    [Sat Jan 26 00:56:26 2008] [error] [client 67.173.181.164] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: http://mysiteurl.com/

    Are these any help?

    Also, I did have the check box checked in user profile to enable the visual editor, however I had to uncheck it to even have the buttons for the code appear.

  4. andrea_r
    Moderator
    Posted 16 years ago #

    Well, the first two erros can be eliminated by following what it says to do. The file you need to look at is httpd.conf. That's where to increase those limits.

    The last one is a missing file from a plugin.

    Fixing the first bit might actually do it though. TinyMCE kicks offf for odd reasons sometimes.

  5. Taylor0330
    Member
    Posted 16 years ago #

    hmmmmm... that was what I thought.

    This was all working on my last install. My host says I need to make changes in .htaccess only -- I don't have access to the httpd.config to fix the calls. I have access to most everything in the root but httpd.config.

    Is there a way to do that in .htaccess?

    -- Use 'RewriteOptions MaxRedirects' to increase the limit if neccessary.

    -- and Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary.

    Thank you for your help :)

About this Topic

  • Started 16 years ago by Taylor0330
  • Latest reply from Taylor0330