The MU forums have moved to

photos coming up missing, admin pages won't load (38 posts)

  1. billdennis5
    Posted 16 years ago #

    Here's a problem: I run this site:

    One of my member bloggers is experiencing the following issues: When he tries to load any admin pages, he gets a white screen. No error message at all.

    When I or anyone else looks at his site, the photos he has embedded don't load, just a link to them. We click on the link, and we get a 404 message.

    his site is

    No other sites are being affected by this. I checked his status as a user, and he's still listed as admin for the blog.

  2. jackiedobson
    Posted 16 years ago #

    Have to checked to see if the uploaded files are physically there in the blog's uploaded directory?

    What specific browser and version are they running? (That's for the white screen issue)

    When was the last time the user ran a virus check on their system with the latest and most up to date version of the virus sig files? (You may have to specifrically ask them the date on the virus sig files. Most folks don't realize that you have to update both the software and the sig files.)

    I know you mention no error message but is there anything in the webserver's error logs?

  3. andrea_r
    Posted 16 years ago #

    Deactivate all the plugins he's running on that blog and try it again.

  4. billdennis5
    Posted 16 years ago #

    Andres_r: RThanks for the tip. I'm having it checked now.

    As to photos. The images on his site generate 404 messages. No other images on other sites are generating 404 messages.

    See for yourself:


    The error logs show many file not found messages

  5. lunabyte
    Posted 16 years ago #

    Do they exist in the blogs.dir/blog_id/files/2008/01/ directory?

    If not, there's where to start looking.

  6. andrea_r
    Posted 16 years ago #

    Are they actually in his blog directory on the server? (wp-content/blogs.dir/HIS-BLOG-ID-#/)
    Are the permissons correct on the sub-folders?

    How is he posting them? Are they linked correctly in his entries?

  7. billdennis5
    Posted 16 years ago #

    I'm walking out the door, so I'll check these things. Bear in and that these posts works with all images showing until yesterday.

  8. billdennis5
    Posted 15 years ago #

    I'm reposting this, because I'm experiencing the same issue again, after a move to a new server.

    No image stored in any file in blogs.dir are working. They show up as broken images in all browsers.

    The images ARE there, and in the proper directories. The permissions seem to be set at 755

    Consider this one:

    Any assistance would be appreciated!

  9. billdennis5
    Posted 15 years ago #

    I posted a trouble ticket with my server people and received the following reply:

    "This appears to be related to your mod_rewrite rules. How are you including the images in your posts?"

  10. lunabyte
    Posted 15 years ago #

    This would be the direct link to that file, no?

    Which that file doesn't exist, so index.php takes over and serves a 404 page through the theme.

    Working back, the lowest directory that can bee seen is:

    Clicking on /files/ produces a 404.

    So the problem seems to be that while the blogs.dir, and blog_id dir under that exists, there doesn't seem to be anything under that, or if there is, then the permissions/owner/group are incorrect and the web server can't even read those directories.

  11. billdennis5
    Posted 15 years ago #

    I have the permissions set at 755. But the people who run the server say that it's a mod-re0wrode problem.

    I downloaded the files via ftp and uploaded the same way.

  12. andrea_r
    Posted 15 years ago #

    Check the account ownership on the files (chown).

  13. billdennis5
    Posted 15 years ago #

    Andrea: I am stuck here. My server people tell me it's a problem with .htaccess. Indeed, they seem to have dug in their heals on this issue. The WPMU community says it's permissions. There has to be a way to fix this.

  14. lunabyte
    Posted 15 years ago #

    That has absolutely nothing to do with mod_rewrite. That's a direct url to an image. If it was there, or accessible by the web server, it would show the image.

    Here's an example:

    That link is no different than the first one. It's a direct link to the image. Gee, it shows up.

    mod_rewrite seems to be working fine. You hit the link you provided, and it says 404, not found. Which is right.

    If the image was there/accessible, it would show up.

  15. billdennis5
    Posted 15 years ago #

    lunabyte: What you are saying makes perfect sense to me. Still, here I am dealing with people who have dug in their heals on this being a problem with my .htaccess file.

    I need to be able to tell these people what they need to check. I need to tell them what specifically to do, or learn how to do this myself.

    Any advice you give me will help. I'll call them tonight after I get off work.

  16. andrea_r
    Posted 15 years ago #

    Actually, you can go all the way back to and clicking on /files/ in any user's subfolder produces a 404.

    (you really need a blank index.html in that folder Bill.)

  17. andrea_r
    Posted 15 years ago #

    Allrighty, verify for me that you have this line in .htaccess (NOT htacces.dist)

    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    Should be the 3rd on under #upload files heading.

    If that is there, then there's nothing wrong with your rewrite rules.

  18. billdennis5
    Posted 15 years ago #


    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]
    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    # END WordPress
  19. billdennis5
    Posted 15 years ago #

    Oh great. Absolutely freeking wonderful. Now when I try to lick on the link to the image, I get the following error message:

    Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 311296 bytes) in /home/blogpeor/public_html/wp-settings.php on line 516

  20. lunabyte
    Posted 15 years ago #

    Yep, I mentioned that already Andrea.

    Bill, I don't know how to really be more clear, honestly.

    The images either do not exists, or the owner/permissions currently set do not allow for the web server to read them. Have you looked through FTP?
    Is there actually a file in:


    If there is, then it's an owener/permission problem.
    The rewrite rule is doing it's job. That part works just fine. Well, at least it did last night as it was printing 404 not found onto a white page (as it should).

    Although right now it's printing fatal errors, which you should fix.

    Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 311296 bytes) in /home/--directory-name--/public_html/wp-settings.php on line 516

    Time to up the memory for PHP as well, it seems.

  21. billdennis5
    Posted 15 years ago #

    I absolutely agree with you Lunabyte. I'm not arguing with you. I'm reporting what my hiosting company is insisting to me, which is that this is a mod-rewrite problem.

    I either get a committment from them today to fix the problem or I'm moving AGAIN, an idea which pisses me off to no end.

    Can anyone recommend a powerful managed VPS that costs less than $100 a month? One that's beign run by people who know WPMu/ Hell, I'll setting for people who understand how permissions on files work.

  22. billdennis5
    Posted 15 years ago #

    And can you give me instructions for upping the memory on php.

  23. andrea_r
    Posted 15 years ago #

    I'm using on a $62 /month package.

  24. billdennis5
    Posted 15 years ago #

    I'll be contacting the host to move these directories from one server to another directly, maybe preserving the ownership and the permissions.

  25. billdennis5
    Posted 15 years ago #

    I have a friend -- a new friend actually -- take pity on me and he's having a look around my database.

    He discovered the following: my site's IP address is pasted into a browser's URL window, the result is a WPMU datebase error.

    In other words, gets this message "o WPMU site defined on this host. If you are the owner of this site, please check Debugging WPMU for further assistance."

    But I can get access to my front page and any member site just fine (except for the issue of the member uploaded photos not showing up, even if they are all in the appropriate blog.dir directory). In fact, I'm hoping the two issues are related, as it would provided much needed clues to fixing the problem.

    Any thoughts from the WPMu community?

    [edited for clarity]

  26. andrea_r
    Posted 15 years ago #

    It should either redirect to your domain name or show the main page of your MU site. Something is up. I'd be combing over the httpd.conf file.

  27. billdennis5
    Posted 15 years ago #

    I passed that information along.

  28. IdaWebCo
    Posted 15 years ago #

    Hey you Good People!
    Like you I'm trying to help here. Bill has a good number of bloggers and this is a pretty big deal for him. I want to lend information to the discussion and let's hope we can get him running again soon.

    PHP.INI - At least 32M is recommended, bills is set at 64. I guess this was the default when his new vps was created. If not and it has been changed, server needs to be restarted for the change to take effect.

    In my experience, the memory error he is experiencing is more often sparked by corrupted files than a lack of memory.

    lunabyte - I think I get what you are saying about group_owner, bill ftp uploaded all files to new server and the group_owner are both the same. blogpeor and blogpeor. I believe this is fine but since I didn't think to rule out perms, I'm sharing this info with you.

    andrea_r - I have not asked bill if the httpd.conf file has been edited for WPMU. As you know his sub domains are all working except for files/mem issue. I have ruled out as much as my little brain could think of and the tables all look good. I'm going to correct a coalation issue in mysql, but I doubt that is causeing this problem. I'm starting to think the httpd.conf file was never edited on the new server. Bill is at work but I will address this with him this evening. You may have nailed it down.

    Other ideas: If the httpd.conf is not an issue, I think some files may have been corrupted during ftp upload. Anyone have any new ideas or additional feedback for us to rule out?

    Thanks for your time!

  29. andrea_r
    Posted 15 years ago #

    (hey, i know you...)

    Awesome, keep us posted. The conversation is a good resource.

  30. billdennis5
    Posted 15 years ago #

    Thanks for you help. Citizen journalism in Peoria thanks you.

About this Topic

  • Started 16 years ago by billdennis5
  • Latest reply from andrea_r