The MU forums have moved to

Trouble with updating options after upgrading (9 posts)

  1. StianH
    Posted 15 years ago #


    I just recently updated to the latest WPMU code on my site, and now I am having some trouble with a custom admin plugin I've written.

    I am using the add_/get_options commands, and a form with the wp_nonce_field('update_options') function in it.

    This worked just fine before updating, but now I am redirected to wp-admin/options.php after pressing the update button, and I get a question like "Are you sure you wish to do this" (I have norwegian language, so exact english equivalent I am unsure of), and the No / Yes options.

    When pressing "Yes", options.php reloads with a message saying "Error! Page for optionsettings was not found" (again roughly translated from norwegian). And the settings are not set.

    Any ideas?

  2. jackiedobson
    Posted 15 years ago #

    Latest as in off the download page or out of trac?

    Some folks have reported issues with using the object cache? I'm wondering if you're running into this. May want to try turning this off if you are. Does this issue occur when your plugin isn't being used?

    A good place to start is the debugging script linked to out of the readme file.

  3. StianH
    Posted 15 years ago #

    I am using the latest from the download page.

    How do I turn of the object cache?

    The plugin is in my admin area, and basically just stores some values used by another plugin I've modded a little. The plugin that uses the options saved by my plugin, works just fine and is able to read the options. This is true for my plugin as well, can read the options, it's just saving that doesn't work.

    I'll take a look at the debugging script.

  4. StianH
    Posted 15 years ago #

    I found some related issues in the tickets in track and a possible fix here which I'll try out


    Just realised I'm at 1.3.2, not 1.3.3, gonna deal with that and see if it might fix things.

  5. Trent
    Posted 15 years ago #

    Reverting to cache.php from Rev 1126 and applying Fredericks patch seems to be working as a temporary fix as per lunabyte's instructions.


  6. StianH
    Posted 15 years ago #

    Hmm, I just tried that patch on the suggested revision, but didn't do any good. I don't seem to have this problem elsewhere though.

  7. deximer
    Posted 15 years ago #

    The WPMU options page error:

    "Are you sure you want to do this?"

    Is caused by an update to WPMU that introduces a $whitelist_options array that seems to list th options that will be allowed for the MU site. There are a few API's for controlling it but I have not looked into it yet.

    grep for whitelist_options in the MU code base to see if you are effected.

  8. awarner20
    Posted 15 years ago #

    I just ran into this options.php error exactly as described here. I was trying to configure a plugin I had activated in my admin blog.


    Please forgive my ignorance, but what does "grep" mean? I would really like to find out the fix for this one. Does it have more to do with how the plugin code is written, or something in the WPMU core files?

    Thanks for any further info. I am running the 1.5 RC1 version.

  9. awarner20
    Posted 15 years ago #

    Anyone have any thoughts on this one?

About this Topic

  • Started 15 years ago by StianH
  • Latest reply from awarner20