The MU forums have moved to WordPress.org

Can't change max upload size (11 posts)

  1. FrankRichards
    Member
    Posted 14 years ago #

    I'm trying to import a 2 meg wxr file into wpmu. Besides the message about a 0k max file size, when I try it, I get an error saying 1500k is the max size.

    I've found the setting in wp-admin and changed it to 8000k. The page still says 0 and the error message still says 1500.

    It's a site wide setting that I can't change from inside the individual blog. Did I need to change it before I created the blog? Is this a known bug like the 0 is?

  2. bloggus
    Member
    Posted 14 years ago #

    Maybe the limitation is server issue you have (upload size set in php.ini) to adress and not the script in this case.

  3. FrankRichards
    Member
    Posted 14 years ago #

    Nope, already changed php.ini to 10M. Besides the php.ini default is 2 megs, not 1.5

  4. FrankRichards
    Member
    Posted 14 years ago #

    The issue is that I'm using multiple domains and changing the max upload size only affects the 'original' domain. To change it for other domains requires adding rows to the site-meta table, one for each site.

    Bug filed in Trac.

  5. jackiedobson
    Member
    Posted 14 years ago #

    Just for reference, there's a number of plugins over on wpmudev.org that will do this for you.

    edit: You may also want to mention what version of mu you're running as 1) it's part of the debugging process linked to out of the readme file and 2) there were a number of tickets on this topic a few months back around v1.2.5 of the mu software.

  6. pumpkinslayer
    Member
    Posted 14 years ago #

    the multiple site plugin at wpmudev.org now fills in these details when a new domain is added http://wpmudevorg.wordpress.com/project/Multi-Site-Manager

  7. bloggsbe
    Member
    Posted 13 years ago #

    I ran in to the same problem, and when I took a look at wordpress.php in the wp-admin/import folder, I noticed that it supported gzip. So i gZip'ed my 3.5 MB XML file down to 646KB, and then it worked as it should.

    But there should be an option to gzip the export file when exporting a XML file....

    --
    R

  8. Shane G
    Member
    Posted 13 years ago #

    Hi,

    You just need to use this code:

    <?php
    ini_set('upload_max_size','100M');
    ini_set('post_max_size',’105M');
    ini_set('max_execution_time,'300');
    ?>

    Save this file as php like myfile.php and upload it in the plugins directory and activate this plugin. It should be working fine.

    Thanks,

    Shane G.

  9. VentureMaker
    Member
    Posted 13 years ago #

    I guess the second line should be

    ini_set('upload_max_filesize','100M');

  10. lonb
    Member
    Posted 13 years ago #

  11. tdjcbe
    Member
    Posted 13 years ago #

    So it other words, it's what's discussed up above.

About this Topic

  • Started 14 years ago by FrankRichards
  • Latest reply from tdjcbe