The MU forums have moved to WordPress.org

user themes not working (21 posts)

  1. garretthes
    Member
    Posted 16 years ago #

    I must be missing something obvious. I have 15 to 20 themes enabled but when I log in as a user there is no presentation tab. All I have is -
    dashboard, write, manage, comments, profile

  2. andrea_r
    Moderator
    Posted 16 years ago #

    Is the user an admin on that blog?

  3. garretthes
    Member
    Posted 16 years ago #

    I want to set it up like multiply where each user has their own site and can change the way it looks. Is there a way to do this?

  4. andrea_r
    Moderator
    Posted 16 years ago #

    that's what MU does by default? If they sign up for a blog, they should be admin on their blog and be able to change themes.

    If they just sign up as a *user* on the system, then that's different.

    edit: I'm checking your site out and testing it for ya. :D

  5. andrea_r
    Moderator
    Posted 16 years ago #

    Yep, that's what is wrong. You're allowing just usernames to sign up without a blog. They default to the main blog anddo not get a blog of their own that way.

    Go to Site Admin -> Options, and look for Allow New registrations. Make sure "Enabled for all. Blogs and user accounts can be created." is selected.

    Then it will work the way you want.

  6. garretthes
    Member
    Posted 16 years ago #

    Thanks very much! How do I clear the account of the client user. I deleted her account but when I try to re-register her properly it says the user name and email are already in use. Will it just take some time and clear automatically?

  7. andrea_r
    Moderator
    Posted 16 years ago #

    It's probably not out of the database. you may have to go into phpmyadmin and get it out that way.

    You didn't have to delete her username though - revisiting the signup page would now give her the option to get a blog anyway.

  8. garretthes
    Member
    Posted 16 years ago #

    Aaaaaah! I just set up another user and the activate email link doesn't work!
    http://kelly.thebloggersdiet.com/wpmu/wp-activate.php?key=f696cd2ca06c152e
    All I did was check the option to "enable all"

  9. andrea_r
    Moderator
    Posted 16 years ago #

    I bet you don't have the wildcard subdomains set up right. Go over the readme file and make sure you did all the steps to enable it. :)

    It's a server issue, and not a setting within MU.

  10. garretthes
    Member
    Posted 16 years ago #

    So I called and asked the tech support at bluehost.com to create a dns wildcard entry. They told me they don't support wildcard dns! Now what? I picked them because they were recommended #1 on the wordpress.org website.

  11. demonicume
    Member
    Posted 16 years ago #

    good luck with blue host. if bluehost did wild card domains without fuss- which they can but they'll charge you - i wouldn't have a subdir install right now. search the forum, someone posted on it like 2 days ago.

  12. andrea_r
    Moderator
    Posted 16 years ago #

    they are recommended #1 for *regular* wordpress installs.

    Either you'll have to find a new host, or like demonicume said, reinstall and use subdirectories.

    And yeah, I wish they made that clearer.

  13. garretthes
    Member
    Posted 16 years ago #

    Reinstalled using subdirectories but now I get nothing but blank pages.
    Error log shows this-
    [26-Feb-2008 21:30:04] PHP Fatal error: require() [function.require]: Failed opening required '/home/blogger5/public_html/wpmu/wp-config.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/blogger5/public_html/wpmu/wp-login.php on line 2

  14. andrea_r
    Moderator
    Posted 16 years ago #

    When you reinstalled, did you drop tables, delete the wp-config file AND the htaccess file?

  15. garretthes
    Member
    Posted 16 years ago #

    I removed the entire directory and started over. Drop tables???

  16. andrea_r
    Moderator
    Posted 16 years ago #

    On the database. :) It's gotta go too.

  17. garretthes
    Member
    Posted 16 years ago #

    Checked. No tables. I actually deleted it and started over.

  18. garretthes
    Member
    Posted 16 years ago #

    Enjoyed looking through some of your photos. You can keep those Canadian winters. We home schooled our 3 kids for 5 years.

  19. andrea_r
    Moderator
    Posted 16 years ago #

    :D we had snow *again* overnight. the homeschooling has gone on 13-14 years and counting..

    how's that install going? :D

  20. garretthes
    Member
    Posted 16 years ago #

    Stuck! I removed all the files from the wpmu folder, uploaded fresh install files and re-created a database but I still get a blank page no matter what address I type.

  21. garretthes
    Member
    Posted 16 years ago #

    We had snow last night too. Of course only about 1/2 inch. The freezing temps did shut the schools down today though. I doesn't take much to shut down a Tennessee school system :)

About this Topic

  • Started 16 years ago by garretthes
  • Latest reply from garretthes