The MU forums have moved to WordPress.org

Change default language (26 posts)

  1. svinus
    Member
    Posted 14 years ago #

    I'm trying to change to default language of the admin page for my bloggers to dutch but it doesn't work als default

    i already changed my config file of wordpress with the language pack and it appear in the language drop down menu but i can't set is as default.

    Suggestions ?

  2. svinus
    Member
    Posted 14 years ago #

    also in the admin panel i changed the language so it should be active sitewide but it has no effect

  3. pumpkinslayer
    Member
    Posted 14 years ago #

    To change it for the whole site, in wp-config.php, alter line 23 to look like this

    define ('WPLANG', 'da');

    also note the instruction above that line in the file

  4. svinus
    Member
    Posted 14 years ago #

    i already changed my config file of wordpress with the language pack and it appear in the language drop down menu but i can't set is as default.

  5. qza
    Member
    Posted 14 years ago #

    I have this problem too. I manually change language of each newly created blogs. Setting different language as default work before, and stopped working since version 1.3.1 or 1.3.2 (I don't remember which one is)

  6. bloggus
    Member
    Posted 14 years ago #

    Same problem here. Looked in the scheme.php, but is is not set there. Anybody know where it should be set?

  7. Akashic
    Member
    Posted 14 years ago #

    Exactly, it is not set there.
    So, what to do? Just set it up, man!

    Had the same problem.
    As you look carefully into newly created blog option table you'll see that WPLANG is not set up as default.
    To solve it, simply insert into wp-admin/includes/schema.php following line:

    add_option('WPLANG', 'ja');

    Of course change the latter accordingly to you mother-tongue.

    Cheers,
    A.

  8. telecarlos
    Member
    Posted 14 years ago #

    Thank you Akashic!

    It works exactly how I expect

  9. selad
    Member
    Posted 14 years ago #

    It is better not to change core files. You can use the WPMU new blog settings plugin to set this option for new blogs.

  10. Fredrik-S
    Member
    Posted 14 years ago #

    Has something change to the new version 1.5.1? I downloaded "WPMU new blog settings plugin" and tryed to change my deafult language to Swedish (se) but it doesen't work.

    I have put the plugin file in following folder: wp-content/mu-plugins/

    and my code look like this:
    <?php

    /*

    Plugin Name: WPMU new blog settings plugin
    Version: 0.1
    Plugin URI: http://www.ringofblogs.com/2007/12/21/wpmu-new-blog-settings-plugin/
    Author: Elad Salomons
    Author URI: http://www.ringofblogs.com
    Description: WPMU new blog settings plugin
    */
    function new_blogs_setting( $blog_id ) {
    //set your options here:
    add_option('WPLANG', 'se');
    // stop editing here
    return;
    }
    add_action('wpmu_new_blog', 'new_blogs_setting');
    ?>

    But still it doesn't work, whats wrong?

  11. margjedonder
    Member
    Posted 14 years ago #

    The solution above does not work with wpmu 1.5.1

    putting the line below in schema.php does not work:
    add_option('WPLANG', 'nl_NL');

    or using the Plugin Name: WPMU new blog settings plugin:
    //set your options here:
    add_option('WPLANG', 'nl_NL');
    // stop editing here

    Doesn't work either.

    What to do to change the default language for new created blogs in wpmu v1.5.1 ?

    Thanks in advance

  12. chinafla
    Member
    Posted 14 years ago #

    first, you need to creat a folder named languages in wp-content folder. and put your own languages files in that folder. example zh_CN.mo zh_CN.po in languages folder.
    then add_option('WPLANG', 'zh_CN'); will work

  13. Fredrik-S
    Member
    Posted 14 years ago #

    chinafla, I have added the language I want like you said and the guide at wordpress.org.

    Then I added the plugin wpmu-new-blog-settings, but it doesn't work.

    Is it really good to change in the core file?

  14. chinafla
    Member
    Posted 14 years ago #

    no, Fredrik-S, you don't need to change the core file.
    if you've got those two languages files, then login as the admin of wordpress MU,
    Site Admin -> Options -> Default Language
    you can select your own language at Default Language, just select and submit. done.
    BTW: wpmu-new-blog-settings doesn't seem to work for 1.51
    ,at least for me.

  15. margjedonder
    Member
    Posted 14 years ago #

    @chinafla,

    The path and file ../wp-content/languages/nl_NL.mo was allready present. Adding "add_option('WPLANG', 'nl_NL')" to schema.php does not work. New created blogs are in English. Users CAN set the language to dutch/chinese by hand but the default language stays English. I'll think this is a problem since 1.5.1

  16. chinafla
    Member
    Posted 14 years ago #

    @margjedonder

    but it does work for me.
    you can try it yourself, you can login:
    http://baidu.pk/mu/flashflash/wp-login.php
    user:flashflash
    pass:123321

    or you can creat a new account
    http://baidu.pk/mu/wp-signup.php

    this is a test site for wordpress mu, so it'll be deleted few weeks later.

  17. margjedonder
    Member
    Posted 14 years ago #

    your right, thanks! got it working on my site also! thanks for your time.

    cheers!

  18. chinafla
    Member
    Posted 14 years ago #

    :)

  19. nonegiven
    Member
    Posted 14 years ago #

    Is there a Japanese translation of WPMU?

  20. Ueland
    Member
    Posted 14 years ago #

    For those of you that has this bug, you can do the following:

    1) define WPLANG as mentioned in config file
    2) Add this in ./wp-includes/l10n.php, line 45:

    if (empty($locale))
    $locale = WPLANG;

    That will default all blogs that does not have a language defined to your main language. :)

  21. Shi-no
    Member
    Posted 14 years ago #

    I tryed to change default language from English to Japanese.(Wordpress Mu 2.6.5)

    I did ...

    1. upload "ja.mo" and "ja.po" to wp-include/language

    2. access to Settings but I could not find "Blog Langage"

    3. access to SiteAdmin-->Options but I could not find "Default Language"

    What I should do next? What is the problem?

  22. mayansoldier
    Member
    Posted 13 years ago #

    I'm having a similar problem on wordpress mu 2.6.5, i've uploaded the *.mo, and *.po files to wp-content/languages/ folder and changed my wp-config file to ('WPLANG', 'es_ES') but nothing seems to happen... help!

  23. NetBlog
    Member
    Posted 13 years ago #

    ('WPLANG', '???') for Greek language
    which is?

  24. VentureMaker
    Member
    Posted 13 years ago #

    el_EL I guess... Ellanica :)

  25. WhoKnowZ
    Member
    Posted 13 years ago #

    and Dutch language?

  26. VentureMaker
    Member
    Posted 13 years ago #

    nl_NL to the best of my knowledge :)

About this Topic

  • Started 14 years ago by svinus
  • Latest reply from VentureMaker