The MU forums have moved to WordPress.org

ERROR - Sorry, this blog doesn't exist. Try the homepage instead! (45 posts)

  1. blogpig
    Inactive
    Posted 17 years ago #

    I have attempted to instal WPu on 2 different servers and always get the msg:

    Sorry, this blog doesn't exist. Try the homepage instead!

    In addition I have also received this error msg:

    Warning: main(/home/blogpigs/public_html/wp/wpmu-settings.php): failed to open stream: No such file or directory in /home/blogpigs/public_html/wp/wp-config.php on line 16

    Fatal error: main(): Failed opening required '/home/blogpigs/public_html/wp/wpmu-settings.php' (include_path='./:/usr/local/lib/php:/usr/lib/php') in /home/blogpigs/public_html/wp/wp-config.php on line 16

    I have CHMOD, tweaked and jumped up and down, and yelled at my puter but noting seams to work.

    Any ideas from anyone?

    Used WPMU-2005-05-08

  2. blogpig
    Inactive
    Posted 17 years ago #


  3. klaudius
    Member
    Posted 17 years ago #

    I encountered the same problem with wpmu-stable-1_5_1_2.tar.gz. I only get the ERROR msg "Sorry, this blog doesn't exist. Try the homepage instead!", and no data was inputed to database. Can any guru help us?

  4. klaudius
    Member
    Posted 17 years ago #

    No tables or data were inputed to database - it's empty!

    Can anybody give me an initial data.sql file?

    Mmaybe it can help me to install wpmu.

  5. klaudius
    Member
    Posted 17 years ago #

    I searched this problem in Yahoo!,

    3 sites as followed encontered the same problem�

    http://blogs.linux.ie/corexified
    http://blog.biru.co.id/ajiew
    http://www.bbcity.co.uk/user/awct/index.php

    So what is wrong?

  6. NetAndif
    Inactive
    Posted 17 years ago #

    Same problem here. This new wpmu code is broken, as expected.
    I will start fixing if i can find the time.
    Searching for bugs in undocumented code can be very time consuming...

  7. pdeweese
    Inactive
    Posted 17 years ago #

    I get the same error. One thing that I notice on 1.5.1.3 and on 07/07/05 is that the users table doesn't exist! 1.5.1.3 doesn't complain about it, but 07/08/05 does (its installation has been updated). In a fresh install from either version, 07/08/05 reports the following two errors:

    WordPress database error: [Table 'wordpressmu.wp3_users' doesn't exist]
    SELECT ID FROM wp3_users WHERE user_login = 'admin'
    The main blog has already been created. Edit your blogs table and delete the entry for this domain!
    result: error: problem creating blog entry

  8. NetAndif
    Inactive
    Posted 17 years ago #

    Hm, somewhere (think it was on trac.mu.wordpress.org) i read about creating the 'main' blog using wp-newblog.php after initial install.
    But my wpmu installation seemed to be broken, though.
    I know there is heavy development at time.
    Wondering if anyone could get the 'unstable' to work yet...

  9. NetAndif
    Inactive
    Posted 17 years ago #

    When submitting a new post on this forum, you get:

    "bbPress database error: [Unknown column 'topic_start_time' in 'field list']"

    But ok, to the topic ;-)

    I've worked around the glob() issue (php < 4.3 didn't support this function).

    And now i could succeed to the 'well done...' message.
    But after loading the new wpmu site, i get this:

    "No Blog by that name on this system."

    Weird...

  10. NetAndif
    Inactive
    Posted 17 years ago #


  11. NetAndif
    Inactive
    Posted 17 years ago #

    This is the error i get on every install of wpmu unstable:
    "No Blog by that name on this system."

    I noticed these:
    - htacces written
    - rewrite seems to work
    - blogs dir created: blogs.dir/1/ but nothing in there
    - table created wp_1... ?? Why not 'main'?

    What is going wrong there?

    Btw: could you please fix the bbpress error?

  12. testche
    Inactive
    Posted 17 years ago #

    I check the php code and see that the problem is in required php module
    Smarty Templates

  13. driveby
    Inactive
    Posted 17 years ago #

    Hi,

    What exactly is going on with my failed installation of wpmu concerning this error: "Sorry, this blog doesn't exist. Try the homepage instead!"

    Am I doing something wrong or is there something wrong with the zip download and its installation files?

    Im new to wpmu so please forgive me if this is a stupid question. I just want to get the thing up and running asap.

    Thanks

  14. donncha
    Key Master
    Posted 17 years ago #

    Netandif - table names now use numbers instead of names, makes it more logical and easier to maintain!
    Try today's unstable release. It has more debug info.

  15. NetAndif
    Inactive
    Posted 17 years ago #

    Hm, blog numbers are a good addition - could be usefully for referencing and counting purposes.
    But i find it rather important that what i see is a name then a number, when i'm looking at tables and folders - it's much easier to handle, don't you think?

  16. donncha
    Key Master
    Posted 17 years ago #

    It's logical - the numbers match the blog_id field in wp_blogs, and also avoid any filename conflict when more than one site is running on the one install of WPMU. It also avoids security issues with directory names containing special characters.
    The vast majority of people admining a WPMU site in the future will admin it through the interface we're building, not through PHPmyadmin. It is *very* useful being able to quickly find a particular blog's tables but that's still possible, only with a little more searching now. (but again, the common case is unchanged in terms of complexity)

  17. NetAndif
    Inactive
    Posted 17 years ago #

    Donncha,
    if you for example have 'blogname.domain.com', that's good.
    But what if you don't have vhosts support?
    Do you use the blog number or the name for the path? (like 'http://domain.com/1/index.php', this would be bad)

    Just curious

  18. NetAndif
    Inactive
    Posted 17 years ago #

    "the numbers match the blog_id field in wp_blogs"
    Yes, the global wp_blogs table is very useful :-)

    "avoid any filename conflict when more than one site is running on the one install of WPMU"
    Yes. I did'nt think about that.

    "It also avoids security issues with directory names containing special characters"
    This could be achived through a little more checking...but ok

    "The vast majority of people admining a WPMU site in the future will admin it through the interface we're building..."

    For tables, this is ok. But for pathnames IMHO not.

  19. NetAndif
    Inactive
    Posted 17 years ago #

    Can't install wpmu unstable at all.
    There seems to be an error somewhere when the blog path is generated.
    And everything seems to go wrong then with the install.
    - Warning: Invalid argument supplied for foreach() in /***/wp-inst/wp-includes/functions.php on line 314
    - No Blog by that name on this system.
    I even updated my php install.
    I'm giving up now with this. For sure.

  20. donncha
    Key Master
    Posted 17 years ago #

    The blog_id doesn't appear in the path at all, it's translated by mod_rewrite and php code :)
    Netandif - email me at donncha @ linux.ie and maybe we can walk through it more quickly offline.

  21. NetAndif
    Inactive
    Posted 17 years ago #

    Well, i've tried it again, and found exactly four bugs so far:

    - line 314 of functions.php gives 'Invalid argument supplied for foreach()', but only on first install. It can be ignored.

    - beginning at line 64 of wp-settings.php there is being checked for the blog id. This causes the 'No Blog by that name on this system' error.
    So, i've set $blog_id=1, and wow! WPMU is running! :-)
    But ok, this has to be fixed.

    - The 'blogs' link under SiteAdmin->Users is wrong. It points to test.***.com. *g* Additionally, it shows the base domain, and without dots (eg.' wpmudomaincom') instead of wpmu.domain.com/blog
    - The email which is sent to the site admin, contains the wrong urls

    Inspite of these bugs, it looks really great!

  22. donncha
    Key Master
    Posted 17 years ago #

    Thanks Netandif - removed that wp.com link! Can you check the wp_blogs table in your db? Is your url in there? Email me if you want to discuss it in private if it's a testing site.. donncha @ linux.ie

  23. NetAndif
    Inactive
    Posted 17 years ago #

    Seems there is missing a slash at the end of the blog url in the wp_blogs table.
    I've appended this slash in my install. That's all i had to change with the last snapshot.
    Also, this is reflected by the email which is sent - before 'wp-login.php' there should be a slash...

    Anyways, thanks for offering email support...

  24. m2test
    Inactive
    Posted 17 years ago #

    I only get the ERROR msg "Sorry, this blog doesn't exist. Try the homepage instead!" after the installation. Does it need to install the single user version to create the database table first? Or any procedure to install this BLOG - WPMU 1.5.1.3.

  25. donncha
    Key Master
    Posted 17 years ago #

    No, you just need to install WPMU, it will configure the database correctly, or should.
    Try the unstable version instead!

  26. TonyR
    Inactive
    Posted 17 years ago #

    I had this and like NetAndIf - I appended the / to the end of my blog url, it fixed it :)

    Thanks NetAndIf

  27. Ste_000
    Member
    Posted 17 years ago #

    scuse me ....at last which is the solution for this problem? i'm italian scuse me for my english tnk !

  28. TonyR
    Inactive
    Posted 17 years ago #

    In your wordpress table wp_blogs

    Make sure that the entry in the PATH has a slash at the end. as an example change it from

    /myblog

    to

    /myblog/

    Its a manual change each time Im afraid :(

  29. Ste_000
    Member
    Posted 17 years ago #

    thank you very much for yuor answer but i don't found the table wp_blogs...is a php page? or a sql table of the database? tnk

  30. Ste_000
    Member
    Posted 17 years ago #

    nothing ? :(

About this Topic