The MU forums have moved to WordPress.org

Installed in root, how to administer (5 posts)

  1. lieb
    Inactive
    Posted 18 years ago #

    I installed wpmu in the root directory of a virtual server. I can create new blogs but I can't administer the root blog when I go to /wp-login.php it comes back with
    Fatal Error

    Could Not Find Blog!
    Searched for blogs.sou.edu/ in wpmu::wp_blogs table. Is that right?
    Please check that your database contains the following tables:
    wp_blogs
    wp_users
    wp_usermeta
    wp_site
    wp_sitemeta
    wp_sitecategories

    All the tables exist. What can I do?

  2. itdamager
    Member
    Posted 18 years ago #

    Check wp_blogs, wp_site, and wp_sitemeta tables in the database for blogs.sou.edu and my guess would be you'll find the site's domain name incorrectly entered into one or more of the tables. Edit the value(s) to correct it.

  3. lieb
    Inactive
    Posted 18 years ago #

    It all looks fine to me. Domain is what it should be and path is /.

  4. lieb
    Inactive
    Posted 18 years ago #

    Wait a minute... the meta data had the domain name in uppercase Blogs instead of blogs. I changes it and now I'm getting a login prompt....

    mysql> select meta_key, meta_value from wp_sitemeta where meta_key="site_name";
    +-----------+---------------+
    | meta_key | meta_value |
    +-----------+---------------+
    | site_name | Blogs.sou.edu |
    +-----------+---------------+
    1 row in set (0.00 sec)

    mysql> update wp_sitemeta set meta_value="blogs.sou.edu" where meta_key="site_name";
    Query OK, 1 row affected (0.00 sec)
    Rows matched: 1 Changed: 1 Warnings: 0

    mysql> select meta_key, meta_value from wp_sitemeta where meta_key="site_name";
    +-----------+---------------+
    | meta_key | meta_value |
    +-----------+---------------+
    | site_name | blogs.sou.edu |
    +-----------+---------------+

  5. mshao
    Member
    Posted 18 years ago #

    Lieb,
    How did you install wpmu under the root? I have tried to do the same but no success. Can you please reply to my post if you can?

    http://mu.wordpress.org/forums/topic.php?id=838&replies=5

    Thanks in advance.

About this Topic