The MU forums have moved to WordPress.org

login page problem (15 posts)

  1. drx
    Inactive
    Posted 18 years ago #

    Hi all
    I have problem to login me & or a client
    when pressing the login button wp-login.php page will load again & nothing happens so I can't login
    plz help me

  2. ergate
    Member
    Posted 18 years ago #

    Same problem using 12-23 build.

    Everytime when trying to log in, the login screen reloads. Even if I then try and call admin or any admin pages directly it re-directs to login. If I try and login with incorrect login info it does tell me wrong username or password.

  3. ergate
    Member
    Posted 18 years ago #

    Look at this post, 742.

    I looked at wp-settings lines 304 to 307 were not commented out, but lines 298 to 314 were, I uncommented them and now it works.

  4. drx
    Inactive
    Posted 18 years ago #

    I have 12-24 build
    what uncomment means ? you mean that I should
    delete these lines ?

  5. drx
    Inactive
    Posted 18 years ago #

    thanks ergate
    Now it's working good

  6. mshao
    Member
    Posted 17 years ago #

    Post 742 is not found. Can anyone help me on this?
    The problem is that a blogger has to login twice in order to get to admin page. Here's how it works. Assume my site is mysite.com, the blog is blogger.mysite.com. On mysite.com, the blogger clicks on the Login link. It goes to http://www.mysite.com/wp-login.php . After types in login name, pwd, and click on the login button. The page gets reloaded with URL as http://archexpression.com/wp-login.php?redirect_to=%2Fwp-admin%2Fprofile.php (sometimes the URL becomes http://blogger.archexpression.com/wp-login.php?redirect_to=%2Fwp-admin%). The blogger has to do the whole thing one more time before getting to the admin page. Another problem is on the admin page, the Logout link is not working. It doesn't do anything when you click on it. I am using IE. FireFox has the similar issue.

    I am kind of surprised that WPMU hasn't ironed out this kinds of issues (or bugs). They are too obvious.

    Thanks for any inputs.

  7. Le-Fay
    Member
    Posted 17 years ago #

    Hi,
    I'm having the same problem over here.
    anyhow here is the link to 742.

    I'll try and check it out.

  8. Le-Fay
    Member
    Posted 17 years ago #

    Well,
    As I said, we're having the exact same problem mshao is describing over here.
    this 742 doesn't seem to be the fix.
    I'll keep you posted.

  9. samchng
    Member
    Posted 17 years ago #

    Do a search on the script I use for login. It will redirect you to the second login URL so your user can do a one time login. ;)

  10. mshao
    Member
    Posted 17 years ago #

    samchng,
    I don't understand you. What script? Please explain.

    Thanks

  11. mshao
    Member
    Posted 17 years ago #

    Just found that this login problem only happens in FireFox. IE is OK. But the logout problem is the other way around. I think it has something to do with cookies.

  12. samchng
    Member
    Posted 17 years ago #

  13. donncha
    Key Master
    Posted 17 years ago #

    mshao - delete the cookies for your site from your browser and try again.

    I'm debugging the install process, so I installed it to the root directory, logged in fine, then tried in /blogs/ and after some tinkering (which will be submitted shortly) it worked, but I got a "session has expired" message when I tried to log in. Only after I deleted the cookies did it work.

  14. mshao
    Member
    Posted 17 years ago #

    samchng,
    Your script works great for the login page. Thanks a lot. Except one thing that you are aware of. If I enter an invalid login name, I see a Fatal Error. Any update on that?

    Thanks

  15. 3baid
    Member
    Posted 17 years ago #

    I got this problem after clearing the wordpress URL field and saving.

About this Topic