The MU forums have moved to

Files exist in blogs.dir but aren't visible in blogs (7 posts)

  1. unco
    Posted 16 years ago #

    Hi -

    I upgraded to 1.3.3 not too long ago and clicked "Upgrade" in the admin backend. After that, users noticed their images were no longer visible. Now when they upload new images, they go to /wp-content/uploads/image. Everyone's in the same folder!

    I've read every topic that seems related to this issue, but I'm not finding any solutions.

    Here's an example blog entry that exhibits the problem.

    Her images were all just fine before I clicked "Upgrade." :(

    Does anyone have any ideas about how I can fix this?


  2. Trent
    Posted 16 years ago #

    The files are directed through your .htaccess so I would check to make sure everything is still in there to direct the blogs. As well, check out a couple blogs to make sure it is still showing the correct path when you edit the blog in the Site Admin.


  3. unco
    Posted 16 years ago #

    Does anyone have a properly 1.3.3 working .htaccess I can compare to?

    I noticed newly created blogs have a different path than older blogs. The new blogs upload to the /wp-content/uploads folder, where everyone can see all of the files.


  4. dgilmour
    Posted 16 years ago #

    I hit this problem too, and can't remember exactly how I got past it. I'm sure it was .htaccess. This is a working .htaccess from a V1.3.3 subdirectory installation. (Blog names are like

    RewriteEngine On
    RewriteBase /blogs/

    # Rewrite to
    RewriteCond %{HTTP_HOST} ^www\.(.*)
    RewriteRule ^(.*) http://%1/$1 [R,L]

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

  5. unco
    Posted 16 years ago #

    Thanks. I've copied the default .htaccess back in and have tried this one too, but it's still not working. Do you remember if you had to go as far as completely reinstalling everything to get yours working again?

  6. dgilmour
    Posted 16 years ago #

    No, I only backed out twice, once for strange symbols and again after losing categories"...

  7. unco
    Posted 16 years ago #

    Well, I have the images working again. I noticed that new blogs were being created with their files directories chmod 777, so I made the rest of them 777, made sure their upload directories were /wp-content/blogs.dir/files instead of /wp-content/uploads and then everything was ok. I also had replaced the .htaccess file, wp-config.php and everything in /wp-admin and /wp-includes, so I'm not sure what caused the image displays to work again. I hate when that happens!

    Thanks everyone for the help. Now to figure out why feeds aren't working. :)

About this Topic