The MU forums have moved to WordPress.org

plain english please (12 posts)

  1. epdady007
    Member
    Posted 16 years ago #

    can someone explain this in plain english:
    Install
    =======
    Unarchive into a web directory and call that directory through your
    browser and web server. Follow the instructions and links and all
    should work fine.

    i have wpmu in a folder in my public_html
    what should i do with it other than give up!

  2. jcow
    Member
    Posted 16 years ago #

    If you have uploaded the wpmu folder into public_html, now you should:

    open your web browser.
    go to this url: http://www.yourwebaddress.com/wpmu/
    where yourwebaddress should be switched out with... your web address of course.
    follow the instructions to install.

    Things you need to know.

    At this piont in the development to my knowledge, you absolutely have to have a wildcard dns setup. This usually has to be done by your host, unless you are the host.

    You should go ahead and setup your mySQL database before installing, the main part of the installation is telling it your database info (name, username, password, and prefix [wp_], and localhost)

    hope that helps...

  3. andrewbillits
    Member
    Posted 16 years ago #

    it's not required to use wildcard dns. You could simpply choose not to use vhosts while installing and the blogs will be in a directory type format instead subdomains. :)

  4. jcow
    Member
    Posted 16 years ago #

    Have you tried that and gotten it to work. I spent a few hours trying to get it to work with vhosts turned off, and I got nowhere. I finally sent an email to my host and they set up the wildcard pretty quickly for me.

    So unless something has changed in the last couple weeks, I couldn't get it to work with the nightly i am using (wpmu-2006-03-27). I just figured it isn't working at this time.

  5. andrewbillits
    Member
    Posted 16 years ago #

    It's working. It's just difficult to setup. The largest problem is that since few people use it the level of support for it is near the bottom of the bucket.

  6. jcow
    Member
    Posted 16 years ago #

    Well that is good to know. Thank you for setting me straight on that. I suppose all of this support will get figured out eventually...

  7. trickmandan
    Member
    Posted 16 years ago #

    I am having the same issue. I can install and run the directory method, but not sub domain method.
    I just get a not found for my new sub domain blogs??
    My vhost file looks like this:

    ServerAlias *.mysite.com
    <Directory /path/to/my/home/directory>
    AllowOverride FileInfo
    </Directory>

    My DNS looks like this:
    *.mysite.com. A ipnum.ipnum.ipnum.ipnum

    I have been all over the web for the last several days.
    Do you have any suggestions?
    Do you have any stepped tests?

    trickmandan
    http://BizBlogPro.com

    I am using build 2006-03-29

  8. trickmandan
    Member
    Posted 16 years ago #

    You can see my actual blog at:
    http://BizBlogPro.com/blog

    thx,
    trickmandan

  9. trickmandan
    Member
    Posted 16 years ago #

    #fixed
    Configuration for Plesk in Apache Server on a Linix Box
    I have been working on this for days and found a solution that worked.
    *tear of joy*

    add DNS entry: *.mysite.com. CNAME mysite.com.
    (you should have access to DNS entries in your Plesk interface)
    If you don't have access, contact your server administrator.

    log into box with Putty
    PuTTY: A Free Telnet/SSH Client
    Find Putty Telnet/SSH Client

    enter: su
    + password again

    change directory to /
    change directory to /home/httpd/vhosts/mysite.com/conf

    Find How to use VI Editor

    --- enter: vi httpd.include
    1. find the <VirtualHost tag. (the area where you see "ServerName"
    1a. add this line in the tag: ServerAlias *.mysite.com

    2. find the <Directory tag that points to your document root
    2a. add this line just before the tag end: AllowOverride FileInfo

    Finish by restarting your server. You can do this in the Plesk from the System/Server menu or Host Manager

    Note: Plesk documents state that you can use vhost.conf, but I had no luck with this.
    How to configure MU in Plesk

    Thanks for all the help here,
    trickmandan
    BizBlogPro
    http://BizBlogPro.com/blog

  10. bambam4479
    Member
    Posted 16 years ago #

    You should not make any changes to httpd.include because they won't stick when upgrading Plesk. Your best bet is to just create a vhost.conf and vhost.ssl.conf and enter the information here.

    Then reconfigure the domain in Plesk by calling "$PRODUCT_ROOT_D/admin/bin/websrvmng -a -v" where $PRODUCT_ROOT_D is where Plesk is located on the server, in my case its /usr/local/psa so complete path is "/usr/local/psa/admin/bin/websrvmng -a -v". I'd then restart Apache just to make sure it gets restarted.

    Also, remember, if you just added the wildcard to your DNS, it might take up to 48 hours to propogate around the 'net so just be patient

  11. trickmandan
    Member
    Posted 16 years ago #

    Thanks for the tip BamBam4479!

    I could not call websrvmng. I even went into the $PRODUCT_ROOT_D/admin/bin/ directory and tried to enter
    websrvmng -a -v

    I just got back an error message saying cmd websrvmng not found??

    I must have drain bramage?!

    I can run websrvmng -a -v in putty right?

    trickmandan
    BizBlogPro
    http://BizBlogPro.com

  12. bambam4479
    Member
    Posted 16 years ago #

    try doing a "locate" on "websrvmng", so from the Putty (or any other ssh console it would be the following for me on RHEL3:

    Note: [user@server /]# is just what is displayed on the console when I'm logged in.

    [user@server /]# locate websrvmng
    /usr/local/psa/admin/bin/websrvmng
    /usr/local/psa/admin/sbin/websrvmng

    Then just call
    [user@server /]# /usr/local/psa/admin/bin/websrvmng -a -v

About this Topic

  • Started 16 years ago by epdady007
  • Latest reply from bambam4479