The MU forums have moved to WordPress.org

Pages not displaying (55 posts)

  1. billdennis5
    Member
    Posted 14 years ago #

    No. The admin "write" page was covered with these messages, and I got the "cannot modify header" message with I hit the publish button on a test Page. The page never showed up, either.

  2. andrea_r
    Moderator
    Posted 14 years ago #

    make sure you didn't accidentally add a blank line to the end of that file. That's what gives the "headers already sent" errors.

  3. billdennis5
    Member
    Posted 14 years ago #

    OK, I went back and followed the instructions again. I am seeing the publish button when I try to write posts, but not when I try to write a Page. All I see in write Page page is "submit for review."

    This happens no matter what username I am using (I'm an admin for several usernames).

    And it only happens when I am trying to publish a Page at blogpeoria.com ... it doesn't happen when I write a Page in any other blog.

  4. billdennis5
    Member
    Posted 14 years ago #

    bumping

  5. lunabyte
    Member
    Posted 14 years ago #

    Let me see if I have this right.

    When you go under the main blog, to manage->page you don't get a list of pages as expected? It's more like the top bar of the list/columns, then nothing else?

    I just did a 2.6 upgrade last night, and had this happen. Nowhere else, just blog_1.

    The fix, as silly as it seems, was to go to:

    -- your domain here--/wp-admin/page.php?action=edit&post=2

    Where the 2 in post=2 is an id of one of your pages.

    Don't do anything to the page, just save it.

    Pages back in business.

    Not sure why this occurred, but the quick analysis I ran through showed that the function page_rows in /wp-admin/includes/template.php wasn't getting past line 566.

    It would run through the foreach loop on/around 552, then just stop when it was done.

    I ran out of time I was able to spend on it, but if someone runs into a similar problem, re-saving a page seemed to correct it.

  6. billdennis5
    Member
    Posted 14 years ago #

    Done. All I got when I tried this was a page with the normal admin header and the rest was blank, except for a message: "You are not allowed to edit this page."

  7. lunabyte
    Member
    Posted 14 years ago #

    Bummer.

    Not sure what you did when you upgraded, but something got hosed.

    I've done upgrades from 1.5.1->2.6, 1.3->2.6, and 1.3->2.6+(from trunk), and other than the above little thing, all has been well.

  8. billdennis5
    Member
    Posted 14 years ago #

    I had this problem when I was using 1.3.1. I only recently upgraded to 1.5.

    Not an upgrade problem.

    Wouldn't the fact that this problem has followed me from one upgrade to the next suggest that it's a problem with a setting that's storied in my database?

  9. lunabyte
    Member
    Posted 14 years ago #

    If it were me, I wouldn't have upgraded until it was resolved. Upgrading probably just compounded the problem(s).

    You may want to try, if you haven't already, removing all files (except wp-content) and try uploading fresh ones from the 1.5.1 release. Completely deleting your wp-admin and wp-includes directories, and all the files that sit in the site root.

    Not saying it will fix it, but it could be a problem with that.

    Other than that, you could create a new user, make them a site admin, and try using that login to see if it works.

    Have you tried removing all plugins and such, to make sure it isn't a plugin issue?

  10. billdennis5
    Member
    Posted 14 years ago #

    If it were me, I wouldn't have upgraded until it was resolved. Upgrading probably just compounded the problem(s).

    Funny. I was advised repeatedly that upgrading would help me to get held, because no one wanted to try to support an older version. Oh well.

    And I did create another user and give him admin rights. Same problem.

    I'm sure I did the plugin removal thing. Will try again, though.

    Thanks for the advice.

  11. billdennis5
    Member
    Posted 14 years ago #

    I deactivated all plugins and then manually deleted everything from the plugin and mu-plugins folders.

    Same problem.

    It's gotta be a setting in my database, I'm thinking.

    Just so everyone who is trying to help is clear ... This is a screenshot of what I am seeing when I try to write a page while logged in as an administrator:

    http://blogpeoria.com/images/write_page_screenshot.gif

  12. andrea_r
    Moderator
    Posted 14 years ago #

    luna - this is a long thread, he's tried pretty much all that. Something is up somewhere.

    And how come no one noticed this a few posts back?

    "Checking cap manage_options
    Checking cap level_0
    Checking cap moderate_comments"

    Maybe that level_0 is the issue when the rest in the list are all 10?

    Bill, if you haven't guessed by now, you're stumping all of us. :D

  13. billdennis5
    Member
    Posted 14 years ago #

    I guessed a long time ago ...

    ;-)

    Seriously, I appreciate the help.

  14. billdennis5
    Member
    Posted 14 years ago #

    Doing the bump ...

  15. billdennis5
    Member
    Posted 14 years ago #

    Bumping, just in case someone has any bright ideas ..,

  16. agenius
    Member
    Posted 14 years ago #

    I have the same issue. We loaded through plesk. Then upgraded manually. The pending is there but no publish button on pages. When we first loaded we had to manually set the user permissions after seeing the "you do not have permission to .." message. But everything else is working fine it seems except this.

    You are not alone!

  17. billdennis5
    Member
    Posted 14 years ago #

    I am sorry for your misery, but comforted by the fact that I am not alone. Let me ask: Do you have the option to set a static page as the front page? I do for member blogs, but not at http://blogpeoria.com

  18. andrea_r
    Moderator
    Posted 14 years ago #

    Well, the fact that someone else is having the same problem is actually GOOD.

    For starters, it means you're not crazy. :)

  19. MrBrian
    Member
    Posted 14 years ago #

    That statement is not definitive :P

  20. billdennis5
    Member
    Posted 14 years ago #

    Five of my seven of my personalities resent that remark.

  21. billdennis5
    Member
    Posted 14 years ago #

    OK, folks, It's been two weeks. Time to bump us this post again.

    Guess what! I discovered a brand new problem that is no doubt related to this problem.

    I wrote a post, tried to delete it -- WITHOUT logging out -- and was told that I did not have permission to delete this post.

    I cannot help but think that this problem is somehow related to a setting in my database.

    PLEASE someone find a solution. This is seriously making it impossible to turn this site into a group journalism site. I want the front page of this blog to be a portal, and I can't make the changes I need to make.

  22. billdennis5
    Member
    Posted 14 years ago #

    NOTE: Andres_r is the BOMB. She found the problem, which I cannot even begin to explain, and fixed it. I am now able to write and public pages, delete posts and set a state page as the front page of my domain-level WPMu blog.

    Folks, HIRE this person. Highly recommended.

  23. andrea_r
    Moderator
    Posted 14 years ago #

    Oh stop... *blushes* :D

    It was missing info in wp_1_options:wp_1_capabilities. It *looked* right at first glance, but it was ultimately too short when I compared it to the same info in another install. The capabilities defined everywhere else for the site admin were correct.

    Dunno what caused it, but that's what fixed it.

  24. billdennis5
    Member
    Posted 14 years ago #

    Is there any way this problem is what was causing my site to create such a load on the hosted servers I've been using?

  25. andrea_r
    Moderator
    Posted 14 years ago #

    Nope, I don't see how it could.

About this Topic

  • Started 14 years ago by billdennis5
  • Latest reply from andrea_r