The MU forums have moved to WordPress.org

Cannot Load ... error on every external Admin Page? (10 posts)

  1. suleiman
    Member
    Posted 13 years ago #

    I'm getting this "cannot load [plugin name here]" error on every single admin page of my mu install, with the exception of the base admin pages (themes, users, blogs, options, etc.,)

    Has anyone bumped up against this one before? I'm struggling to try and figure out what could be going wrong.

  2. suleiman
    Member
    Posted 13 years ago #

    And the culprit is....montyspam. I'm somewhat surprised, but the good news is the developer is quick to the flip with fixes like these, so hopefully it will get resolved soon.

  3. lunabyte
    Member
    Posted 13 years ago #

    I noticed that once installed, the site admin tab now defaults to the monty page.

    From the readme file, it doesn't appear that it should be doing that, but it was. Tried it on 4 different test beds, same result.

    Haven't had a chance to email about it yet though.

  4. macgruder
    Member
    Posted 13 years ago #

    @ Suleiman,
    Thanks, I'll look into this. Do you have WP 1.5 installed? Do you have Plugin Commander installed?

    @ Lunabyte,
    Yes, that should not be the case. In my initial development when I started, Monty was the last menu, but somehow on one of the WP updates he moved to the left. I like to think that he is striving for attention :-)

    When I was developing on 1.3, I was unable to find a way to install Monty without adding one file to the wp-admin folder. The hooks & actions seemed to only work for sitewide blogs but not as a single addition to an admin submenu. I think that the method I used my conflict with 1.5. I'll take a look.

  5. macgruder
    Member
    Posted 13 years ago #

    "Do you have Plugin Commander installed?"
    Ignore that! The problem happens for me on 1.5 too. I'll try to get the fix asap.

  6. lunabyte
    Member
    Posted 13 years ago #

    Well, what it's done is take over wpmu-admin.php, and the default site admin link now point to monty instead of wpmu-admin.

  7. macgruder
    Member
    Posted 13 years ago #

    Quick fix.
    Go to /mu-plugins/montyspam.php

    Look for [near the top]
    add_action( '_admin_menu', 'montyspam_admin_menu' );
    and change it to
    add_action( '_admin_menu', 'montyspam_admin_menu' , 1999);

  8. lunabyte
    Member
    Posted 13 years ago #

    OK, that's good for that one, but why does it make the Site Admin link point to monty instead of wpmu-admin.php?

    I'm talking about the top level site admin link, not where it's at as a submenu.

  9. macgruder
    Member
    Posted 13 years ago #

    You mean the 'Admin' link on the right hand side:
    *Admin*, Settings, Plugins, Users

    That's pointing to Monty still? You did a refresh right :-) Because on my 1.5.1 install it points to wpmu-admin.php as expected, or am I looking at the wrong menu/link?

    Anyway, clearly the way I have it set up is not the best way. I never liked the idea of putting a file within wp-admin. I know before I had tried to use
    add_submenu_page ('wpmu-admin.php' ...
    but it wasn't working quite as I wanted.

    It's clear the best way is to use add_submenu_page() , and I'll need to update the montyspam/admin.php file (i.e. moving the stuff into a function) which will take a little time, but should not be too much of a challenge.

    So rather than trying a temporary fix, I'll get it properly fixed.

  10. suleiman
    Member
    Posted 13 years ago #

    thanks for the fix macgruder, it worked for me.

About this Topic

  • Started 13 years ago by suleiman
  • Latest reply from suleiman