The MU forums have moved to WordPress.org

Image "http://yblog.com/user/files/2008/03/s.gif" cannnot be displayed. errors (11 posts)

  1. horrorshow
    Member
    Posted 14 years ago #

    I just recently upgraded from 1.3.3 to 1.5.1, and I am seeing this error when I click on an image in a post (image that's linked and opens in its own page.) In firefox only.

    The image "http://yblog.com/user/files/2008/03/sample.gif" cannnot be displayed, because it contains errors.

    I've searched around, but haven't found any info in the forum. I hope I didn't miss it. Please let me know if anyone else have seen this error.

    On a side note,
    Looks like 1.5.1 really doesn't like plugins that creates a separate Admin menu. I've resorted to using a sub menu. There was a post in the forum regarding this problem for an earlier release of wpmu, and there was a patch. I looked at the patch, and it has been incorporated into 1.5.1 So I am puzzled why it wouldn't work.. but anyway, I've found a work around.

    thanks.

  2. tdjcbe
    Member
    Posted 14 years ago #

    It's always a good idea to give the actual error that you are receiving. We can't see what is occurring when you substitute potyions of it out. Also a link would be a good idea. The debugging page linked to from the readme file mentions this.

    Checking the error logs and seeing if the file actually exists would also be a good idea.

    But from what the error says, it's the image that is the issue. It may be corrupt.

    Sub pages are fine. Again, specifics please would be helpful. We can't help much unless we know what actually is occurring.

  3. horrorshow
    Member
    Posted 14 years ago #

    tdjcbe,

    My apologies. Here is the actual url:

    http://achillesblog.com/dennis/files/2008/03/activate_achilles_widget_plugin.gif

    The error is:

    The image "http://achillesblog.com/dennis/files/2008/03/activate_achilles_widget_plugin.gif" cannot be displayed, because it contains errors.

    I wondered if it was a corrupt image as well, but it was fine on wpmu 1.3.3 I was having the same problem with a jpg.

    The link is from this page:

    http://achillesblog.com/dennis/achilles-timeline-widget/

    It's the 3rd image.

    The problem occurs on windows xp, firefox 2.0.0.14
    It's fine on firefox/ubuntu.. internet explorer/XP
    So it could very well just be my computer.. but it wasn't happening before the upgrade.

    The image does exist since it opens in IE.

    If it works fine for you on firefox/xp then I'll attribute it to my xp/firefox, and I'll live with it.

    thanks for your response.

  4. lunabyte
    Member
    Posted 14 years ago #

    I checked all three images on that page. Works just fine. FF/Safari, Mac.

  5. horrorshow
    Member
    Posted 14 years ago #

    lunabyte,

    It works fine when you click through the third image, and it displays just the image in firefox/XP?

    If so, then it's my firefox/xp issue. thanks for taking the time.

  6. lunabyte
    Member
    Posted 14 years ago #

    It works just fine in FF/Mac, clicking through to the image, right clicking and viewing image, etc.

    I don't know about XP. I refuse to touch windows.

  7. horrorshow
    Member
    Posted 14 years ago #

    lunabyte,

    Fair enough. :)

  8. tdjcbe
    Member
    Posted 14 years ago #

    I see it as well in WinXP/Firefox 2.0.0.14 and IE 6.0.2900.

    Was there anything in the webserver error logs?

    Do note that the content drops down in IE under the left sidebar.

  9. horrorshow
    Member
    Posted 14 years ago #

    tdjcbe,

    Yes, here's the last few entries in the error_log, but it looks like they are errors from running-time-1.1.php. I've just removed it from the plugins since I am not using it anyway. I don't see anything else either in the httpd error_log or the error_log in the root wordpress mu installation.

    "Do note that the content drops down in IE under the left sidebar."

    What do you mean by this? I am don't quite understand what you mean. thanks.

    01-Jun-2008 13:36:28] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND post_date != '0000-00-00 00:00:00' AND post_status = 'publish' ORDER BY wpos' at line 1 for query SELECT wposts.ID, wposts.post_dat
    e FROM wp_38_posts wposts, wp_38_post2cat wpostcat WHERE wposts.ID = wpostcat.post_id AND wpostcat.category_id = AND post_date != '0000-00-00 00:00:00' AND post_status = 'publish' ORDER BY wposts.post_date DESC LIMIT 1 made by runningtime_daterange_core

    [01-Jun-2008 13:36:28] WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the
    right syntax to use near 'AND post_date != '0000-00-00 00:00:00' AND post_status = 'publish' ORDER BY wpos' at line 1]
    SELECT wposts.ID, wposts.post_date FROM wp_38_posts wposts, wp_38_post2cat wpostcat WHERE wposts.ID = wpostcat.post_id AND wpostcat.category_id = AND post_dat
    e != '0000-00-00 00:00:00' AND post_status = 'publish' ORDER BY wposts.post_date DESC LIMIT 1

    [01-Jun-2008 13:36:28] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the ri
    ght syntax to use near 'AND wposts.post_date != '0000-00-00 00:00:00' AND wposts.post_status = 'publish'' at line 1 for query SELECT wposts.ID, wposts.post_dat
    e FROM wp_38_posts wposts, wp_38_post2cat wpostcat WHERE wposts.ID = wpostcat.post_id AND wpostcat.category_id = AND wposts.post_date != '0000-00-00 00:00:00'
    AND wposts.post_status = 'publish' ORDER BY wposts.post_date LIMIT 1 made by runningtime_howold_core
    [01-Jun-2008 13:36:28] WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the
    right syntax to use near 'AND wposts.post_date != '0000-00-00 00:00:00' AND wposts.post_status = 'publish'' at line 1]
    SELECT wposts.ID, wposts.post_date FROM wp_38_posts wposts, wp_38_post2cat wpostcat WHERE wposts.ID = wpostcat.post_id AND wpostcat.category_id = AND wposts.p
    ost_date != '0000-00-00 00:00:00' AND wposts.post_status = 'publish' ORDER BY wposts.post_date LIMIT 1

  10. horrorshow
    Member
    Posted 14 years ago #

    Forgot to mention, here's some additional errors Looks like there is a bunch of these:

    [Sun Jun 01 15:04:46 2008] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.

  11. horrorshow
    Member
    Posted 14 years ago #

    Figured out what the problem was. This wasn't limited just to WPMU. It looks like Skype Plugin for Firefox breaks the images. Simple un-install of the Skype Plugin and restart of the browser fixed the problem.

    Damn you Skype!!!

About this Topic

  • Started 14 years ago by horrorshow
  • Latest reply from horrorshow