The MU forums have moved to

Apostrophe in tags generates errors (3 posts)

  1. dsader
    Posted 16 years ago #

    Blog 234 tried to add a tag(/wp-admin/edit-tags.php#addtag) with an apostrophe "what I've learned" and it was not added and generated the following sql error in site error_log

    [02-Jun-2008 11:30:42] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 've learned', 'what-ive-learned', '0')' at line 1 for query INSERT INTO wp_234_terms (term_id, name, slug, term_group) VALUES ('4708', 'What I've learned', 'what-ive-learned', '0') made by wp_insert_term

    I've tried the same tag in a single user version wp2.5 and the tag enters as usual.

    Is there something added(removed) to WPMU1.5.1 that bjorks tags with apostrophes?

    wp_insert_term is found in wp-includes/taxonomy.php, but I can't spot the difference.

    Anyone else able to bjork a tag such as this?

  2. dsader
    Posted 16 years ago #


    Anyone seeing SQL errors in logs related to tags(wpmu1.5.1) with an apostrophe in it?

  3. lunabyte
    Posted 16 years ago #

    Not that I've noticed. But that doesn't mean it hasn't happened.

About this Topic