The MU forums have moved to WordPress.org

Image Subdirectories and Thumbnails (2 posts)

  1. casstech
    Member
    Posted 16 years ago #

    I am having a problem with thumbnail creation when uploading images.

    In summary, the working installation is creating the thumbs in dated subdirectories, and the non-working installation is not.

    I am using the same 1.5.1 install files on two servers hosted by the same company. The .htaccess is the default that comes with the 1.5.1 download. The gd library version is the same on both servers: php-gd-5.1.6-15.el5

    On the working installation, I get the two resized images in subdirectories matching the current month:

    /htdocs/wp-content/blogs.dir/1/files/2008/06/test.jpg
    /htdocs/wp-content/blogs.dir/1/files/2008/06/test-150x150.jpg
    /htdocs/wp-content/blogs.dir/1/files/2008/06/test-225x300.jpg

    On the non-working installation, I see only the original size image two directories up:

    /vservers/christianacaqq2a/htdocs/wp-content/blogs.dir/5/files/test.jpg

    I am uploading an image called test.jpg, 100KB, 800x600, RGB color. I am trying the same image on both servers. Directory permissions on both servers are 755 all the way back up to wp-content.

    I would sincerely appreciate any advice. Thanks in advance.

    Rob

  2. casstech
    Member
    Posted 16 years ago #

    In my case, the uploads directory was not set correctly in php.ini. Hope this helps someone else.

About this Topic

  • Started 16 years ago by casstech
  • Latest reply from casstech