The MU forums have moved to WordPress.org

Root Error: The blog you have requested is not installed properly (23 posts)

  1. tmote
    Member
    Posted 14 years ago #

    The complete error is this:

    "The blog you have requested is not installed properly. Please contact the system administrator."

    I obtained the TRUNK from SVN, ran through setup (without any errors) and applied everything mentioned in README.txt.

    http://blog.krumisd.net

    There is nothing special here: Linux (CentOS 5.1), Apache, MySQL (On a separate box)

    Anyone have something off the top of their head? I have looked over logs and still see nothing.

    I will provide any answers that I can, very promptly. This is my project for the week! :)

    As a side note, I did have non-MU working in this exact config without any issues. I have also had MU working on a Windows box but otherwise an exact config (Apache even).

  2. MrBrian
    Member
    Posted 14 years ago #

    Try the latest stable release from the download page.

  3. imgoel
    Member
    Posted 14 years ago #

    Hi, i am having the same problem. but, i have noticed some unusual things.
    At the time of installing wpmu i had activated subdomains. but, now the system is creating new blogs as subdirectories.

    for e.g.
    http://goelji.com - main blog
    http://anitka1984.goelji.com - error blog

    Please, help me out.

  4. MrBrian
    Member
    Posted 14 years ago #

    check wp-config.php and make sure VHOST is not ON.

  5. IA-joe
    Member
    Posted 14 years ago #

    I have the same problem and also no answer. This problem happens only since wpmu 2.6

  6. franz.skaaning
    Member
    Posted 14 years ago #

    Same here. I also tried to make a brand new install with 2 new domains. I am open for testing :)

  7. franz.skaaning
    Member
    Posted 14 years ago #

    Argh. Sorry for posting. I forgot to add the domains in the domainmapper. I added the first domain as server IP.

  8. boonika
    Member
    Posted 14 years ago #

    Anyone managed to solve this problem? I did more than 20 MU installation so far and had some problems before but this is the first time I see this message.

  9. boonika
    Member
    Posted 14 years ago #

    Just for the record. I've deleted all files and uploaded new ones. I've also used another database(name). Don't know if that has got anything to do with my problem but it's working now.

  10. kennibc
    Member
    Posted 14 years ago #

    I have this issue now too! When I login as site admin and look at the broken blog via "edit" in the admin panel, I see this issue where the broken blog settings should appear...

    Blog options (wp_761_options)

    Warning: Invalid argument supplied for foreach() in /<my server path>/wp-admin/wpmu-blogs.php on line 144

    Also, there are no user "Role" options I can assign the new user. Ironically, in line 144 it looks to address the default role as subscriber??? $edit_blog_default_role = 'subscriber';

    Anyone have a solution? Could this be a plugin issue?

  11. kennibc
    Member
    Posted 14 years ago #

    I just tried removing most of the WPMU plugin files from the directory with little success.

    For the life of me I cannot figure this out. Previously created blogs and users are fine. They can login and work with their blog. It is just new users when they login and create a new blog the blog settings are not setup properly. which kicks back the error.

    Someone please help. This is really bad. I keep running in circles trying to figure this out and I am afraid if I do anything else I may just be creating more problems.

    I have the latest version 2.6.2

  12. kennibc
    Member
    Posted 14 years ago #

    Upon further exploration, I cannot create a blog from the admin panel. Seems Blog Creation is broken with this issue!

    I went to the admin panel to create a new blog with an existing user as well as an attempt with a new user and it was broken as well.

  13. andrea_r
    Moderator
    Posted 14 years ago #

    Something is definitely up on your end.

    Double check that all files are there. Read over the config file. Check your error logs. All that fun server-tech stuff.

  14. kennibc
    Member
    Posted 14 years ago #

    OK. Problem solved. In wp-config I had set the DB-Charset to UTF-8. Apparently it couldn't write it to the database.

    I changed the setting to blank and I was able to login properly.

    Our site is over 3-4 years old and I think the charset is latin1??? Can anyone help me out with a step by step tutorial to move the database to UTF8?

  15. kennibc
    Member
    Posted 14 years ago #

    I can't speak for the others on this post, but definetly check the wp-config file and try it.

  16. andrea_r
    Moderator
    Posted 14 years ago #

    If the charset is working fine, then I'd leave it. latin1 seems to be the default on cpanel boxes and in the earlier days of WP code, it just said "use the default". Well, now that it's specifying, that's where some people run into issues.

    hadn't seen it deny write access like that before though.

  17. dgilmour
    Member
    Posted 13 years ago #

    @kennibc

    Can anyone help me out with a step by step tutorial to move the database to UTF8?

    I did a note on the steps I took which might help.

  18. Arphia
    Member
    Posted 13 years ago #

    We've had a WPMU site up and running for about 8 months, currently 1154 blogs and 1127 registered users.

    I was editing one of my blogs. Went into Site Admin. Noticed one of the early test blogs we set up last year, an inactive one. I clicked to delete it, and now the blog I was editing no longer displays properly, although it's still there in the blog list.

    If I try to display the affected blog's front page I get:
    "The blog you have requested is not installed properly."

    When I click the link in the blogs admin section to edit the affected blog, the Blog Info (wp_blogs) section displays properly, but the Blog options (wp_761_options) section is blank/empty.

    I've tried cycling through Deactivate/Activate and Archive/Unarchive, to see if that cycling would restore the basic options. WP cycles the affected blog through those states, but no luck on restoring function.

    When I went to delete the old, inactive blog I may have command-clicked on the link, thinking I would open the delete dialog in a new tab to deal with it and then close that tab to go back to working on my active blog.

    How do I fix the "installation" problem on this blog that I've had up and running for months? Thanks.

  19. andrea_r
    Moderator
    Posted 13 years ago #

    Got a backup?

  20. Arphia
    Member
    Posted 13 years ago #

    @andrea - we should have recent backups, I sent an email to our server admins right away yesterday to see about restore options. Haven't heard back yet. How are the individual blogs in WPMU set up? Do they each have their own data tables so that we can restore the affected blog independently without affecting the other 1100+ blogs? Thanks.

  21. andrea_r
    Moderator
    Posted 13 years ago #

    DB structure is here:

    http://codex.wordpress.org/WPMU_Database_Description

    You should be able to just restore the wp_761_options table. It's all you need. Depending on how the backups were made, you may or may not be able to extract just that. The server admin guys will know.

  22. Arphia
    Member
    Posted 13 years ago #

    thx, I'll pass along the info.

  23. Arphia
    Member
    Posted 13 years ago #

    Here's a script our serve admin wrote to automate the restoring the tables for an individual blog that needs to be restored. Right now the script includes hard coding of items you'd probably want to treat as variables (such as blogID), but it would be easily modified.

    ====

    ////////////////////////////////////////////////////////////////////////
    REM ExportWordpressTables.bat
    REM Gregg Ciabattoni
    REM Purchase College State University of New York
    @ECHO OFF
    REM Exports Wordpress tables to .sql files
    CLS
    Title MySQL Table Export
    
    @REM Set DB Info
    SET database=WPMU
    SET mysqlDIR="C:\Program Files\MySQL\MySQL Server 4.1\bin"
    SET mysqlpassword=*********
    SET mysqluser=root
    SET ExportDIR="C:\Temp"
    SET BLOGID=746
    
    @REM dump database table
    SET TableName=wp_%BLOGID%_comments
    %mysqlDIR%\mysqldump -u %mysqluser% -p%mysqlpassword% %database%
    %TableName%>%ExportDIR%\%TableName%.sql
    SET TableName=wp_%BLOGID%_options
    %mysqlDIR%\mysqldump -u %mysqluser% -p%mysqlpassword% %database%
    %TableName%>%ExportDIR%\%TableName%.sql
    SET TableName=wp_%BLOGID%_links
    %mysqlDIR%\mysqldump -u %mysqluser% -p%mysqlpassword% %database%
    %TableName%>%ExportDIR%\%TableName%.sql
    SET TableName=wp_%BLOGID%_postmeta
    %mysqlDIR%\mysqldump -u %mysqluser% -p%mysqlpassword% %database%
    %TableName%>%ExportDIR%\%TableName%.sql
    SET TableName=wp_%BLOGID%_posts
    %mysqlDIR%\mysqldump -u %mysqluser% -p%mysqlpassword% %database%
    %TableName%>%ExportDIR%\%TableName%.sql
    SET TableName=wp_%BLOGID%_term_relationships
    %mysqlDIR%\mysqldump -u %mysqluser% -p%mysqlpassword% %database%
    %TableName%>%ExportDIR%\%TableName%.sql
    SET TableName=wp_%BLOGID%_term_taxonomy
    %mysqlDIR%\mysqldump -u %mysqluser% -p%mysqlpassword% %database%
    %TableName%>%ExportDIR%\%TableName%.sql
    SET TableName=wp_%BLOGID%_terms
    %mysqlDIR%\mysqldump -u %mysqluser% -p%mysqlpassword% %database%
    %TableName%>%ExportDIR%\%TableName%.sql
    
    ////////////////////////////////////////////////////////////////////////
    REM ImportWordpressTables.bat
    REM Gregg Ciabattoni
    REM Purchase College State University of New York
    REM @ECHO OFF
    REM Imports Wordpress tables from .sql files
    CLS
    Title MySQL Table Import
    
    @REM Set DB Info
    SET database=WPMU
    SET mysqlDIR="C:\Program Files\MySQL\MySQL Server 4.1\bin"
    SET mysqlpassword=*********
    SET mysqluser=root
    SET ImportDIR="C:\Temp"
    SET BLOGID=746
    
    @REM Import database tables from .sql files
    SET FILENAME=wp_%BLOGID%_comments
    %mysqlDIR%\mysql -u %mysqluser% -p%mysqlpassword%
    %database%<%ImportDIR%\%FILENAME%.sql
    
    SET FILENAME=wp_%BLOGID%_links
    %mysqlDIR%\mysql -u %mysqluser% -p%mysqlpassword%
    %database%<%ImportDIR%\%FILENAME%.sql
    
    SET FILENAME=wp_%BLOGID%_options
    %mysqlDIR%\mysql -u %mysqluser% -p%mysqlpassword%
    %database%<%ImportDIR%\%FILENAME%.sql
    
    SET FILENAME=wp_%BLOGID%_postmeta
    %mysqlDIR%\mysql -u %mysqluser% -p%mysqlpassword%
    %database%<%ImportDIR%\%FILENAME%.sql
    
    SET FILENAME=wp_%BLOGID%_posts
    %mysqlDIR%\mysql -u %mysqluser% -p%mysqlpassword%
    %database%<%ImportDIR%\%FILENAME%.sql
    
    SET FILENAME=wp_%BLOGID%_term_relationships
    %mysqlDIR%\mysql -u %mysqluser% -p%mysqlpassword%
    %database%<%ImportDIR%\%FILENAME%.sql
    
    SET FILENAME=wp_%BLOGID%_term_taxonomy
    %mysqlDIR%\mysql -u %mysqluser% -p%mysqlpassword%
    %database%<%ImportDIR%\%FILENAME%.sql
    
    SET FILENAME=wp_%BLOGID%_terms
    %mysqlDIR%\mysql -u %mysqluser% -p%mysqlpassword%
    %database%<%ImportDIR%\%FILENAME%.sql
    pause

About this Topic