The MU forums have moved to WordPress.org

MU - Expert help please ! Blog problem (29 posts)

  1. mickymich
    Member
    Posted 14 years ago #

    |I have MU up and running and when I create a blog it's showing on the admin, but when I go to view the blog I am getting 404 and if I go to backend

    http://testing.diynetwork-homeimprovements.com/blogs/wp-admin/

    Not Found

    My front page is there
    http://diynetwork-homeimprovements.com/blogs/

    The requested URL /blogs/wp-admin/ was not found on this server.

    Any help would be really appreciated

    Thanks in advance

  2. mickymich
    Member
    Posted 14 years ago #

    This is my htaccess ;

    RewriteEngine On
    RewriteBase /blogs/

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ /$1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

  3. mickymich
    Member
    Posted 14 years ago #

    using Apache as servers and using Debian Linux as the operating system

  4. andrea_r
    Moderator
    Posted 14 years ago #

    You missed a step, is why. Please read the readme.txt file and make sure you do the Apache edits.

  5. mickymich
    Member
    Posted 14 years ago #

    Also when I tried to upgrade I got the following message and about 3 seconds to copy it before it said update ok

    Failed! HTTP/1.1 404 Not Found in /customers/diynetwork-homeimprovements.com/diynetwork-homeimprovements.com/httpd.www/blogs/wp-admin/wpmu-upgrade-site.php on line 31
    http://testing.diynetwork-homeimprovements.com/blogs/

    • Warning: fopen(http://testing.diynetwork-homeimprovements.com/blogs/wp-admin/upgrade.php?step=1) [function.fopen]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found in /customers/diynetwork-homeimprovements.com/diynetwork-homeimprovements.com/httpd.www/blogs/wp-admin/wpmu-upgrade-site.php on line 31
    http://diynetwork-homeimprovements.com/blogs/

  6. mickymich
    Member
    Posted 14 years ago #

    Hi Andrea, Thanks for the post, could you please be more in depth I have no coding experience, I am not a complete novice but I don't have php skills.

    Where do I find the httpd.conf

    " In the <Directory> directive of your virtual host "

    No idea what this is or where to find it.

    Thanks again

  7. Farms
    Member
    Posted 14 years ago #

    I'd recommend you get a fully managed server and talk to your support regarding httpd.conf etc.

  8. andrea_r
    Moderator
    Posted 14 years ago #

    I really can't get more in depth than the readme.
    THe apche edit to get wildcards working is not php, nor coding.

    If there are parts you don't understand with the install, ask your host to do it.

  9. mickymich
    Member
    Posted 14 years ago #

    My host told me that I don't have access to my httpd.conf, but apparently there is a php script that will let you override the settings. Do you know of any such script and which files it would have to override,

    Look forward to hearing from anyone !

  10. andrea_r
    Moderator
    Posted 14 years ago #

    For wildcards? No, the edit has to be made to the httpd.conf file. by your host, if they won't let you do it.

    And if they won't do a one-line edit, I'd consider getting a new host.

  11. Farms
    Member
    Posted 14 years ago #

    And a dedicated server...

  12. mickymich
    Member
    Posted 14 years ago #

    This is the code they have given me ;

    <?php $filename = "yourfilewhatever.php"; chmod ("/customers/mydomain/mydomain/httpd.www/$filename", 0777); echo "chmod for $filename was changed"; ?>

    So what your saying it's the wild card thats the problem ? not the other permissions ?

    To my Hosts below

    Question : In the section of the config file for your host there will be a line defining the hostname. You need to add the following if you want virtual hosts to work properly: "ServerAlias *.domain.tld" Replace domain.tld with whatever your one is, and remove the quotes.
    you: again in the conf settings

    Answer : This is already one by sysadmin. you don't need to worry about Virtual Records

    Farms dedicated server is out of the question, not that flush !

    Thanks again in advance

  13. MrBrian
    Member
    Posted 14 years ago #

    Like they said, your host needs to add a wildcard entry for your domain. If they can't do it or act stupid, you need to get a new host.

    There is absolutely no php code that can bypass this.

  14. bschwarting
    Member
    Posted 14 years ago #

    see if this thread helps you any mickymich.

    http://mu.wordpress.org/forums/topic.php?id=8631

  15. mickymich
    Member
    Posted 14 years ago #

    Before I start thanks for everyones help, I really do apresiate it.

    I have spoke to my hosts and they have said the following ;

    Hello,

    I read the mail you sent to us.

    I'll take it from the beginning:

    We already have mod_rewrite.

    There is no need to edit the apache-configuration
    manually, since you already have full control
    over the settings (like the wildcard-option
    for example) in the control panel, under
    DNS-settings. You can easily verify this
    by typing in anything.diynetwork-homeimprovements.com
    in your browser.

    The problem seems to be that Wordpress MU
    doesn't put any rewriterules in the root
    of your account, and it doesn't create any
    folders for the blogs you have set up. Have
    you set all permissions properly? Have you
    contacted the wordpress MU Support regarding
    this (again, the problem is not with mod_rewrite
    or with the wildcard)?

    We have other customers who are running Wordpress
    MU.

    Any help on what I need to do next would be great as I am a little lost, I am not a total
    loser and I can figure out what to do if I know what to do !

    Tx Guys

    Micky

  16. cafespain
    Member
    Posted 14 years ago #

    What are the options available in the "the control panel, under
    DNS-settings."

    It certainly looks like you can resolve a wildcard comain, it's just a matter of finding out where it resolves to....

  17. mickymich
    Member
    Posted 14 years ago #

    diynetwork-homeimprovements.com A One.com Network Yes Disable

    *.diynetwork-homeimprovements.com A One.com Network Yes Disable

    http://ftp.diynetwork-homeimprovements.com A One.com Network Yes Disable

    iloapp.diynetwork-homeimprovements.com A One.com Network Yes Disable

    imap.diynetwork-homeimprovements.com A One.com Network Yes Disable

    logs.diynetwork-homeimprovements.com CNAME One.com Network Yes Disable

    phpmyadmin.diynetwork-homeimprovements.com A One.com Network Yes Disable

    pop.diynetwork-homeimprovements.com A One.com Network Yes Disable

    pop3.diynetwork-homeimprovements.com A One.com Network Yes Disable

    stats.diynetwork-homeimprovements.com CNAME One.com Network Yes Disable

    webc.diynetwork-homeimprovements.com A One.com Network Yes Disable

    http://www.diynetwork-homeimprovements.com A One.com Network Yes Disable

  18. mickymich
    Member
    Posted 14 years ago #

    I have attached a screen shot as the above is not really clear.

    http://www.diynetwork-homeimprovements.com/dns.jpg

  19. cafespain
    Member
    Posted 14 years ago #

    I've just had a quick look at the support pages for one.com - can you see what the settings for the diynetwork-homeimprovements.com and the *.diynetwork-homeimprovements.com records - just to check they are indeed pointing to the same location.

    If the IP address is the same, then I would send an email to one.com support and say something along the lines of:

    My domain and wild card DNS settings A records both point to the same IP address, however:
    http://diynetwork-homeimprovements.com/blogs

    and

    http://test.diynetwork-homeimprovements.com/blogs

    don't seem to resolve to the same location

  20. mickymich
    Member
    Posted 14 years ago #

    Thanks for the help Cafespain, your name makes me feel like I should go back on Holiday after all this, I just got back from my mums in Valencia on Monday to wake up to this :-(

    I have sent them an email and I will see what they have to say and post the reply soon as.

    Thanks again

    Micky

  21. mickymich
    Member
    Posted 14 years ago #

    One question, they said in the above, that it's not creating the blog on the server? As you can see in the screen shot it's created in WPMU admin ? Would this be down to the same problem as the DNS pointers ?

  22. cafespain
    Member
    Posted 14 years ago #

    No, it's down to them not understanding how MU works. They are probably expecting MU to make a new directory for each blog created - which it doesn't. It uses the same codebase for every blog and just uses different tables.

    If the blog name is showing on your home page (which the test one is) then MU knows about it.

  23. mickymich
    Member
    Posted 14 years ago #

    Tx again

  24. mickymich
    Member
    Posted 14 years ago #

    Is there anyway for me to check that the test blog has been created in the DB or do you know it has ?

    Tx
    micky

  25. cafespain
    Member
    Posted 14 years ago #

    Load up your PHPMYADMIN and look in the database that your MU install uses.

    In the wp_blogs table you should see a row for the main site and one for the test site.

    Make a note of the Id number for it and then check for tables names like wp_x_posts and wp_x_options (where x is the id number of the test blog).

    Check they have content in them - if they do then your test blog looks like it was set up in the database.

  26. mickymich
    Member
    Posted 14 years ago #

    Thanks again for the pointer, I have posted a screen shot. It looks like the data is in the tables but Iam no expert as you can see.

    http://www.diynetwork-homeimprovements.com/phpad.jpg

  27. mickymich
    Member
    Posted 14 years ago #

    A word from my hosts, let me know what you think ?

    diynetwork-homeimprovements.com/blogs and
    test.diynetwork-homeimprovements.com/blogs
    resolves to the same IP, but as you say,
    not to the same location.

    Which is how it should be, our default rewriterules
    forwards requests for subdomains (that are
    not defined in the dns-settings) to folders,
    and since there's nothing in diynetwork-homeimp
    rovements.com/test/blogs/, you get a 404 response
    from apache.

    I was expecting Wordpress MU to create its
    own rewriterules (which would have priority
    over our default apache rewrites) to handle
    the Worpress MU "subdomains" (which, technically
    speaking, isn't subdomains but forwards of
    certain requests). The problem is that WP
    MU doesn't create any appropriate rewriterules
    where it's needed, only in the folder where
    you installed it.

  28. andrea_r
    Moderator
    Posted 14 years ago #

    All wildcard subdomains should get tossed at the folder where WPMU is. MU *will* handle it. You got the htaccess in there, right?

    "and since there's nothing in diynetwork-homeimprovements.com/test/blogs"

    Where did you install WPMU? Because all subdomain blogs should be directed to go to that folder not the one quoted above.

    It's not MU. Someone screwed up some setting somewhere.

  29. mickymich
    Member
    Posted 14 years ago #

    It's in a subdirectory /blogs

    Does the htaccess need to be in the root and not in the WPMU subfolder ?

    Can you check my htaccess to see if you can spot anything wrong

    RewriteEngine On
    RewriteBase /blogs/

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ /$1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

About this Topic

  • Started 14 years ago by mickymich
  • Latest reply from mickymich