The MU forums have moved to WordPress.org

Mac OS X - Rewrite - and subdomains (17 posts)

  1. ijak
    Member
    Posted 14 years ago #

    I am having quite a bit of trouble trying to figure out how to get WPMU working on my test Mac OS X 10.5 Leopard server.

    I cannot get to other created pages, or the about page.

    --------
    Error 404

    3866062757187 (<-Server ip number nat accurately reflected here)
    Wed Jun 18 11:41:11 2008
    Apache/2.2.8 (Unix) mod_ssl/2.2.8 OpenSSL/0.9.7l DAV/2 PHP/5.2.5 mod_jk/1.2.23 mod_fastcgi/2.4.2 mod_scgi_pubsub/1.11-pubsub SVN/1.4.4
    ---------
    I have placed all my files directly into the webservers root folder, not in a sub folder of their own.

    I have MySQL installed and can connect to it.

    I have created a blog, and the frontpage/login work. ... I can make new pages and postings. ... I just cannot get to them

    I cannot seem to create multiple blogs, It says I have created them, but either I did not, or I just cannot get to them.

  2. lunabyte
    Member
    Posted 14 years ago #

    You need to read the readme file, and make the appropriate modifications to httpd.conf.

    Also, verify that you have an htaccess file, and that apache is set up to use them.

    Another thing, is that perhaps the DNS isn't set up correctly either. However, since you did not specify whether you have a subdomain or subdir mode install, that may not be applicable.

  3. ijak
    Member
    Posted 14 years ago #

    Sorry it took me so long to get back to you. ... I had just forgotten to write some other info. ...

    I had made the changes to the httpd.conf file. ... (But I just now rechecked them)
    And
    .htaccess file exists in the weblog location.

    And I have restarted the Apache server.

    How do I check if Apache is set to use them?

  4. lunabyte
    Member
    Posted 14 years ago #

    It's a setting in httpd.conf, and it's on by default.

    Other than that, need more info (like specific errors, and results) about this.

  5. andrea_r
    Moderator
    Posted 14 years ago #

    And are you using a TLD? If it's localhost or an IP address, it won't work.

  6. ijak
    Member
    Posted 14 years ago #

    Lunabyte - In the httpd.conf file, the reference exists, and it is turned on.

    andrea_r - Right now I am using an ip address, and I think I am using localhost. ... Where should I change that? Localhost in the sql database? I don't know whderfe to change it. What is TLD?

  7. Rubyducky
    Member
    Posted 14 years ago #

    Make sure in Server Admin, in your Site under Options, that "Allow All Overrides" is checked.

  8. ijak
    Member
    Posted 14 years ago #

    Rubyducky - Thanx! That (Make sure in Server Admin, in your Site under Options, that "Allow All Overrides" is checked.) fixed part of the problem ... Now my base sites links to about pages, and other pages all work right now.

    Now when I create a second blog, it cannot be found. ... they are organized as...

    NewBlogName.IPnumber

    Would it work if it was organized as?
    NewBlogName.DomainName

  9. lunabyte
    Member
    Posted 14 years ago #

    The main domain needs to be exactly that. A domain (with an extension).

  10. ijak
    Member
    Posted 14 years ago #

    Lunabyte - Ok. ... I just went and put NationalJeepOgraphic.com as a domain name. ...

    It is real, funny, but real. ... I registered it a while back when I thought 4-wheel driving was the cats pajamas. ... TMI? ... ;-)

    Soo. ... NationalJeepOgraphic.com works, but I cannot get Jax.NationalJeepOgraphic.com to work.

  11. lunabyte
    Member
    Posted 14 years ago #

    That would point to most likely a missing DNS wildcard entry, although you may also want to double check httpd.conf to ensure you have the wildcard there as well (since you changed domains). That is, unless that virtual host is set to answer for anything thrown at it.

  12. ijak
    Member
    Posted 14 years ago #

    Ok. ... I will search down how to do that.

  13. ijak
    Member
    Posted 14 years ago #

    Ok. ... Everything is working for me.

    Mac OS X 10.5.x Leopard Server
    MacMini
    MySQL as installed on the server as default
    PHP as installed on the server as default
    WordpressMU - all files in the top level of the webserver documents folder.
    Server Admin - Site - Options - "Allow All Overrides" is checked.
    DNS - "*." as wild card at my managing site - Godaddy.com

    I think that is about it.

  14. netspencer
    Member
    Posted 14 years ago #

    I have a very similar problem. I have resolved most of it but when a user tries to signup with wp-signup.php they fill out all the information and it forwards to a browser error page (not a server error page.) I too am running Mac OS X 10.5.4 Leopard Server on a Mac Mini with the default PHP and MySQL enabled. I use Godaddy for DNS and have a wildcard record to forward to my IP. I have tried everything and cannot get it to work. I am using virtual name based hosting built into Mac OS X server by adding multiple sites in Server Admin. All the sites reside in /Library/WebServer/Sites/Sitename/. What could my issue be. The site is schoeben.com. Here is my signup page schoeben.com/wp-signup.

    Please Help

  15. lunabyte
    Member
    Posted 14 years ago #

    And the browser error page says....

    It works just fine for me with 10.5.4.

    Not sure what you've got going on there, but I've got it running on Mac Pro's, iMac's, and even on the macbook I'm typing on right now.

    Naturally that's being hosted locally for development, but MU works just fine. Could be DNS or a number of things. Without knowing your specific config or error messages, not much anyone can point you to.

  16. netspencer
    Member
    Posted 14 years ago #

  17. Achilleus
    Member
    Posted 14 years ago #

    I run Leopard also. If you go to /private/etc/ and edit "hosts" and add 127.0.0.1 subdomain.domain.test to the end of the file, it should work. For example, here is my hosts file:

    ##
    # Host Database
    #
    # localhost is used to configure the loopback interface
    # when the system is booting.  Do not change this entry.
    ##
    127.0.0.1	localhost
    255.255.255.255	broadcasthost
    ::1             localhost
    fe80::1%lo0	localhost
    
    127.0.0.1 http://www.acegamingsyndicate.test
    127.0.0.1 games.acegamingsyndicate.test
    127.0.0.1 blogs.acegamingsyndicate.test
    127.0.0.1 downloads.acegamingsyndicate.test
    127.0.0.1 events.acegamingsyndicate.test
    127.0.0.1 acegamingsyndicate.test
    127.0.0.1 achilleus.acegamingsyndicate.test
    127.0.0.1 support.acegamingsyndicate.test
    127.0.0.1 forums.acegamingsyndicate.test

    The hosts file will not take wildcards. If you want to set up wildcards, you'll need to edit your localhost.zone file. And I wouldn't have a clue how to do that, I wasn't able to get it to work so I'm not bothering with it until I get my dedicated server with root access up. Then I'll just use the control panel, lol.

    Optionally, if you're running OS X Server, there is a configration program you can use to edit your localhost.zone file with a GUI and it makes it a whole lot easier to set up wildcard subdomains.

About this Topic