The MU forums have moved to WordPress.org

httpd.conf (22 posts)

  1. General Green
    Member
    Posted 14 years ago #

    Any pointers as to where I might find this little blighter on my apache server would be greatly appreciated!

    Do I have to edit it by the way?

    My Install works but it does not create the subdirectories.

    http://www.vegeburger.com

    Thanks to the MU Gods!

  2. bschwarting
    Member
    Posted 14 years ago #

    you on a shared host or VPS?

  3. bschwarting
    Member
    Posted 14 years ago #

    /etc/httpd/conf for dedicated
    /var/www/vhosts/domain.com/conf for VPS (not exact, but probably something similiar)

    not sure on shared

  4. General Green
    Member
    Posted 14 years ago #

    I have a dedicated server.

    I found the file, made some half-assed attempts at changes and now i get this on all subdomains, lol...

    Great Success !
    Apache is working on your cPanel® and WHM™ Server

    http://test.vegeburger.com/

  5. General Green
    Member
    Posted 14 years ago #

    I could post the contents of my hpptd.conf file if that helps (192 lines).

    I have already done the dns wildcard, do I also need to do the php bit?

    God, I'm tired!

  6. bschwarting
    Member
    Posted 14 years ago #

    did you restart apache after you made the wild card entry?

  7. General Green
    Member
    Posted 14 years ago #

    no, i'll do that now then, lol

  8. General Green
    Member
    Posted 14 years ago #

    deleted

  9. General Green
    Member
    Posted 14 years ago #

    oooh fffoook!

    httpd has failed, please contact the sysadmin

  10. General Green
    Member
    Posted 14 years ago #

    I think I broke the internet!

  11. General Green
    Member
    Posted 14 years ago #

    After removing what I added from the conf file it restarted ok

    <VirtualHost {87.117.239.65}>
    DocumentRoot /home/vegeburg/public_html
    BytesLog domlogs/vegeburger.com-bytes_log
    User vegeburg
    Group vegeburg
    ServerAlias vegeburger.com *.vegeburger.com
    ServerName http://www.vegeburger.com
    CustomLog domlogs/vegeburger.com combined
    </VirtualHost>

  12. bschwarting
    Member
    Posted 14 years ago #

    i think it should be:

    ServerAlias *.vegeburger.com

  13. bschwarting
    Member
    Posted 14 years ago #

    restart apache :)

  14. General Green
    Member
    Posted 14 years ago #

    That's weird, it seems to have added this to the conf file by itself...

    <VirtualHost 87.117.239.65:80>
    ServerName simon.vegeburger.com
    ServerAlias http://www.simon.vegeburger.com
    DocumentRoot /home/vegeburg/public_html/simon
    ServerAdmin webmaster@simon.vegeburger.com
    ## User vegeburg # Needed for Cpanel::ApacheConf
    <IfModule mod_userdir.c>
    Userdir disabled
    Userdir enabled vegeburg
    </IfModule>
    <IfModule mod_suphp.c>
    suPHP_UserGroup vegeburg vegeburg
    </IfModule>
    <IfModule concurrent_php.c>
    php4_admin_value open_basedir "/home/vegeburg:/usr/lib/php:/usr/php4/lib/php:/usr/local/lib/php:/usr/local/php4/lib/php:/tmp"
    php5_admin_value open_basedir "/home/vegeburg:/usr/lib/php:/usr/local/lib/php:/tmp"
    </IfModule>
    <IfModule !concurrent_php.c>
    <IfModule mod_php4.c>
    php_admin_value open_basedir "/home/vegeburg:/usr/lib/php:/usr/php4/lib/php:/usr/local/lib/php:/usr/local/php4/lib/php:/tmp"
    </IfModule>
    <IfModule mod_php5.c>
    php_admin_value open_basedir "/home/vegeburg:/usr/lib/php:/usr/local/lib/php:/tmp"
    </IfModule>
    <IfModule sapi_apache2.c>
    php_admin_value open_basedir "/home/vegeburg:/usr/lib/php:/usr/php4/lib/php:/usr/local/lib/php:/usr/local/php4/lib/php:/tmp"
    </IfModule>
    </IfModule>
    <IfModule !mod_disable_suexec.c>
    SuexecUserGroup vegeburg vegeburg
    </IfModule>
    CustomLog /usr/local/apache/domlogs/simon.vegeburger.com-bytes_log "%{%s}t %I .\n%{%s}t %O ."
    CustomLog /usr/local/apache/domlogs/simon.vegeburger.com combined
    ScriptAlias /cgi-bin/ /home/vegeburg/public_html/simon/cgi-bin/
    # To customize this VirtualHost use an include file at the following location
    # Include "/usr/local/apache/conf/userdata/vegeburg/simon.vegeburger.com/*.conf"
    </VirtualHost>

  15. General Green
    Member
    Posted 14 years ago #

    http://www.simon.vegeburger.com/wp-admin/

    returns a 500 Internal Server Error

    this is hard work!

  16. bschwarting
    Member
    Posted 14 years ago #

    doh! look at the end of that file. yours is like mine, it must be a VPS and not dedicated.

    # To customize this VirtualHost use an include file at the following location
    # Include "/usr/local/apache/conf/userdata/vegeburg/simon.vegeburger.com/*.conf"
    </VirtualHost>

    edit that conf file and restart apache and you should be good to go. that is the "main" apache file that you don't need to edit for this.

  17. General Green
    Member
    Posted 14 years ago #

    i think it should be:

    ServerAlias *.vegeburger.com

    I LOVE YOU BSCHWARTING !!!!!!!!

    IT WORKS!!!

    Thanks so much mate, really appreciate your help!

  18. bschwarting
    Member
    Posted 14 years ago #

    good deal, enjoy! MU is a lot of fun!

  19. lunabyte
    Member
    Posted 14 years ago #

    VPS or Dedicated, cpanel/whm is cpanel/whm.

    You can't modify the virtual host directly, as anytime httpd.conf needs to be written to, cpanel uses a standard template to generate it. Which is why it specifically tells you to use an include, and where to put it.

    ServerName vegeburger.com
    ServerAlias *.vegeburger.com

    Note, the * covers www as well, since it's a subdomain of vegeburger.com.

    Don't forget the DNS wildcard as well.

  20. General Green
    Member
    Posted 14 years ago #

    hehehehe, no sleep for me today / tonight / this morning...

    Can I get all the subdomains to automatically list on the main site?

  21. General Green
    Member
    Posted 14 years ago #

    This is mental!

    I currently have about 20 separate wordpress blogs. My life has just got so much easier!

    : D

  22. bschwarting
    Member
    Posted 14 years ago #

    sweet! yeah, i remember my 1st night. i couldn't sleep thinking about the potential. a lot of fun, thanks wordpress! if more around here would remember that initial glee, i think it would be a better/nicer forum.

About this Topic

  • Started 14 years ago by General Green
  • Latest reply from bschwarting