The MU forums have moved to WordPress.org

500 Internal Server Error after intall (21 posts)

  1. Illi.Pro
    Member
    Posted 9 years ago #

    Hi friends, i get a 500 Internal Server Error when i want to see my wordpress mu. Here i will tell you my configuration:

    Domain for Wordpress MU Home: http://blogs.illi-pro.com
    Domain for each user: Subdirectory -> http://blogs.illi-pro.com/example

    Well.. i don't know what's the problem.. when the install finish it said all is ok but i want to see my worpdress mu home and i get this error.. please.. what i can do?

    Here is my error_log:

    [22-Jun-2008 20:04:54] PHP Warning: main(./wp-blog-header.php) [function.main]: failed to open stream: No such file or directory in /home/ami0358/illi-pro.com/blogs/index.php on line 4
    [22-Jun-2008 20:04:54] PHP Warning: main(./wp-blog-header.php) [function.main]: failed to open stream: No such file or directory in /home/ami0358/illi-pro.com/blogs/index.php on line 4
    [22-Jun-2008 20:04:54] PHP Fatal error: main() [function.require]: Failed opening required './wp-blog-header.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/ami0358/illi-pro.com/blogs/index.php on line 4
    [22-Jun-2008 20:04:55] PHP Warning: main(./wp-blog-header.php) [function.main]: failed to open stream: No such file or directory in /home/ami0358/illi-pro.com/blogs/index.php on line 4
    [22-Jun-2008 20:04:55] PHP Warning: main(./wp-blog-header.php) [function.main]: failed to open stream: No such file or directory in /home/ami0358/illi-pro.com/blogs/index.php on line 4
    [22-Jun-2008 20:04:55] PHP Fatal error: main() [function.require]: Failed opening required './wp-blog-header.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/ami0358/illi-pro.com/blogs/index.php on line 4
    [22-Jun-2008 20:04:59] PHP Warning: main(./wp-blog-header.php) [function.main]: failed to open stream: No such file or directory in /home/ami0358/illi-pro.com/blogs/index.php on line 4
    [22-Jun-2008 20:04:59] PHP Warning: main(./wp-blog-header.php) [function.main]: failed to open stream: No such file or directory in /home/ami0358/illi-pro.com/blogs/index.php on line 4
    [22-Jun-2008 20:04:59] PHP Fatal error: main() [function.require]: Failed opening required './wp-blog-header.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/ami0358/illi-pro.com/blogs/index.php on line 4
    [22-Jun-2008 20:23:14] WordPress database error Unknown column 'blog_public' in 'field list' for query UPDATE wp_blogs SET blog_public = '1', last_updated = NOW() WHERE blog_id = '1' made by update_blog_status
    [22-Jun-2008 20:23:14] WordPress database error: [Unknown column 'blog_public' in 'field list']
    UPDATE wp_blogs SET blog_public = '1', last_updated = NOW() WHERE blog_id = '1'

  2. sombra
    Member
    Posted 9 years ago #

    did you install it in the /blog/ subdirectory?

    also have you looked at line four in index that its referring to?

  3. Illi.Pro
    Member
    Posted 9 years ago #

    no, i create a subdomain for my domain: http://www.illi-pro.com

    I want to install it in a subdomain and the members will have a subdirectory link like:

    http://blogs.illi-pro.com/sombra
    ..

    also have you looked at line four in index that its referring to?

    what do you mean?

    My index.php is:

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./wp-blog-header.php');
    ?>

  4. andrea_r
    Moderator
    Posted 9 years ago #

    Are all the MU files in http://blogs.illi-pro.com ?

  5. Illi.Pro
    Member
    Posted 9 years ago #

    yes.. i upload all the folder and installed it :S

  6. lunabyte
    Member
    Posted 9 years ago #

    "failed to open stream: No such file or directory in"...

    That's the problem. Either by permission, or location, it can't find and include the necessary file(s).

    Your best bet would be to completely wipe all the files (don't forget "hidden" files, meaning .htaccess), empty the database, and try it again. Paying very close attention to the install.

    Also, make sure the modification was made to your vhost in apache's configuration file for the directory section.

  7. Illi.Pro
    Member
    Posted 9 years ago #

    vhost in apache's

    what's that? how i do it?

  8. MrBrian
    Member
    Posted 9 years ago #

    You shouldn't be installing MU if you don't know what virtual hosts are, it's too advanced for you sorry :(.

  9. Illi.Pro
    Member
    Posted 9 years ago #

    :(! Well.. where i can find a guide about this? i want to learn :)

  10. lunabyte
    Member
    Posted 9 years ago #

  11. rreuss
    Member
    Posted 9 years ago #

    Well let me pick this up since I am technically proficient enough and willing to deal with your snobbery. I am having the same issue, as well as a related problem using permalinks. I have set a vhost on an intranet.

    I am running a SuSE v10.1 Enterprise server.

    My vhost (I am leaving the options at a much more open state than I normally would just for testing):

    <VirtualHost *:80>
        ServerAdmin webadmin@mydomain.com
        ServerName blog.mydomain.com
    
        DocumentRoot /srv/www/vhosts/blog
    
        ErrorLog /var/log/apache2/blog.mydomain.com-error_log
        CustomLog /var/log/apache2/blog.mydomain.com-access_log combined
    
        HostnameLookups Off
        UseCanonicalName Off
        ServerSignature On
    
        Include /etc/apache2/conf.d/*.conf
    
        ScriptAlias /cgi-bin/ "/srv/www/cgi-bin"
    
        <Directory "/srv/www/cgi-bin">
    	AllowOverride None
    	Options +ExecCGI -Includes
    	Order allow,deny
    	Allow from all
        </Directory>
    
        <Directory "/srv/www/vhosts/blog">
    
    	Options Indexes FollowSymLinks Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
        	AllowOverride None
        	Order allow,deny
    	Allow from all
    
        </Directory>
    
    </VirtualHost>

    My wp-config.php:

    define('VHOST', 'no');
    $base = '/';

    So I should have users in subdirectories as in http://blog.mydomain.com/rreuss. New users can register and their is created fine. The URL as listd above (which they get redirected to) does not work - I get a 404 error. My error log shows:

    [Fri Jun 27 07:18:29 2008] [error] [client XXX.XXX.XX.XX] File does not exist: /srv/www/vhosts/blog/super-rr, referer: http://blog.mydomain.com/wp-admin/wpmu-blogs.php?action=editblog&id=3

    My htaccess:

    RewriteEngine On
    RewriteBase /
    
    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ /$1/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    Now the related issue (I think it is) is that if I use any permalink option besides the defalt I get 404 errors

    [Fri Jun 27 07:10:28 2008] [error] [client XXX.XXX.XX.XX] File does not exist: /srv/www/vhosts/blog/blog
    [Fri Jun 27 07:10:30 2008] [error] [client XXX.XXX.XX.XX] File does not exist: /srv/www/vhosts/blog/blog

    I suspect I have soemthing misconfigured in the Rewritebase or the actul rule, but this stuff can be kind of voodoo, when you ahve three things working on the same URL.

    Any advice?

  12. lunabyte
    Member
    Posted 9 years ago #

    First problem I see, is a missed step in the readme:

    2. In the <Directory> directive of your virtual host, look for this line
    "AllowOverride None"
    and change it to
    "AllowOverride FileInfo Options"

  13. lunabyte
    Member
    Posted 9 years ago #

    "Any advice?"

    - Never dip your pen in company ink.

    - Don't stare at the sun too long.

    - Snide remarks about snobbery when in need of help isn't the best way to get it.

  14. rreuss
    Member
    Posted 9 years ago #

    Thanks for the info - the overide did the trick. I was under the impression that was only if you were using define('VHOST', 'yes');

    And you have to admit the comment my MrBrian was pretty snobbish.

  15. lunabyte
    Member
    Posted 9 years ago #

    You're welcome.

    IRT Brian's comment. Not really. Blunt, but sometimes that's what it takes. MU just isn't for everybody, and at times it's best to be upfront about it.

  16. andrea_r
    Moderator
    Posted 9 years ago #

    And honestly if someone's posting such things, it shows they haven't even read the readme.

  17. dentatur
    Member
    Posted 8 years ago #

    hi
    Fatal error: Call to undefined function wp() in /home/dentatur/public_html/blog/wordpress/wp-blog-header.php on line 14
    what is this can you help me?

  18. SteveAtty
    Member
    Posted 8 years ago #

    that means that for some reason wp-blog-header.php cannot find the wp function which is defined in wp-includes/wp-functions.php.

    I suspect you've got a path messed up somewhere or a file missing

  19. dentatur
    Member
    Posted 8 years ago #

    thank you

  20. richs0914
    Member
    Posted 8 years ago #

    I recently upgraded my site to Wordpress Mu 2.7 and buddypress. http://sportsblognet.com and everything was working fine. Now I get an Internal 500 error (or blank white screen) whenever someone sign's up and tries to use their wp-activate key that is sent to them in the email.

    Needless to say, now people cannot complete their activation.

    It worked fine yesterday (I activated a few accounts myself), but now today, the wp-activate doesn't work. And I didn't install any new plugins, or do anything different that I can think of.

    Here's an example:

    http://sportsblognet.com/wp-activate.php?key=603926e873b6da0f

  21. richs0914
    Member
    Posted 8 years ago #

    Solved it...it was a problem with plugins in the mu directory causing the script to hang

About this Topic

  • Started 9 years ago by Illi.Pro
  • Latest reply from richs0914