The MU forums have moved to WordPress.org

Theme options page (3 posts)

  1. caspararemi
    Member
    Posted 16 years ago #

    Hi,
    i've installed a theme which has a custom options page. It doesn't display the link to the options page in the 'Design' tab like it does in normal WordPress, but I noticed it put it in the top bar, i.e. I see these links:

    * Write
    * Manage
    * Design
    * Comments 0
    * Brightness Settings

    When I try to go into it, I get an error as it tries to visit:
    http://witchesgrimoire.org/home/.ketut/casparian/witchesgrimoire.org/wp-content/themes/Brightness%20Theme/functions.php
    So it seems to be trying to be trying to take me to the server path. When I take that all out and just try to go directly to
    http://witchesgrimoire.org/wp-content/themes/Brightness%20Theme/functions.php
    I get:
    Fatal error: Call to undefined function add_action() in /home/.ketut/casparian/witchesgrimoire.org/wp-content/themes/Brightness Theme/functions.php on line 6

    This theme works fine on normal WordPress, just not on my MU installation.

    Are there any suggestions? Is there any way to access custom theme option pages under MU? And is there any wa to enable the theme editor page for Admin users? I want to add custom footers to all the themes to link back to my main site and would rather do this online via the admin area.

  2. andrea_r
    Moderator
    Posted 16 years ago #

    You might have to take the custom option off that theme. There are stored in the functions.php file. That's the one thing that breaks themes under MU. yes, there are some with ones that work.

    As for putting in a custom footer there's a plugin for that.
    http://mu.wordpress.org/forums/topic.php?id=2984#post-17884

  3. laura1234
    Member
    Posted 15 years ago #

    you can access the options page directly through this link:
    http://yourdomain.com/wp-admin/admin.php?page=/home/yourdirectory/public_html/wp-content/themes/Brightness Theme/functions.php

    but the link directly through your admin panel doesn't work, apparently.

About this Topic

  • Started 16 years ago by caspararemi
  • Latest reply from laura1234