The MU forums have moved to WordPress.org

WordPress MU 2.6 beta 1 (42 posts)

  1. donncha
    Key Master
    Posted 14 years ago #

    I've just announced WordPress MU 2.6 beta 1. You can grab wordpress-mu-2.6-beta1.zip and test it.

    I find it's fairly stable as have others but if you're at all squemish about running new code then don't put this into production just yet.

    Yes, the version number bumped. Calling it 2.6 just makes life easier for people who have to explain what their customers are getting and hopefully it'll encourage all the stragglers to upgrade!

  2. boonika
    Member
    Posted 14 years ago #

    Once again, I'm the first one to thank you:) Thank You. When can we expect stable release?

    Btw, are there any changes in menu.php?

  3. donncha
    Key Master
    Posted 14 years ago #

    menu.php? Not sure, better check that yourself. Stable release may be next week or the following week.

  4. cafespain
    Member
    Posted 14 years ago #

    Muy bien. Perfect timing as usual :)

  5. jamescollins
    Member
    Posted 14 years ago #

    Thanks Donncha!

    Looking forward to trying it out.

  6. dsader
    Member
    Posted 14 years ago #

    Thanks, Donncha.

    Bookika, go to http://trac.mu.wordpress.org/browser note the version number of a file(s) you wish to compare then click the "view changes."

  7. boonika
    Member
    Posted 14 years ago #

    @dsader

    thanks

  8. DragonFlyEye
    Member
    Posted 14 years ago #

    I've installed the new beta and am experiencing some logon issues. It seems I'm not able to logon to any but the root blog. If I attempt to logon to any of the others, I get redirected right back to the logon screen, sans errors.

    Additionally, as I noted on Donncha's 2.6 release post, the xmlrpc.php file seems to only register the main blog, not any of the others.

  9. GIGALinux
    Member
    Posted 14 years ago #

  10. demonicume
    Member
    Posted 14 years ago #

    *shaking head* i dunno. i just fixed the last thing i broke.

  11. SteveAtty
    Member
    Posted 14 years ago #

    was 1.5 1288 in trunk? so a 1288:1360 diff would give me the changed files?

  12. MrBrian
    Member
    Posted 14 years ago #

    If you're having login probs, you probably need to add the new authentication keys to wp-config.php. It gives them to you when you login as admin.

  13. DragonFlyEye
    Member
    Posted 14 years ago #

    McBrian, if you're referring to the salt keys such as AUTH_KEY, I have those in my wp-config.php. In fact, I've confirmed that my wp-config.php is identical to the supplied version in every way.

    Any other ideas?

  14. DragonFlyEye
    Member
    Posted 14 years ago #

    Ok, another ripple: when I login at one of the non-root blogs, I do in fact get properly logged in. If I go back to the root blog, I'm able to get to it's control panel without a problem. Additionally, even after confirming I've logged in, when i click on one of the non-root blogs' control panels, I'm asked to login again.

    So, this doesn't so much seem a login problem as it is a problem with *authenticating* an already-logged in user. So, I'm guessing either cookies or the site reading said cookies are the problem.

  15. smajda
    Member
    Posted 14 years ago #

    Only problem I've encountered: the new "Default Avatar" settings won't stick. If I select any option other than Mystery Man, it says "Settings saved," but Mystery Man is still selected. I turned off all plugins & tried on a brand new blog with the same result.

  16. DragonFlyEye
    Member
    Posted 14 years ago #

    I'm looking into my cookies. It should be mentioned that I'm using directory-based blogs, not subdomain blogs. I found these:

    name: wordpress_test_cookie
    content: WP+Cookie+check
    domain: .holisticnetworking.net
    path: /
    send for: Any type of connection
    expires: at end of session

    name: wordpress_
    content: <<password hash>>
    domain: .holisticnetworking.net
    path: /wp-content/plugins
    send for: Any type of connection
    expires: at end of session

    name: wordpress_
    content: <<password hash>>
    domain: .holisticnetworking.net
    path: /wp-admin
    send for: Any type of connection
    expires: at end of session

    name: wordpress_logged_in_
    content: <<password hash>>
    domain: .holisticnetworking.net
    path: /wp-admin
    send for: Any type of connection
    expires: at end of session

    I don't claim to be any kind of expert in cookie handling, but shouldn't there be a cookie set for the root that's not a "test cookie?" The other cookies seem redundant to me, being as they contain the same information but simply different directories, but again, I don't really know.

    Does this help anyone find a solution to this problem?

  17. wehican
    Member
    Posted 14 years ago #

    Tried a fresh install.

    You fixed the Add Media and XMLRPC issues!!

    Vista and IE7 centered the screen like it was supposed to. WLW hooks up just fine.

    Great!!! Hope it works when I upgrade a site.

    This release just feels better. Smoother.

  18. MrBrian
    Member
    Posted 14 years ago #

    Just a note: I'm not a McBrian and i don't taste like one either :).

    The test cookie is just part of the login process used to verify the browser accepts cookies. Those cookies are all the normal ones, don't know why you're having issues.

  19. donncha
    Key Master
    Posted 14 years ago #

    DragonFlyEye - can you list the security constants defined in your wp-config.php please? No need for the values of course. Keep them secret!

  20. donncha
    Key Master
    Posted 14 years ago #

    FYI - A few minutes ago, in http://trac.mu.wordpress.org/changeset/1364 I changed the "blog_id" field on the signup form to "blogname". If you're living on trunk and use any signup plugins make sure to update them!

    This change also affects several filters. They're listed in the changeset message.

    Using "blog_id" was always a bad idea since that's an important global variable! Took me long enough to change that ..

  21. DragonFlyEye
    Member
    Posted 14 years ago #

    Donncha, here are those security constants you asked for:

    define('AUTH_KEY', '<<budda,budda,budda>>');
    define('SECURE_AUTH_KEY', '<<budda,budda,budda>>');
    define('LOGGED_IN_KEY', '<<budda,budda,budda>>');
    define('SECRET_KEY', '<<budda,budda,budda>>');
    define('SECRET_SALT', '<<budda,budda,budda>>');
    define('LOGGED_IN_SALT', '<<budda,budda,budda>>');
  22. DragonFlyEye
    Member
    Posted 14 years ago #

    I think I may be seeing the problem, at least in terms of what the code is outputting:

    I logged into one of my secondary blogs, /news/ and checked the cookies again:

    name: wordpress_test_cookie
    content: WP+Cookie+check
    domain: .dragonflyeye.net
    path: /
    send for: Any type of connection
    expires: at end of session
    
    name: wordpress_
    content: <<passwordhash>>
    domain: .dragonflyeye.net
    path: /news/wp-content/plugins
    send for: Any type of connection
    expires: at end of session
    
    name: wordpress_
    content: <<passwordhash>>
    domain: .dragonflyeye.net
    path: /wp-admin
    send for: Any type of connection
    expires: at end of session
    
    name: wordpress_logged_in_
    content: <<passwordhash>>
    domain: .dragonflyeye.net
    path: /
    send for: Any type of connection
    expires: at end of session

    Correct me if I'm wrong, but shouldn't all those paths be set to /news/_whatever_? Only the plugins directory strikes me as properly assigned.

  23. Anonymous
    Unregistered
    Posted 14 years ago #

    Darn! Now I have to change all my values to '<<krishna,krishna,krishna>>'

    Note to N00bies: Do NOT use Beetlejuice...

  24. DragonFlyEye
    Member
    Posted 14 years ago #

    wp-settings.php, starting at line 398:

    /**
     * It is possible to define this in wp-config.php
     * @since 1.5.0
     */
    if ( !defined('SITECOOKIEPATH') )
    	define('SITECOOKIEPATH', $current_site->path );
    
    /**
     * It is possible to define this in wp-config.php
     * @since 2.6
     */
    if ( !defined('ADMIN_COOKIE_PATH') ) {
    	if( constant( 'VHOST' ) == 'no' ) {
    		define( 'ADMIN_COOKIE_PATH', SITECOOKIEPATH );
    	} else {
    		define( 'ADMIN_COOKIE_PATH', SITECOOKIEPATH . 'wp-admin' );
    	}
    }
    
    /**
     * It is possible to define this in wp-config.php
     * @since 2.6
     */
    if ( !defined('PLUGINS_COOKIE_PATH') )
    	define( 'PLUGINS_COOKIE_PATH', preg_replace('|https?://[^/]+|i', '', WP_PLUGIN_URL)  );

    Looks to me like the problem is that the cookie paths are being declared differently and getting different results. Seems like there's something up with $current_site->path because it's those cookies that use that value that don't look right to me.

  25. DragonFlyEye
    Member
    Posted 14 years ago #

    @intheweeds ~ LOL! Awesome.

  26. donncha
    Key Master
    Posted 14 years ago #

    DragonFlyEye - it's ok that the path is "/" because you want to be able to login everywhere. I'm not sure why you can't stay logged in unfortunately.

  27. wehican
    Member
    Posted 14 years ago #

    I see you have the themes listed in multiple pages now. What is that activation screen about when changing themes?

  28. bigdadgib
    Member
    Posted 14 years ago #

    I have it up- and running.
    Just testing before I upload perm.

    You can see it at http://group.bigdadgib.net/mu/

    I cant get a new user to crate a blog that works.

    I think it has to do with my server.
    If you wish, register, try it and see if you can tell what is wrong.

  29. wehican
    Member
    Posted 14 years ago #

    Are you sure your wildcard DNS is working?

    I just tried. Filled out the first page and when it clicked it said page not found. Tried it again and it went to the second page and finished the registration. Got a confirmation email but get a can't find server error. The URL given for my blog is http://dingus.group.bigdadgib.net/mu/

    Kinda don't look right.

  30. bigdadgib
    Member
    Posted 14 years ago #

    No, i'm not sure about the DNS wildcard.
    I started a clean install again.
    This time at http://www.bigdadgib.net/mu

    It does the same thing I think...
    Something is stopping it from creating new blogs with the name before the url.

    You can try it again at the bigdadgib.net/mu but i think you will find the same problem.

    BTW... My main WP blog is at bigdadgib.net
    and the WPMU is at bigdadgib.net/mu

About this Topic

  • Started 14 years ago by donncha
  • Latest reply from billdennis5