The MU forums have moved to

Blog URL question (2 posts)

  1. mshao
    Posted 18 years ago #

    I know a lot of you have done this. The URL of a new blog could be "". But I can't get this to work. I tried to install in a directory called /blog under /public_html. The URL for a blog became "". I also tried to install it directly under /public_html and hoped to get the right URL. But I ran into an issue that said the .htaccess file already existed. But I was not able to remove the file.

    How did you install it in order to get the URL right in the format of ""?


  2. samchng
    Posted 18 years ago #

    I understand the frustration. I have been through it. :)
    I installed it in like what you did. /wpmu in /public_html. Using ITDamager's .htaccess and it worked, but there was some problems. I did some modifications and I can incorporate the default .htaccess successfully.

    I suggest you clean your entire system of WPMU and start a fresh. Delete all your files, including your .htaccess. If you can't, go to your File Manager in cpanel to delete it.
    Then install again in the format above.

    It should work, if not, then it's your Apache settings that is troubling you. Ask your admisnitrator to do this.

    Request update BIND Zone file by

    go to zone file

    add this at the end of above file
    * 14400 IN A

    restart BIND
    /etc/init.d/named restart


    Virtual Host setting for to be like this.

    DocumentRoot /home/username/public_html
    BytesLog domlogs/
    User username
    Group username
    ServerAlias *
    CustomLog domlogs/ combined

    Please restart all web services (apache) after modification.


    In addition, I would also need access to edit the httpd.conf file. As I need
    to get Apache configured so that mod_rewrite works. Here are the instructions
    1. Make sure a line like the following appears in your httpd.conf

    LoadModule rewrite_module /usr/lib/apache2/modules/

    2. In the <Directory> directive of your virtual host, look for this line

    "AllowOverride None"

    and change it to

    "AllowOverride FileInfo Options"


    VOILA!! Happy good friday! :)

About this Topic