The MU forums have moved to WordPress.org

ServerAlias ok? (3 posts)

  1. musnake
    Member
    Posted 12 years ago #

    So, after a month of my host telling me that they had setup the serveralias stuff correctly (despite my "proof"), I finally hear that it had not been setup correctly after all... A month.

    This is all very discouraging and not particularly productive.

    Fine.

    WPMu 1.3 PHP5 Apache2 cPanel

    Both plugin directories renamed.

    They tell me that the serveralias stuff looks like this:

    ServerName mydom.org
    ServerAlias *.mydom.org http://www.mydom.org mydom.org
    DocumentRoot /home/domusr/public_html

    I specifically asked them to put the wildcard serveralias first as per forum wisdom.

    The DNS zone has the wildcard enabled (* 14400 A etc)

    wp-config has define('VHOST', 'yes');

    The logs are all empty.

    I get the standard "No WPMU site defined on this host" message for blogs that I create and for blogs other than the main blog that were created before the month-long drama. The main blog works fine.

    The standard advice to new installers is to delete .htaccess, drop tables and reinstall.

    With work already invested in this project, is there an alternative route? If in the future my host does something that results in "No WPMU site defined on this host" will I have no choice but to drop the baby?

    In PHPMyAdmin, the path for all blogs in the wp_blogs table is "/"

    I can edit the blogs in the admin backend, they are all set to "Public" but I can not view them or access the backends.

    WPMu does work on this host. I was using it until things got sloppy.

    Does anyone have magic fairy dust left? Anything specific I can have them check on?

    Thanks.

  2. jamescollins
    Member
    Posted 12 years ago #

    Hi musnake,

    Can you please post your entire VirtualHost directive?

    Personally, my VirtualHost looks like this:

    <VirtualHost xxx.xxx.xxx.xxx:80>
    DocumentRoot "/home/domain.com/html"
    ServerName domain.com
    <Directory "/home/domain.com/html">
    allow from all
    Options -Indexes
    AllowOverride All
    </Directory>
    ServerAlias *.domain.com
    </VirtualHost>

    There's no need to have http://www.domain.com and domain.com in the ServerAlias line, although I don't think it would stop your WPMu install from working.

  3. musnake
    Member
    Posted 12 years ago #

    Hello James,

    Thank you for your response. Believe me, I have begged and screamed to have a copy of the VHOST settings for reference -no joy. I've had to throw chicken bones to guess at what they're set to up until yesterday.

    Anyway, after the night, all appears to be functioning normally. I do not know if this is due to my restarting my PC or if it was some stealthy thing they did or of the server flushes it's own cache/daemons etc.

    So for people reading this later, it now looks like the issues I was having where the "No wpmu site defined" error was being thrown was a result of cached erroneous settings...

    A case where if it walks like a duck and talks like a duck -it's actually Tofurkey.

About this Topic