The MU forums have moved to WordPress.org

Resolved: Unable to create directory (4 posts)

  1. demonicume
    Member
    Posted 14 years ago #

    - Is its parent directory writable by the server?

    I recently moved my subdir install to a subdomain set up. I the log of all my screw ups for another post (maybe a how-to!). But I got my site back up and functioning with the exception of an error my bloggers were getting when they attempted post images.

    Unable to create directory /var/www/.../.../public_html/wp-content/uploads//2008/05. Is its parent directory writable by the server?

    If you google this error, you'll see that it's more of a wordpress issue. I tried everything on several posts. The solution was simple, though. I'll use blog id#1 for this example.

    I renamed the blog.dir folder from '1' to '1_old' (thats in case I ever need anything from that folder. I can't imagine I will, but I might'. When that user attempted to upload a image, the directory was automatically recreated and worked fine.

    Sorry if this solution is a dupe, but I never found it, myself. I still don't know why there was a double-slash, either.

  2. andrea_r
    Moderator
    Posted 14 years ago #

    Weird bug. :-/

    Clever solution though. :D

  3. MrBrian
    Member
    Posted 14 years ago #

    It's because when the folder gets created, it gets chmoded with write permissions. Often when people migrate sites incorretly, they lose the original file permissions - hence why your blog.dir directory was probably not writable.

  4. demonicume
    Member
    Posted 14 years ago #

    thats what was tripping me out. i chmodded everything to 777 and it was still a no go. deleting the directory was the only thing I could think to do. say i moved a site again, what would be the correct way to move that directory so that I don't lose privileges?

    i should also mention that my user was unable to upload headers, either. that's what lead me here in the first place.

    thanks, Curt

About this Topic

  • Started 14 years ago by demonicume
  • Latest reply from demonicume