The MU forums have moved to

Can only create and view three new blogs, fourth fails to load (6 posts)

  1. rcwatson
    Posted 15 years ago #

    I have created three new blogs with MU:


    However, when I or anyone creates blog4.subdomain.domain.tld and above, we can't get them to appear.

    The VirtualHost entry in apache's conf/extra/http-vhosts.conf file exists for blog4 and is exactly like that of blogs 1, 2, and 3 except for its name. Everything else in the options for blog4 are set the same as 1, 2, and 3 (except the name). Finally, I was also sure to click the activation link, but even that comes up as "Server Not Found".

    Is there a default limit to the number of blogs you can create with MU? If so, how do I change it? If not, what else could be wrong here?

  2. lunabyte
    Posted 15 years ago #

    The readme file. It's not been followed properly.

    The should be no "additional vhosts" for blogs.

    It's all under one, with a wildcard ServerAlias under the main site vhost (in apache's configuration for subdomain.domain.tld).

    Also, what about the wildcard DNS entry?

  3. rcwatson
    Posted 15 years ago #

    Thanks. I'm not in charge of our DNS entries. Can you give me an example of what that should look like?

    So, for vhosts, the following entry is all that I should need, right?

    <VirtualHost XX.XXX.XX.XX:80>


    DocumentRoot /path/to/wordpress

    DirectoryIndex index.htm index.html index.php

    ServerName *.subdomain.domain.tld

    ErrorLog /path/to/logs/wordpressmu-error_log

    CustomLog /path/to/logs/wordpressmu-access_log custom

    <Directory "/path/to/wordpress">

    Options All

    Order allow,deny

    Allow from all


    <IfModule dir_module>

    DirectoryIndex index.html index.cfm index.htm



  4. lunabyte
    Posted 15 years ago #

    ServerName *.subdomain.domain.tld


    ServerName subdomain.domain.tld
    ServerAlias *.subdomain.domain.tld


  5. rcwatson
    Posted 15 years ago #

    Thanks. What about the correct syntax and placement of the DNS entry to make this work? Sorry, but I need to be able to communicate that to the IT team in charge of the DNS server.

    Thanks again!

  6. lunabyte
    Posted 15 years ago #

    Tell them to add the following A record: *.subdomain.domain.tld. and point it to the right IP address.

About this Topic

  • Started 15 years ago by rcwatson
  • Latest reply from lunabyte