The MU forums have moved to WordPress.org

dns, apache & wildcard problem (2 posts)

  1. blogono
    Member
    Posted 14 years ago #

    hi there,
    i am moving from one vps to another, because i cant get my subdomains to work correctly. i hope that somebody in the wpmu-family can help me out.

    last week i have moved from my old host to another, and got the main wpmu site working correctly. you can access http://blogono.com and login, and even create new blogs.

    but when i try to access any blog-url or subdomain-url, it will give me an error-msg, although i have setup wildcard domains.

    in cPanel/WHM -> dns zone looks like this ...

    http://img410.imageshack.us/img410/5712/dnsblogonosj6.jpg

    .
    .
    .
    .
    .
    .
    .

    in /etc/httpd/conf/httpd.conf i edited ...

    .
    .
    .
    .
    .
    .
    .

    <VirtualHost 208.89.218.244:80>
    ServerName server.blogono.com
    DocumentRoot /usr/local/apache/htdocs
    ServerAdmin somebody@gmail.com
    </VirtualHost>

    # Default vhost for unbound IPs

    <VirtualHost *>
    ServerName server.blogono.com
    DocumentRoot /usr/local/apache/htdocs
    ServerAdmin somebody@gmail.com
    </VirtualHost>

    # DO NOT EDIT. AUTOMATICALLY GENERATED. IF YOU NEED TO MAKE A CHANGE PLEASE USE THE INCLUDE FILES.

    <VirtualHost 208.89.218.244:80>
    ServerName blogono.com
    ServerAlias blogono.com *.blogono.com
    DocumentRoot /home/blogono/public_html
    ServerAdmin email@domain.com
    UseCanonicalName Off
    CustomLog /usr/local/apache/domlogs/blogono.com combined
    CustomLog /usr/local/apache/domlogs/blogono.com-bytes_log "%{%s}t %I .\n%{%s}t %O ."
    ## User blogono # Needed for Cpanel::ApacheConf
    <IfModule !mod_disable_suexec.c>
    SuexecUserGroup blogono blogono
    </IfModule>
    ScriptAlias /cgi-bin/ /home/blogono/public_html/cgi-bin/

    # To customize this VirtualHost use an include file at the following location
    # Include "/usr/local/apache/conf/userdata/std/2/blogono/blogono.com/*.conf"

    </VirtualHost>

    .
    .
    .

    # CPANEL/WHM/WEBMAIL/WEBDISK PROXY SUBDOMAINS
    <VirtualHost 208.89.218.244:80 *>
    ServerName server.blogono.com
    ServerAlias cpanel.* whm.* webmail.* webdisk.*
    DocumentRoot /usr/local/apache/htdocs
    ServerAdmin somebody@gmail.com
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^cpanel\.
    RewriteRule ^/(.*) http://127.0.0.1:2082/$1 [P]
    RewriteCond %{HTTP_HOST} ^webmail\.
    RewriteRule ^/(.*) http://127.0.0.1:2095/$1 [P]
    RewriteCond %{HTTP_HOST} ^whm\.
    RewriteRule ^/(.*) http://127.0.0.1:2086/$1 [P]
    RewriteCond %{HTTP_HOST} ^webdisk\.
    RewriteRule ^/(.*) http://127.0.0.1:2077/$1 [P]
    UseCanonicalName Off
    </VirtualHost>

    .
    .
    .
    .
    .
    .
    .

    then, i entered ...

    service httpd restart

    in winscp to restart apache.

    .
    .
    .
    .
    .
    .
    .

    my htacess:

    .
    .
    .

    RewriteEngine On
    RewriteBase /

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    .
    .
    .
    .
    additional info ...

    in cpanel/whm, in restart services, when i try -> DNS Server (BIND) -> Restarting Bind

    .
    .

    i get ...

    .

    Attempting to restart named
    Waiting for named to restart.... . . . . . . . . . . finished.

    named status

    named is disabled

    Service: [named] has been disabled by the sys admin

    .
    .

    could the problem be caused by this?

    .
    .

    i still can not access any subdomain or blog-urls

    eg
    http://candy.blogono.com

  2. blogono
    Member
    Posted 14 years ago #

    somehow i got it to work now, dont know if the dns-edits need some propagandation time or the "reload rndc" caused that.

    however, i am very happy that the site is running again.

About this Topic