The MU forums have moved to WordPress.org

Unable to add/specify images in Hamasaki 1.2 (8 posts)

  1. jonwalkers
    Member
    Posted 12 years ago #

    Hi

    I'm currently looking into using the Hamasaki 1.2 theme (http://www.jauhari.net/themes/hamasaki)

    I would like to take advantage of where you can add your own images to posts, in order for them to appear next to the main posts, but I don't know how to do this?

    Any help would be appreciated. FYI, the website is http://www.freesoccerpics.tv

  2. musnake
    Member
    Posted 12 years ago #

    Post smells spammy.

    Line 99 of the index.php:
    $cats_on_featured = 'cat='. get_settings('hamasaki_featuredcats');

    indicates that there are theme options to configure under the 'Design' admin menu option. It looks like you'll be able to specify the category ID number for the category 'Featured' that you may need to create to use this theme...

  3. jonwalkers
    Member
    Posted 12 years ago #

    many thanks for the reply - i assure you its not spammy..I'm genuinley having difficulties and thought that posting the two urls may be helpful?

    There doesn't appear to be an option to do that, I was thinking perhaps there is a standard method used in wordpress for this feature, perhaps using custom fields maybe?

  4. andrea_r
    Moderator
    Posted 12 years ago #

    Are you using single-user wordpress? If so, wrong forum. This is for multi-user WP.
    Also, have you asked the theme author? If it's looking for a specific category, you may have to edit the theme.

  5. musnake
    Member
    Posted 12 years ago #

    Yet another recent example of how I do not read people's posts :)

    Design/Hamasaki Options

    I see what you mean about there not being an option besides specifying which category shows up on the bottom...

    I have misunderstood what you mean by the images appear(ing) next to the main posts...

    If you mean post thumbnails next to the post excerpts displayed under the first 'Featured' post, then this theme does not do that. It only displays thumbs for the 'bottom' category and an image for the first featured post at the top.

    Do you possibly mean the 'Ad Place' areas?

  6. jonwalkers
    Member
    Posted 12 years ago #

    Hi musnake

    Yes im referring to the post thumbnails...I can't see where or how I am able to specify an image to appear where it is currently showing "no image".

    I can edit the "ad place" areas no problem at all.

    I thought perhaps it would be a custom field to sort this, but doesn't appear to work?

  7. musnake
    Member
    Posted 12 years ago #

    Hmm, I deleted the theme... let me ask a few Q's before I reinstall it.

    So, we're on the same page that this theme does not display post thumbnails on the main page (take a look at the code for the index.php and you'll see it displays only the excerpt)?

    "no image" sounds familiar, let's see: Hamachi/index.php line 19:

    <?php if($image_src != '') { echo $image_src; } else { ?><?php bloginfo('template_directory'); ?>/images/no-img.gif

    So if the code searches the post ($content) and does not find an img tag it will display the default "no image" image found here: themes/hamachi/images/no-img.gif

    If you wanted to display a different image in that case (no image tag found in $content) then you would replace the file no-img.gif with the one you want to use (using the same name and dimensions), but I suspect you know that...

    Hold on, let me install it and check something...

  8. musnake
    Member
    Posted 12 years ago #

    Yeah, it works just fine for remote images too.

    For this theme, the key is that the link to the image must be an <img> tag. If you insert an <a> tag with a URI to the image, it will not find what it is looking for and then display the "no image" graphic...

    So, in your post content, try switching to HTML mode when you're editing and insert a link to an image (remote or local) wrapped with <img>

    Check the permissions on the directories and files in your theme (especially the image folder too)

About this Topic

  • Started 12 years ago by jonwalkers
  • Latest reply from musnake