The MU forums have moved to WordPress.org

Blank screen of death after upgrade (7 posts)

  1. jlawrie
    Member
    Posted 11 years ago #

    Hi,

    Firstly let me just say I've trawled this forum for hours trying every suggestion I found.

    I have a wordpress mu installation with about 2000 blogs as subdomains on them, and a few of the blogs will return a blank screen - as far as I can tell it is only the main page of subdomain blogs that are affected.

    Here is what I've tried:
    - Removing whitespace from the end of wp-config.php
    - Increasing allocated memory in php.ini
    - Deleting/Inserting/Overwriting/Creating .htaccess
    - Repairing the mysql tables in the database
    - Deleting everything, downloading the newest version, installing the newest version to a new database and finally pointing wp-config.php back to the original database,
    - Database upgrade via the wordpress->admin->upgrade section.

    I'm really at a loose end here so any help is really appreciated.

  2. andrea_r
    Moderator
    Posted 11 years ago #

    If it's a blank white screen of death, then it's an error. 9 times out of ten, it's a plugin's fault. Go into these blogs and turn off whatever plugins they have on, see if that helps.

    I noticed that's the only thing you didn't try. :D

    Could be a theme too - do they all use a similar theme?

    Also, check your old config file against the latest one - there's more stuff in there. And the htaccess file.

  3. lunabyte
    Member
    Posted 11 years ago #

    And the server error logs. :)

  4. jlawrie
    Member
    Posted 11 years ago #

    Thanks for the help.
    It turns out the problem was the opposite of your suggestion andrea_r - the blogs that weren't loading were trying to load a template that was no longer installed. Copying the templates across didn't solve the issue, but clicking on "default theme" and confirming for each blog (even though it already thought it was on default theme) and then refreshing solved the issue.
    There has got to be a better way of doing this - I tried via mysql with
    UPDATE wp_xx_options SET option_value='default' WHERE option_name='template';
    Made the site visible, but the template wasn't found - it just showed html.

    You'd think wordpress would default if it didn't find a theme!

  5. dgilmour
    Member
    Posted 11 years ago #

    If turning off the plugins they have on, as Andrea suggests, doesn't help, you could also try disabling any site-wide plugins in /mu-plugins.

  6. andrea_r
    Moderator
    Posted 11 years ago #

    WP is supposed to default if it doesn't find the right theme. Was the default theme disabled under site Admin -> Themes?

    (I have run into that issue before...)

  7. lmneditor
    Member
    Posted 10 years ago #

    More on the WSOD issue: LIkewise trying to upgrade from 1.11.
    a.)Cleared newline characters from config.php, used samples, tweaked per version.
    b.)Repaired DBs. (Also, ran Auto Upgrade on DBs)
    c.)No plugins are installed at all.
    d.)Theme is default, sitewide.
    e.)Can't change php.ini, on host, however.
    f.)Can't access Apache error logs on host, either.
    g.)Can't activate DEFINE(wp-bug) or other error-echoing code.

    Initially, upgrades were successful ->1.25a -> 1.33, then failed at backup 1.51, failed at backup 1.33 and backup 1.25a thereafter. Only 1.11 is running now on backup db.

    Finally, one blog does not appear on the default frontpage of other blogs.

    I find no other suggestions; any more to offer?

About this Topic

  • Started 11 years ago by jlawrie
  • Latest reply from lmneditor